电话语音系统的访问结构

www.TeleLink.com.cn

AG32 ® 电脑语音广场 ® 语音呼叫系统生成器 应用例子 简要说明

AG32 电话语音系统应用平台包含了 GUI 电话流程编辑环境，语音通讯管理服务器，AG32 集成工作室（流程载入备份管理工具，传真管理工具，实用系统模拟器，信号侦测工具，语音管理工具等）；AG32 可使各个技术层次的程序员或应用级人员能够快速部署即使最复杂的电话语音应用方案，过去得花高级程序员几周甚至几月时间才能创建的应用程序，现在一般应用人员只要几小时或几天就足够了；而且由于AG32 的多年稳定性检测，维护的方便性，更免去了客户的后顾之忧，应用成本大大降低。具有内建数据库及访问能力，可与外部程序连接，传真发送与接收，语音播放与录制，支持WAV文件格式;程序执行与监控等功能。

电话语音系统的访问：

当用户的电话接入时，语音系统提供语音导航提示，引导用户选择服务内容，并接收用户在电话拨号键盘上输入的信息；实现对计算机数据库等信息资料的交互访问，和与电话网络的交互访问。

AG32 语音系统产生器元件的补充说明

AG32 有17个功能元件按对语音卡操作方面分为：

1、基本元件 [AG32 2.x 以前版本]

语音：语音播放、语音录音、文字播放、多方会谈、信箱操作

传真：传真发送、传真接收

接收按键：按键输入元件

电话：电话转接、外拨电话

2、增补元件 [AG32 3.x 版本]

坐席转接、数据库操作、物件指定、物件比较、邮件接收、邮件发送

一、17个功能元件所共有的事件

二、按键输入元件详细介绍

三、数据库操作元件详细介绍

四、物件指定元件详细介绍

五、各元件之间的关联

六、元件中容易出现的错误


共有的事件

用户会发现在所有的元件，其中 程序1与挂断/特殊音 都是一样的！我们称为基本元件单元

程序1与挂断/特殊音是在系统产生器中17个功能元件所共有的事件

程序1：

是否计时： [在系统内用的不多]

[计时规定选项]中设定进入元件后，即在元件里面自行执行回路的工作，直到计时条件选项的时间到或挂断为止，其中时间可由三种方式规定

  1. INTERVAL(n).TXT：内容仅含一组数字，在物件指定元件或外部程序中设定，例如：100，单位是秒

  2. 变数：物件指定元件中赋值或在指定变量中直接设定

  3. 固定的时间:可在物件指定元件中设定或由外部程序提供。

[记录计时时间]当进入元件时，立即将此时的时间记录到TIME(n).TXT 里面。也可将计时时间到结束时间设定给字串变量。

[判别计时结束]即进入此元件时，立即判别结束的时间是否已到，判断方式为系统以目前的时间与TIME(n).TXT之开始时间的时间差是否已经超过设定之时间，此时间可以是固定时间或INTERVAL(n).TXT提供。可以将计时时间的结束时间设定给字串变量。当判别到达结束时间后可执行别的元件功能。

是否计数：[经常用在需要限制用户输入次数的应用中]

例如：在 50AP 的 医疗保险 ：的1000 和1003 元件]

表示元件启用计数功能，可设定重复元件回路次数。必须是两个元件配合使用，一个元件设定回路的次数，另一个元件则设定当次数减到0时所执行的元件代号。

指定变数：其中提供了30个变数（V1-30），可用于存取数据库时，或传递数据时使用

将系统时间、系统日期、唯一值（可用于记录一个临时的留言文件）、通道号码在进入此元件前或进入元件后指定给变量。可将型态为数值的变量作递增或递减、可将来电号码指定给变量、将软件产生器执行文件所在的路径指定给变量。[变数与变量为同样的意义]

播放语音功能：

表示在执行该元件的元件功能前先播放语音文件。语音文档名由三种提供方式：

1. Vmslink(n).txt：文档的来源由物件指定中设定或外部程序2种方式

2. 变数：在物件指定元件中设定的，设定型态为’文字’给变量，语音文件的格式例如：c:\xx\y.wav ‘xx’为存放语音文件的目录、’y’为语音文件名、’wav’语音文件的播放格式 [此种方式设定类似 文字播放元件]

3. 固定语音：写入语音的路径及文档名

挂断/特殊音 设定：

系统侦测到挂断/特殊音是的处理状态，通过侦测到的挂断音/特殊音可忽略、挂断或改变语音流程，如侦测到是传真机之应答声时间可进入到接收传真元件。


按键输入元件

按键输入元件： 在所有的语音系统中，此元件必不可少；他作为主要的语音流程中的结点，连接各种功能模块。是判断一个语音平台优劣的试金石。 详细的应用请参考50AP\综合举例 或 50AP\简单查询系统

其功能是将电话按键的输入值存成文字文件或者变量等，按键输入元件可以说是这17个元件中的头节点，接收或记录用户的一个或多个按键值并根据按键数值跑到对应的元件。可跳到17个功能元件中的任一种。按键输入元件加语音播放元件再按键输入、语音播放元件…可无限止的循环的IVR系统。程序1执行完到程序2，程序2的设定的功能执行完到程序3，程序1中[招呼语选项]可启用或不启用。

程序2中[招呼语选项]有三种选项：

1:招呼语根据DENTRY(n).TXT设定 ，N代表第几条线路所要播放的语音；

语音文件名在DENTRY(n).TXT中，DENTRY(n).TXT文件可由语音产生器中的物件指定元件写入、也可由外部程序连接元件产生。DENTRY(n).TXT各栏内容语法说明与文字播放元件中的设定

2: 招呼语固定由GREET(N).GRT提供，N代表第几个语音文件；

语音文件为固定文件名GREET(n).GRT语音文件，存放在其相对应元件‘xxx.box’ 文档中,xxx为元件代号

3:招呼语由变数提供，一般不用；

招呼语语音文件，路径文件名由已设定之字串变量提供。格式同程序1中的[招呼语由变数提供]

[系统播放语音且同时接受按键]：

按键值指定给变量：此项选中时，可将所按键之按键值指定给变量，由变量指定中根据播放语音个数设定变量，
最多同时可以设定5个变量，变量型态为字串。

变量的输入顺序根据greet(n).grt的播放顺序。播放greet1.grt 时输入的是第一个变量、播放greet2.grt时输入的是第二个变量、依次类推、、、

「按键最大长度」根据电话按键最多可按几个键设定的。

[播放语音个数]：

’n’ 表示播放的第几个语音、播放语音个数可设1-5个，播放语音个数由「播放语音个数」规定例如设成5，「播放语音个数」设定为5。则播放顺序为：

1 播放第1个语音文件 greet1.grt

2 播放第2个语音文件 greet2.grt

依次类推、、、

[错误重试次数]

电话重新输入次数，播放语音（招呼语）GREET（n）．GRT时即可接受按键，一直到播完招呼语之后3秒(时间由「等待输入按键时间」设定等待输入电话按键)内仍接受按键，若未按键则请重新输入

[是否要确认]

要不要确认电话所按键的内容，如果设成要确认，则接受电话按键后要求确认（需自行录制确认语音，具体见说明文档：AG32.CHM,或说明书）

[未达最大按键长度，前补0]
表示接收按键长度若为5，但使用者输入4码，则会在最前面补0，变为5码。例如：按键最大长度设定为5，用户输入1234时，则统计的按键不是1234、而变成了01234

[根据INFORM.TXT内容播放语音] ：参考<简单查询系统>

依据按键值到INFORM．TXT去寻找相对应的语音文件播放
（此功能必须打√，编辑INFORM．TXT钮才能使用）。
INFORM．TXT格式：[按键1，按键2，对应的语音文件1，
对应的语音文件2，．．．．]电话按键数目依照[播放语音个数]设定。
例如[播放语音个数]设定＝1，INFORM．TXT内容为：1，weather.wav表示当电话按键为1，则播放weather.wav语音。例如：若[播放语音个数]设定＝2，INFORM．TXT内容为：234，567，weather.wav表示当电话第1次按键为234且第2次按键为567，则播放weather.wav语音

[程序2]中的<根据INFORM.TXT内容播放语音>和[程序3]中的<执行完按键>详细功能请参考例子50AP\综合举例或50AP\简单查询系统说明。


数据库操作元件的详细介绍

数据库操作元件的特别介绍：

功能：一般根据按键输入的值查询相关的数据库表的信息

[程序2]查询中的连结中的选项在　语音系统产生器中 [设定]下的[数据库设定]事先设定好要使用到的数据源名称和连接名称

主要动作为两个：1：查询 2：动作 3:联结 [一般不用]

查询： 可以为大部分的标准 SQL 语句，可以为查询SELECT，增加 INSERT，修改 UPDATE

例：[select * from products where 序列号 ='%%v1%%'] [v1为一个变量，%%为分隔符]

指定给资料表：共有20个资料表可供设定，将查询出之资料集存放在资料表中，其实是相当于放入缓存中，给物件指定元件使用。

动作：[移动指标至]有4个选项,选中某个资料表(table),将查询的全部数据集指向最上笔(第一条数据)、最下笔(最后一条数据)、上一笔（移动table表中数据的上一条数据）、下一笔（移动table表中数据的下一条数据）

[程序3]

若为BOF跳到XX元件中的BOF是当移动数据到最上笔数据时跳到XX元件

若为EOF跳到XX元件中的EOF是当移动数据到最上笔数据时跳到XX元件


物件指定元件详细介绍

物件指定元件详细介绍 [以下变量即为变数]

功能：

物件指定相当于赋值，对变量赋值、写文件等
型态： 是欲指定给变量的型态，一共有6种可供选择：

              1、总笔数 2、栏位 3、常量 4、变数 5、文字 6、档案

      栏位是数据库表中的字段名；总笔数是select语句所查询到的记录数

      型态2：为‘栏位’只能指定给(v1~30)的变量，是将XX表中YY字段内容取出，并且指定赋值给变量参数。

      常用到的型态有2、5、6

      型态5： 为‘文字’可指定的变量为‘31、档案’、‘v1~v30变量’；在“编辑文字文件”按键进入编辑，在档案的设定中有两种格式：

      1、编写到固定的文本文件，供其他元件或外部程序使用，固定的文本文件存放目录在‘语音系统产生器’中[设定]〉[其他设定]>[外部程序沟通]中设定

      2、固定文本文件有7种文件格式

可直接设定文本文件的存储路径,存放固定目录下的的文本文件名可用

变量设定，可设定[程序1]中变量设定将唯一值设定某个变量 例如：给

变量1(v1)，在此就可写为c:\wav\%%v1%%.txt,在存放留言、接收传真

时时经常用到的；

型态6：档案 仅能指定给 ‘32 变数’，一般由外部程序生成给AG32用。


各元件之间的关联

1、一个简单的查询，一般用到 按键输入元件、数据库操作元件、物件指定元件、

文字播放元件、语音播放元件 这5个元件

2、按键输入元件直接将按键值指定给变量，数据库操作中将此变量作为查询数

据的条件，将查询的资料集存放在table表中，物件指定元件中‘型态’为‘栏 位’

是将 table 表中的字段名赋给变量(v1~30)。将变量内容写入到固定的文本文中

例如：写入到voice(n).txt中内容，可供文字播放元件使用

写入到vmslink(n).txt中内容，供外部程序或其他元件使用，如语音信箱，传真收发等

元件中的招呼语可用vmslink(n).txt内容

写入到Dentry(n).txt中，供按键输入元件中[程序2]播放招呼Dentry(n).txt

等等…..

3、按键输入元件的按键值可直接写入到vmslink(n).txt文本中，供外部程序连结元件使用


各元件容易出现的错误

按键输入元件：

有greet1.grt文件但是没有播放:

1. 是greet1.grt录制的语音文件的格式不正确

2. 或 greet1.grt带隐藏后缀,应该录制的音频格式为：

PCM 8 Hz,　8 位, 单声道

3. 语音1的按键长度设定为0了，应改为1或别的

有greet1.grt和greet2.grt两个语音文件但只播放greet1.grt 没有播放greet2.grt;‘播放语音个数’应设定为2

录制了greet.grt，而没有录制greet1.grt

数据库操作元件：

      １：查看《控制面板》32 ODBC中数据源是否设定了数据源

      ２：在语音监视程序中出现‘Error:General SQL error．．’或类似其他错误

       查看设定’中‘数据库设定’是否正确:在查询表达式中语法错误

  文字播放元件：

    １：在语音侦测中出现‘转语音档错误‘：是voice(n).txt文本的格式出现错误

  物件指定元件：

    １：型态为‘栏位‘指定给变量v1，但没有将内容指定变量v1

检查‘栏位‘（字段名）书写是否正确


外部程序开放性

AG32 的开放性 和 与外部程序连接说明

AG32语音生成器是一个开放式的语音生成平台，它可以与任何外部程序配合执行，可以由外部程序去控制语音系统的流程走向，而应用程序开发者无需去了解语音卡的硬件操作。即可设计出一套专业的电话语音系统。

AG32由多个元件模块组成，每个模块都是一个子程序，模块的功能参数设定简易
，模块之间都有功能完成后走向的设定，例如，按键输入元件完成后走到数据库操作元件。
AG32的开放式集中体现在(程序连接元件)，当AG32程序执行到此功能元件时，一般系统立即产生二个文件，它们是REQ(N).TXT、EXEREQ(n).TXT,其中N代表语音卡的第几线，REQ是一个空文件，用来通知您的应用程序执行操作，EXEREQ内含有需要执行操作的内容代码，例如内容为（420，c:\path,2003/12/18 pm 12:18:18）
其中420为可定义的程序运行某种操作的识别代码；后面为目录和时间。

这个功能元件有二个出口，一个是等待时间，如果外部程序在一定的时间内没有回应；另一个是外部程序发出的回应，即产生一个回应文件EXEACK(n).TXT，可以是一个空文件，AG32在等待时间内发现此文件，会立即删除此文件，并根据GOTOBOX(n).TXT内设定的元件内容走到此元件去执行；所以外部程序在生成EXEACK(n).TXT之前还必须生成GOTOBOX(n).TXT和一些必要的文件，比如VOICE(n).TXT(此文件用来组织放音的信息)，VMSLINK(n).TXT，DIAL.TXT(让AG32自动往外拨号)等；

所以外部程序与AG32沟通需要如下动作：为了实时监视REQ(n).TXT，一般程序采用一个TIMER计时器，执行操作如下：
[
IF FileExists(req[i].TXT)
then
//读取文件exereq[i].TXT内容给字符串ls_Emp_exereq[i]
//读取文件VMSLINK[i].TXT内容,此文件内一般含有来电者的按键内容
//删除文件exereq[i].TXT，req[i].txt，如不删除您的时钟将重复操作

filedelete(exereq[i].txt)
filedelete(req[i].txt)
//执行您的程序操作，例如对数据库进行操作，获取必要的数据信息
{
...........
}
//务必请生成如下两个文件 GOTOBOX(n).TXT，EXEACK(n).TXT和一些所需其它文件，比如VOICE(n).TXT(此文件用来组织放音的信息)，VMSLINK(n).TXT，DIAL.TXT(让AG32自动往外拨号)等；

请注意EXEACK(n).TXT必须最后生成。
]
到此一次沟通完成。
利用循环语句完成多线路的处理

这是一种利用文本实现沟通的最简易的方法，适合任何程序；当然AG32也提供动态连接库(DLL)的沟通方式更有效率。但是对一般的应用，文本字符串沟通的方式最实用和简易。DLL方式在此不做说明，请电话咨询。

现在，对某些呼叫中心应用，AG32 也开放windows socket 端口，以使用户程序实时了解线路状况并采取相应的操作，如当坐席分机振铃时，用户程序可以收到信息，以便及时调出客户服务资料等应用；同时也提供基于soap 的webservice 信息访问！


企业IP PBX 及一体化通信呼叫中心平台

北京天羚季德科技有限责任公司长期从事CTI（计算机通讯集成）技术研究、开发和应用集成；能够为呼叫中心系统应用客户、集成商和应用软件开发商提供包括语音板卡、CTI 中间件平台、可视化IVR编程平台、桌面电话应用软件、呼叫管理监控软件、录音系统、中文语音系统等呼叫中心应用产品。

天羚从中国的国情出发，多年对语音呼叫中心市场的深刻认识，在中国努力普及呼叫中心应用，为广大系统集成商和应用软件开发商提供稳定、低价位、高效率的简易语音呼叫中心平台解决方案和呼叫中心相关设备，使广大中小型企业也能建立一个基于先进的平台、与办公通讯相结合的呼叫中心【实现语音、传真、电话通信、CRM 的有效结合】

天羚 AG32 电话语音呼叫中心应用平台包含了 GUI 电话流程编辑环境，语音通讯管理服务器，AG32 集成工作室（软件产生器,通信服务器，流程载入备份管理工具，传真管理工具，实用系统模拟器，信号侦测工具，语音管理工具等）；AG32 可使各个技术层次的程序员或应用级人员能够快速部署即使最复杂的电话语音应用方案；而且由于AG32 的多年稳定性检测，维护的方便性，更免去了客户的后顾之忧，应用成本大大降低

一般客户需求：

    具普通PBX[电话交换机]的功能

兼具呼叫语音导航，可按键选择服务，获得来电者号码；可根据策略进行号码识别与条件接入、转接；能实现客户自助数据查询服务【IVR】等

服务器要求：

1：处理来自外部与内部电话及其他呼叫请求

2：分机座席及权限管理

3：信息传递管理 [数据信息-语音信息-传真信息-邮件信息]

4：数据统计

5：部门、资源管理及提供CRM接口

客户端要求：

1：可接听来话，弹出客户资料信息，并进行相应的处理

2：可查询个人语音留言及录音记录，查看传真信息

3：可执行分机软电话功能【设定本机状态，电话保持/恢复/转接，邀请三方通话等】

4：可外呼、回呼电话和发送单个、批量传真

5：可处理相关客户多种工作单业务员如咨询、投诉、订单等

一般功能实现：

  1： 语音导航流程的建立： AG32 为类似系统提供简易的流程样例，部分图示如下：

主要使用元件：语音播放元件、按键输入元件、物件指定元件、语音录制元件、数据库操作元件、电话转接元件。

转接前的数据库操作主要结合客户自定义的数据库，在转接前判断客户端是否登录，决定转接方向，记录相应过程的信息。

客户端可以通过各种接口随时侦测AG32 服务程序发送的信息，来作相应的处理

对某些呼叫中心应用，AG32 开放各种接口如：Windows Socket 端口，以使客户程序能实时获取线路状况并采取相应的操作，

如当坐席分机振铃时，用户程序可以收到信息，以便及时调出客户服务资料等应用；

同时也提供基于Soap 的WebService 信息访问接口！　具体请咨询天羚。【方便开发人员尽快实施应用是我们的宗旨】

2：客户端软件实现

集成商或者被委托开发者只需选择一种所提供的接口，来实现与AG32 服务器的沟通，最主要的就是即时获取本坐席的来电信息

简易图例如下：【当获取到本机振铃信号，调取数据库信息，执行相应的工作】

相关应用事例图例：

3： 统计功能

许多呼叫中心需要的就是相关信息的统计功能，如客户来电次数，来电时段，关心内容等等，以供领导层决策

简易来电次数统计图如下：


使用语音、传真范例

应用范例:

AG32 电脑语音广场软件包含各类语音、传真应用范例，这些应用范例全部由语音软件生成器架构生成，基本的流程架构可供使用者参考。在实际的应用中，您必须考虑各种使用情況，修改语音软件生成器架构及设定，必要时再配合外部程序，即可架构出各种多线电话语音传真应用，每一個应用范例都有其测试编号(即起始元件号码)，使用者可根据测试编号模拟它的语音或传真功能，也可以利用语音软件生成器修改架构，以生成不同的流程，符合实务的需要。

天羚公司为您收集了许多应用，在光盘的\50ap 目录下，在每个子目录下，都存在类似flow的应答流程例子，您可使用《电话语音载入程序》直接载入到一个您喜欢的目录，然后使用《语音软件生成器》〉文件〉更改电话流程：打开您刚才导入的目录； 您就可以看到流程的例子。您也可以直接复制一个流程到您喜欢的目录，但此时的文件夹是只读的，请更改属性，方可利用《语音软件生成器》修改流程。

退出其他程序，执行主运行程序《电话语音管理程序》，电话打入就可听到应答了。如接听又挂断了，代表《电话语音管理程序》包含的<电话设定>内设定的元件不存在或错误。其他可能有一些语音文件不存在，例如例程需要一些语音在d:\voice 没有复制或录制；可打开《电话监视程序》〉打开一个通道〉观察在播放哪个语音文件，如不存在，则录制。


Samples 流程的详细说明

电话应答流程的说明 [50AP 中的流程都可以使用电话语音载入程序指向相应目录载入]

1: 使用电话语音载入程序，指向 [50AP]\综合举例\ 目录，载入到您需要的目录。

2: 设定用户数据库DSN 参考 DATABASESET.BMP，COPY TELE.MDB 到C：\ path

3: 打开语音软件生成器，指向您需要指向的目录，参考设定

4: 您可打开电话监视程序的某通道，观察。读懂本例子，您就基本了解和掌握AG32了；谢谢

5: 基本上每一个例子都附带一个例子数据库，请设定相关联结[ODBC DSN]；

北京天羚公司 www.telelink.com.cn

1．语音系统产生器图片

元件代号 总体叙述

1000 语音流程进入点、播放导航语

1100~1104 产品咨询的内容

1200~2003 产品价格

2004~2025 订购产品

2100 留言

介绍按键输入元件的主要功能

其功能是将电话按键的输入值存成文字文件或者变量等，按键输入元件可以说是这17个元件中的头节点， 接收或记录用户的按键值并根据按键数值跑到对应的元件。可跳到17个功能元件中的任一种。按键输入元件加语音播放元件再按键输入、语音播放元件…可无限止的循环的IVR系统。

按完电话按键后会跑到那个元件，可依据以下3种设定：

①依据电话按键，执行对应之元件

是根据电话按键输入元件代号，跑到所对应的元件

例如：1100元件用的此项设定 :如电话按1100键，会跑到1100元件

②依据按键表，执行对应之元件

选取根据按键表GOTOBOX.TXT，跳到对应的元件，此时编辑按键表才能使用

例如：1000元件[程序3]中的选中<依据按键表，执行对应之元件>后点击编辑

按键表。显示内容是：

1,1100

2,1200

3,2004

4,3000

说明：按1跑到1100元件、按2跑到1200、按3跑到2004元件、按4跑到3000元件

③ 依据按键值，执行对应之元件 [也例如50A内的<简单查询系统>的1000 元件的 应用]

可根据按键值对照表，跳到所对应号码的那个元件执行。

[是否为特殊键] ！，这也是AG32 比较特殊的地方，这样就解决了接收不同长度按键问题

判断一个固定的快速键，对于此类可立即执行，不需等待下一个按键值输入 ：

例如： 在一个简单企业应用：“您好，天羚公司，请直拨分机号码，或直接按1 转总机，按2转业务”等

例如：1200元件程序3中的按键值1、2、3会立即跳到相对应的元件1201、1202、1203 ，而无须等到等待时间到才反应。[等待时间是接收一个按键所需要等的时间，时间超过，就算没有收到]

按键值为 “ 其它”是有别于定义的例如特殊按键的其他值，例如直接输入的产品代号、例如输入8000按#键结束，跳到元件2001 进行数据库查询，然后播放相关的报价。

在2010元件中播放输入产品代号按#号键、输入订购数量按#号键。

2015元件先判断输入的产品代号是否存在， 如果存在跳到2018元件（提取库存量、产品名称、单价）再到2020元件做库存量和订购的数量比较，库存量大于订购数量跳到2021元件（修改数据库的库存量）再到2022元件（向定单表中添加新记录， 库存量小于订购数量跳到2025元件播放语音。不存在跳到2019元件播放“输入的产品代号不存在”。

具体打电话流程图：


一般的语音查询应用

<电脑语音广场> 一般的简单查询 系统应用

查询的信息变动较少的语音信息查询的运用，不须要写程序，使用按键输入元件，设定根据INFORM.TXT内容播放语音，根据来电者在电话上所按的数字，依照INFORM.TXT各种语音信息播放，准备INFORM.TXT语音信息对照表即可。例如：语音信息查询服务、张老师讲故事、张老师讲笑话、股市电话分析、联考放榜电话语音查询、电话测试、汽车拖吊电话语音查询、汽车遗失电话语音查询、汽车修护状況电话语音查询、电影内容语音查询和电视节目内容语音查询等等。

本节使用按键输入元件(提供语音信息查询的语音信息)与设定循环回路(提供信息可查询的次数)箱，架构电话语音查询系统，以下以语音信息查询服务为例子，说明如下:

执行【语音软件生成器】，用鼠标在左边显示的元件(语音元件一览表)选元件1100(即语音信息查询服务的起始元件号码)，再在【系统设定】中选【设定为接电话元件】后，自动显示树状结构图，关闭语音软件生成器，并执行【语音管理程序】中的【线上模拟】，即可模拟语音信息查询功能。

<树状图和所用元件表>

<各元件功能>

元件 1100、1104：循环回路，提供语音信息查询的次数。每一个循环回路，含循环回路的起始、继续和结束等三个元件。

元件1102: 提供语音信息查询的语音信息。

1.循环回路的起始: 元件 1100用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件1100后，按鼠标二下，核取是否计数，按【设定】按键，即可看到设定:

    • 设定为起始循环回路，设定为【取用一个新计数器】，【起始值】=1， 经此循环回路元件后，跑到步骤三元件号码1102执行。

    2.循环回路的继续: 元件 1104

    用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件1104后，按鼠标二下，进入功能设定做功能设定，核取【是否计数】，按【设定】按键，即可看到应答功能设定:

    •

    设定为【下一轮】，每次经此元件后，循环次数减一，若循环次数=0，经此循环回路元件后，跑到元件号码90去执行： 若循环次数 >0， 经此循环回路元件后， 跑到步骤三元件号码1102去执行。

    3.元件 1102: 按键输入元件

    元件 1102 提供语音信息查询的语音信息，来电者在电话输入查询代号，根据 C:\AG32\Tools\1102.BOX\INFORM.TXT ，播放语音信息，可用任何文书处理软件或使用程序语言准备INFORM.TXT。以下为C:\AG32\TOOLS\1102.BOX\INFORM.TXT的例子:可至功能设定中核取根据INFORM.TXT内容播放语音，编辑INFORM.TXT

    1234，$1234.WAV

    1235，$1235.WAV

    1236，$1236.WAV

    1237，$1237.WAV

    1238，$1238.WAV

    1239，$1239.WAV

    1240，$1240.WAV

    1241，$1241.WAV

    1242，$1242.WAV

    1243，$1243.WAV

    元件1102播放语音\1102.BOX\VOC\GREET1.GRT中，接受信息查询代号(四位数字:按键最大长度语音1=4)，如按信息查询代号1240，根据 \1102.BOX\INFORM.TXT ，则播放语音信息 \1102.BOX\1240.WAV 语音文件，输入将被存在VMSLINK( n).TXT文件，最后到元件 1104 循环回路元件去执行。

    其它电话语音查询系统的应用例子，循环回路的元件号码和语音信息元件号码如下表:

    电话语音查询的应用例子 | 循环回路元件号码 起始 继续 |  | 按键输入 元件号码
语音信息查询服务 | 1100 | 1104 | 1102
张老师讲故事 | 1200 | 1204 | 1202
张老师讲笑话 | 1300 | 1304 | 1302
股市电话分析 | 405 | 445 |
联考放榜电话语音查询 | 1600 | 1604 | 1602
电话算命 | 1700 | 1704 | 1702
汽车拖吊电话语音查询 | 1110 | 1114 | 1112
汽车遗失电话语音查询 | 1120 | 1124 | 1122
汽车修护状況电话语音查询 | 1130 | 1134 | 1132
电影内容语音查询 | 1140 | 1144 | 1142
电视节目内容语音查询 | 1160 | 1164 | 1162

    电信业务语音查询系统

    本节使用按键输入元件，模拟一个电信业务的电话语音查询系统，并设定循环回路计数，查询多种语音信息或重听。

    <步骤 1> 建立新的按键输入元件

    执行【语音软件生成器】，选【语音元件】的【新增元件】，如下：

    输入【元件号码】和【元件叙述】及做功能设定，不选【播放招呼语】，在应答功能 ，指定此元件功能，在【元件功能】右边按 [image] 选【按键输入元件】:

    在【功能设定】下:

    【播放语音个数】=1 :设定一个语音文件，接受一栏按键。

    【按键最大长度 语音1】=3:最多按3个键。

    【错误重试次数】=1 重新电话输入为一次。

    听取根据Inform(n).TXT内容播放语音

    在【按键设定】下选择【根据按键值】，在按键值选择【其他】【跳至元件】输入8010按 [image] (新增):　按完电话按键后会跑到元件8010。

    同上选项按键值选择【输入错误】及【未输入按键】，跳至元件输入8090,若不按键(含重试一次后)时，会跑到此元件8090。

    在语音软件生成器，按 [image] 准备语音资料

    按【录音】按钮，以录制「您好，这是电信业务的电话语音查询系统，请按查询代号，例如按123可查询如何申请电话」的语音文件，录完按【停止】后，储存成\AG32\Tools\8000.box\greet1.grt的语音文件，按【储存文件】、【确定】按钮。

    在【跳到语音元件：】填入元件8300。

    建立元件8050:

    选【语音元件】的【增加元件】以增加元件8050，在招呼语选项中核取【是否播放招呼语】，按【选择文件案】按钮，按【录音】按钮，以录制「再見」，按【停止】、【确定】按钮。在【元件功能】右边按 [image] 选【只播放语音元件】。

    <步骤 8>

    关闭语音软件生成器，并执行语音管理程序中的【线上模拟】，即可模拟整套功能。

    成绩单语音查询系统

    本节使用语音信息元件和中文转语音功能，模拟一个学校成绩单语音查询系统。请参考电信业务语音查询系统，大部份相同，仅小幅度修改如下:

    <如果您已有一个成绩单的数据库，你可使用外部程序，来准备这一个TEXT文件(INFORM.TXT)，或使用Windows附属应用程序 中的记事本，并输入如下，另存新文件储成 C:\AG32\Tools\8000.BOX\INFORM.TXT 文件：

    <方法一>

    使用中文转语音( TEXT-TO-SPEECH)

    INFORM.TXT格式：

    「电话按键，*中文GB码，*中文GB码，...」:

    中文 TEXT-TO-SPEECH，中文(GB码)自动转换成语音念出。

    <例子>

    12345678，*林志颖，*语文85分，*数学56分，*英文48分，*自然100分

    按12345678，则播放:

    林志颖，语文85分，数学56分，英文48分，自然100分。

    <方法二>

    INFORM.TXT内容：

    「电话按键(学号)，语音文件名(学号)，*xxxxxxxx，语音文件名(语文)，*AA(语文分数)^语音文件名(分)^，语音文件名(数学)，*BB(数学分数)^语音文件名(分)^，语音文件名(英文)，*CC(英文分数)^语音文件名(分)^，语音文件名(自然)，*DD(自然分数)^语音文件名(分)^」

    播放语音文件在\AG32\目录下。

    如上，在电话按键12345678(学号)时，播放语音文件:

    「学号(n.wav)12345678，语文(c1.wav)85分(a.wav)，数学 (c2.wav)56分(a.wav)，英文(c3.wav)48分(a.wav)，自然

    (c4.wav)100分(a.wav)。」

    在电话按键12345680(学号)时，播放语音文件:

    「学号(n.wav)12345680，语文(c1.wav)65分(a.wav)，数学(c2.wav)98分(a.wav)，英文(c3.wav)78分(a.wav)，自然(c4.wav)65分(a.wav)。」

    在语音软件生成器，准备语音资料。按【录音】按钮，以录制:

    「学号」(储存成\multi\n.wav的语音文件)

    「语文」(储存成\multi\c1.wav的语音文件)

    「分」(储存成\multi\a.wav的语音文件)

    「数学」(储存成\multi\c2.wav的语音文件)

    「英文」(储存成\multi\c3.wav的语音文件)

    「自然」(储存成\multi\c4.wav的语音文件)

    <步骤 3>

    状闭【语音软件生成器】，并执行【语音管理程序】中的【线上模拟】，即可模拟整套功能。


政务咨询,办事查询,办理程序查询,自动语音应答咨询服务

政务查询/办事程序/语音咨询 自动语音服务热线
您好，这里是社保中心自动语音应答资讯服务系统
公告、政策、法规查询 | 请按 1
办事程序查询 | 请按 2
申办资料查询 | 请按 3
收费标准查询 | 请按 4
报批结果查询 | 请按 5
语音信箱留言 | 请按 6
人工服务 | 请按 7

简易的咨询菜单流程维护示例图：

留言管理维护简图：

本系统基于天羚公司 强大的 AG32 电话语音呼叫服务平台

本系统基于天羚公司 强大的 AG32 电话语音呼叫服务平台

为了更为方便集成商，客户开展语音系统的应用和维护，我们更在配合 AG32 的基础上，开发了一个类似以上流程应用的软件，供客户选用。特别适用于政府机构，公用事业局，行政服务中心等机构；及学校招生咨询等系列电话自动咨询服务热线，完全将重复、简单的事务移交我们的电脑语音系统来解决。

北京天羚季德科技有限责任公司 8610 62186575 62131778 62145328 www.telelink.com.cn


公用事业局语音咨询信箱

公用事业局语音信箱/语音咨询 自动服务热线
您好，这里是章丘市公用事业局综合服务指挥中心
业务咨询 | 请按 1
应急抢修 | 请按 2
缴费查询 | 请按 3
投诉受理 | 请按 4
转人工服务 | 请按 5

流程示例：

自动留留言管理维护:

本系统基于天羚公司 强大的 AG32 电话语音呼叫服务平台

为了更为方便集成商，客户开展语音系统的应用和维护，我们更在配合AG32 的基础上，开发了一个类似以上流程应用的软件，供客户选用。特别适用于政府机构，公用事业局，行政服务中心等机构；及学校招生咨询等系列电话自动咨询服务热线，完全将重复、简单的事务移交我们的电脑语音系统来解决。

北京天羚季德科技有限责任公司 8610 62186575 62131778 62145328 www.telelink.com.cn

其他 如 税务,社保办事查询,办理程序查询等系统


学历文凭语音查询系统

需求：

通过输入学院毕业证书编号、输入四位出生年份和两位出生月份，并在输入完按键播放输入的按键，选择确定或重新输入。经过数据库判断后，播放姓名、性别、入学年月、毕业年月、专业、学制、层次，并可重复收听

功能介绍：

此流程多用了物件指定元件和按键输入元件，将所有的语音存放在固定的目录下，用户可进入语音系统按”#*#”自行录制所有的录音，给用户带来了极大的方便性。

使用元件：

物件指定元件、按键输入元件、数据库操作元件、文字播放元件、语音录制元件、语音播放元件

技术实现：

元件代号 | 功能介绍
1000 | 进入流程的起始元件，将招呼语写入到Dentry(n).txt文本中
1020 | 播放导航语并进行选择按键值
1450~1520 | 成人教育学历查询，元件1450将语音“2000年以前含2000年毕业的学员请输入证书院校编号以#号键结束2000年以后2000年毕业的学员请输入证书编号以#号键结束“写入到Dentry(n).txt文本中，1500元件播放语音并接受按键值，元件1502用户选择确定输入的证书编号或重新输入证书编号，1503~1509输入出生年月并进行确定，1509元件中当输入的月份不足两位时，流程将自动在输入的1位数前加0。1510数据库操作元件进行查询输入的证书编号是否存在，如果输入的证书编号正确到1516文字播放元件，播放相关的信息，1520元件可选择重听
1550~1620 | 地方委托*校培养学历查询，同成人教育学历查询
2490~2503 | 通过按键输入“#*#”按键，听到提示音后键入语音文件号，例如语音文件号是1 ，请按'1'听到录音提示后录制"请记录,姓名"，录制完一段语音后按#结束后，提示音“重听请按1，重录请按2、取消请按3、确定请按0”当按完0键后会继续录制下一语音文件最后全部录制完成后直接挂机，所有的语音文件都存放在c:\voice,所有的语音文件格式是‘wav’


学校咨询

对外经贸大学中美工商管理学院语音系统

需求：查询学校简介，查询分数

功能：本语音系统的最大特色就是语言的自动切换功能（中、英、法）。当用户打入语音系统时使用语音提示使其进入不同的语言环境中。

技术实现：

1、 每种语言有中美、中法两个学院的不同语音导航，它是利用按键输入元件和语音播放元件的不同组合以达到导航的目的，其它文件已经给予了介绍这里就不在多说了。

2、 在此介绍一下语音切换的具体过程。

这里以中美学院为例；当用户在英文的提示音下选择成绩查询时。就会进入元件1这个语音切换元件中。

元件1[程序2]中“自定语音目录”这里写入的路径为当用户进入成绩查询时进入语音流程，也就是说这个语音系统存在不同的语音流程。

在此提示一下。要进入语音切换事先一定要有那种语言的语音库！

3、 系统50000到50007元件是用来管理各语言成绩查询和录取情况的管理工作。在数据库中一个单选字段，为－1是可以进入。为0就为当然没有成绩和录取情况。

4、 系统60000到66666元件是用来录制语音文件的。当学校添加一些新的学科时。可以叫录音员通过语音系统录制需要的语音内容。

以中文为例：首先在60000中查询数据库科目对应表里有没有尚未录音的内容。如果有就会把这个科目的具体内容提取出来并给予放音（如数据库查询提取字段内容）。特别注意的是在物件指定元件中要给之后要录制的语音文件起个名子并写出要录制的路径并写入vmslink(n).txt中以供之后的语音录音元件使用。最后当录音成功再把尚未录音的标记去掉。


强生热线

强生心扉热线 [800 语音电话]

强生公司作为进入中国的医疗生活用品大型公司，深知客户服务和宣传的重要，早在几年前,就通过公关公司选取系统，最终选择我们基于AG32的系列产品，并合作开发完成了这套热线语音系统。重要的亮点在于AG32 的用户维护方便性，不用担心资料频繁更新的难处。

客户需求：
    满足语音导航，能通过按键选择，服务器将客户咨询的相应公共信息语音播放给客户听取；可以得到打入者的电话号码；可根据限制策略进行号码识别，如果符合条件就接入，否则就挂断；对提示按键而长时间不按键的用户给予挂断；能给公司留言并能通过WEB页浏览管理；语音文件必须方便替换及管理。

功能介绍：

  为本语音系统我们还开发一个WEB页，用来管理语音系统收集到的信息及管理。如留言的听取；系统的打入量、人工座席的接听电话数、用户打入的各个项目的按键数统计；按全国各省统计电话数及详细列表；各项目的语音管理；拦截电话及人工座席的界面管理等等。

使用元件：语音播放元件、按键输入元件、物件指定元件、语音录制元件、数据库操作元件、电话转接元件。

功能实现：

元件代码100到1200： | 当电话打入后取得对方号码并查询拦截功能是否打开，如果是开的就查询这个电话号码是否在拦截之列，如在给予挂断。否则判断是否是第一次打入，如不是在这个电话号码的打入次数加1再写入数据库。最后进入到强生的主语音菜单。
元件代码11000到12130： | 为对产品的介绍，通过按键值再到数据库中去查询相关的内容然后通过按键输入元件中的DENTRY(n).txt给予播出所选择的公共信息，达到导航的目的。并可以横向进入其它的语音项目。
元件代码13200到13300： | 主要完成留言和对留言信息的收集。在13100中首先取一个随机数做为留言文件的文件名并给一个留言文件的保存路径，把这些信息写入到Vmslink(n).txt中以备之后的语音录制元件使用。最后在13200中把相关的内容写入到数据库中使之可以通过WEB页进行访问。
元件代码14000： | 用于转接人工。


云南滇虹药业800医疗热线

药业公司 800 医疗咨询服务热线

需求：

目前很多公司注重客户服务相继开通800热线。其中云南滇虹药业就是其中一个。集成商与他们基于AG32合作应用了一套语音药业热线系统。2002年起，使用的几年多过程中运行良好!

功能：

满足语音导航，能通过按键选择，服务器将客户咨询的相应公共信息语音播放给客户；可以得到打入者的电话号码；可根据限制策略进行号码识别，如果符合条件就接入，否则就挂断；对提示按键而长时间不按键的用户给予挂断；能给公司留言并能通过WEB页浏览管理；转接人工及座席界面。使用元件：语音播入元件、按键输入元件、物件指定元件、语音录制元件、数据库操作元件、外拔电话元件。

技术实现：

元件100到1500： | 当电话打入后取得对方号码并查询拦截功能是否打开，如果是开的就查询这个电话号码是否在拦截之列，如在给予挂断。否则判断是否是第一次打入，如不是在这个电话号码的打入次数加1再写入数据库。最后进入到滇虹药业的主语音菜单。
元件11000到13001： | 全部是对药品的简介，通过我们语音平台的按键输入元件和语音播放元件予以完成，达到导航的目的。
元件13200到13300： | 主要完成留言和对留言信息的收集。在13100中首先取一个随机数做为留言文件的文件名并给一个留言文件的保存路径，把这些信息写入到Vmslink(n).txt中以备之后的语音录制元件使用。最后在13200中把相关的内容写入到数据库中使之可以通过WEB页进行访问。
元件14000到14221： | 主要完成对人工座席的转接和管理工作。当用户选择进入人工时，系统会根据对人工座席界面传给数据库的信息自动转接给一个空闲的人工座席。如果没空闲就会进入到元件14200叫打入者选择是等待、返回还是挂断电话。如选择等待后就会在一定时间后自己去转接电话。

    为本语音系统我们还开发一个WEB页用来管理语音系统收集到的信息及管理。如留言的听取；系统的打入量；人工座席的接听电话数；拦截电话及人工座席的界面管理等等。


企业自动语音信箱

企业自动总机/ 语音信箱/ 产品资料传真回复/ 自动分类接收传真

需求：自动语音信箱，可转接电话、收发传真、多时段设定，传真收发、留言自动通知

功能：主要用到按键输入元件、传真发送元件，传真接收元件，电话转接元件、物件指定元件、语音录制元件、信箱操控元件

技术实现：

1000 按键输入元件： | 白天的电话流程，在[程序3]中‘根据按键值，执行对应元件’中按键值为0~5，9设定为特殊键，当用户按到这几个数字的按键时，就立刻跳到对应的元件，‘其他’是用户直接键入分机号码，分机号码的设定在<工具>下的 〈使用者管理〉中设定要转接的分机号码
1100~3002 电话转接元件： | 选中‘监控转接功能’中设定当分机忙线是可选择继续等待、留言、转接其他分机
1001 按键输入元件： | 晚上6：00到08：00语音流程
4000~4003元件 | 自动传真索取产品资料，价格
4004~4504元件 | 自动传真索取产品价格，价格
4999~5003元件 | 实现传真接收，4999按键输入元件：[程序3]中‘根据按键表，执行对应的元件’在“编辑按键表”中编辑，例如：1234，5000 按1234到元件5000接收传真（防止一些广告传真占据电话线）
8000信箱操控元件 | 是通过元件1000中#号键到，此功能没有提示音是公司内部使用
9000、9001录制语音元件： | 录制留言


工资查询系统

企业工资语音查询系统

需求：

员工不需要到发工资的地点询问所发工资情况，通过电话就可以得知。

功能实现：

员工只需要通过电话输入相应的卡号和密码，再输入要查询工资的月份就可以方便的查询到该员工所发工资情况。

流程说明：

元件代号 | 具体说明
1000 | 进入流程的起始元件，用来提取在d:\voice目录下的10.wav语音文件，将语音文件写入到Dentry(n).txt文本中。跳到12910元件。
12910 | 按键输入元件，播放Dentry(n).txt文本中的语音‘…请输入您的卡号，以#号键结束’时输入卡号，输入的按键值指定给了v1(变量1)
12911 | 物件指定元件，提取11.wav语音文件并将语音文件写入到Dentry(n).txt文本中
13000 | 按键输入元件，播放Dentry(n).txt文本中的语音‘请输入密码，以# 号键结束’时输入密码，输入的按键值指定给了v2
13001 | 数据库操控元件，查询输入的卡号和密码是否正确。不正确跳到13002元件，正确跳到13008元件
13002 | 语音播放元件，播放‘卡号密码输入有误，请重新输入’跳到元件1000
13008 | 同12911元件，提取13.wav
13010 | 播放‘工资查询请按1 ， 修改密码请按 2’进行选择。按1跳到13011元件，按2跳到13100元件。
13011~13028 | 工资查询。
13011、13013 | 同12911元件，分别提取14.wav 15.wav语音文件
13012、13014 | 分别输入查询的年份和月份，并将按键值分别指定给v3、v4。在13014中设定了[未达到最大按键值时前补0]设定的输入的月份的按键值位数为2，如果当输入的月份是一位数时，例如输入月份是‘1’此功能将自动在前加0变为‘01’再指定给v4。年份和月份输入完后跳到13015元件
13015 | 数据库操作元件，查询输入的年份和月份在数据库中是否有数据。将查询的数据指定给资料表1中。没有查到跳到13016元件，有数据跳到13025元件
13016 | 播放语音‘无本月数据，请重新输入’，跳到13011元件重新输入
13025 | 在资料表1中分别提取数据，分别输入字段名指定给不同的变量，这样查询的内容将全部放入到了指定的变量中，最后将这些变量按照一定的格式写入到Voice(n).txt文本中。
13026 | 文字播放元件，播放Voice(n).txt文本中的工资内容。
13028 | 根据13027中提取的语音文件。根据播放‘重听请按 1 ，继续查询请按2，结束请挂机’进行选择
13100~13110 | 修改密码。
13100、13102 | 分别提取24.wav、25.wav语音文件
13101、13103 | 分别是输入新第一次密码和再次输入新密码，指定给变量v10 v11
13104 | 物价比较元件。用来将两次输入的新密码进行对比，输入的相同跳到13105元件，不相同跳到13110元件
13105 | 修改新密码。
13106 | 播放‘密码修改成功’
13110 | 播放‘两次输入的密码不一致请重新输入’跳到13100重新输入
20000~20003 | 用来方便录制流程用到的所有的语音文件，只需输入编号的语音文件号进行录制语音，


电力查询/催缴/报修

需求：查询电量、电费，催缴欠费，留言即时通知

功能：
实现用户电费电量查询、用户投诉留言 、电力抢修留言、用户基本电价查询 、电力基本法规咨询 、人工交互服务。可与天羚管理软件界面配合使用。

技术实现：

100~302元件 | 供外部程序，催缴使用。
2000按键输入元件 | 是流程的介入点，播放导航语按1用户电费查询、按2用户投诉留言、按3用户报修服务留言、按4用户基本电价查询、按5电力基本法规、按6人工服务。
2106~2116元件 | 用户报修留言
2108按键输入元件到2112元件 | 输入用户编号，2109元件进行判断用户号是否存在，存在到2111元件将[程序1]‘唯一通道号’赋给变量3，在[程序2]中将变量3作为报修留言的文件名写入到vmslink(n).txt文本中。例如：d:\voc\%%v3%%.wav.‘留言档名由vmslink(n).txt提供’
2116数据库操作元件 | 将留言数据统计
2200~2209元件 | 用户投诉留言，类似报修留言
2301~2306元件 | 根据用户输入用户号、要查询的月份。播放此月的电量、电费


水费查询催缴

水费查询催缴/自动报修/抢修

需求：查询用水量，催缴水费

功能：通过AG32语音管理器、IE界面数据导入、催缴软件结合，利用外部程序实现；用户只须通过电话机输入用户编号、密码；进入语音系统，输入想要查询的年、月。语音会自动播放用户名、用水量、水费单价、总计金额

技术实现：

300~302 | 这几个元件供外部程序使用
10001 | 进入语音流程，将计数器设置为3、供元件10006使用
10002 按键输入 | 播放两个语音，将输入用户编号、密码分别指定给变量1、变量2
10004 数据操作 | 验证输入用户编号、密码是否正确，如果正确跳到元件20000、不正确到元 10006
10006 按键输入 | 提示用户输入用户编码和密码不正确，跳到元件10004重新输入，当输入次数超过3次时流程会跳到元件99999自动挂断电话 。
20000 按键输入 | 进入主菜单，按键输入元件根据用户的按键值跳到相对应的元件，在[程序3]中设定，选中<依据按键值，执行对应的元件>，按0重听、按1查询水费、按2修改用户密码
21000 数据操作 | 根据20000元件按键值1跳到此元件，用户根据语音提示输入查询的年、月，到元件21010、21020进行数据查询， 当查到数据跳到元件21030、当没有查询到数据跳到元件21025播放'本月信息不存在'
21030 物件指定 | 将查询的数据赋值、将变量6赋给'户名'、变量7赋给'实用吨数'、变量8给'合计金额'、变量9赋给'水费单价'、再将要播放的语音内容写入voice(n).txt文本中
21040 文字播放 | 是文本播放元件，播放 voice(n).txt文本中 的内容
21050 按键输入 | 重听0，再查1，修改密码2，挂机3
22000 语音播放 | 用于计时设定
22005 按键输入 | 输入两次新密码
22010 物件比较 | 将两次输入的密码进行对比，当两次输入的密码不一致跳到元件22020，如果一致到元件22030元件修改密码
22020 语音播放 | 两次输入的密码次数不一致超过3次，跳到元件99999挂机
22040 语音播放 | 播放密码修改成功


电子报税

需求：节约了用户的时间，通过电话直接可咨询税法、输入发票号码进行查询

功能实现：实现通过电话直接电子报税

技术实现：本系统用到AG32模块中的元件按键输入元件、程序连结元件、语音切换元件、传真发送元件、文字播放元件、语音播放元件、信箱操控元件。

本系统多用程序连结元件，通过外部程序的算法，返回结果。

1按键输入元件： | 播放导航语选项，“电话申报按1、查询按2、修改密码按3、税法咨询按4、举报按5、发票查询按6、帮助按7”依据按键值、执行相对应的元件。
4程序连结元件： | 元件1中按1键到，通过外部程序完成电话申报。
5程序连结元件： | 通过外部程序完成查询功能。
6程序连结元件： | 通过外部程序完成修改密码功能码。
9语音切换元件： | 选取的语言类型到元件2。
2按键输入元件： | 播放广州语申报选项。
10000~10160元件： | 根据输入的税号，播放相应的信息。
10200~10260元件： | 实现输入密码进行电子报税。
13000~13210元件： | 举报、并录制留言。
15000~15999元件： | 先输入发票类型编码并进行确认，到程序连结元件进行外部查询，通过外部程序连结元件给出的gotobox(n).txt,跳到文字播放元件播放voice(n).txt中的内容，再到程序连结元件记录发票类型编码。


医疗保险

需求：用户输入ID即保险编号，电脑接受并验证保险编码，播放用户的数据信息

功能：最简单的查询用到按键输入、数据库操作元件、物件指定元件、文字播放元件、语音播放元件5种元件，用户只须输入保险编号，可听到相应的信息

技术实现：

元件号 | 功能说明
1000 | 设定计数
1001 | 根据提示音输入保险编号、将输入的保险编号给变量1
1002 | 查询输入的保险编号是否存在
1003 | 输入的保险编号不正确，请重新输入
1010 | 提取相关的数据，将要播放的语音内容写入到voice(n).txt文本中
1011 | 播放voice(n).txt文本中的内容
1020 | 重听voice(n).txt文本中内容、按2继续查询其他用户保险编号


海南航空

海南航空公司IT服务热线

客户需求：
目前一个产品的售后客户服务是一家公司生存和发展的前提条件。在此以海南航空公司IT服务热线为例，向您简单介绍一下这个客服中心应用。

实现功能：
 主叫识别并能判断非法用户并给予拦截；可判断主叫的局向并统计；开始招呼语可以随时进行修改；可统计人工座席的接通话务量；人工遇忙可以叫用户等待或留言；夜间服务电话可以转移到任何分机中。

使用元件：
 语音播放元件、按键输入元件、物件指定元件、语音录制元件、数据库操作元件、电话转接元件、文字播放元件。

具体实施：

元件1000到1500： | 当电话打入后取得对方号码并查询拦截功能是否打开，如果是开的就查询这个电话号码是否在拦截之列，如在给予挂断。否则判断是否是第一次打入，如不是在这个电话号码的打入次数加1再写入数据库。最后进入到海南IT的主语音菜单。
元件10001到10006： | 要解决的是在正常主菜单开头是否有一个突发事件语音要播放。首先要查询一下数据库目前有没有突发事件语音。之后打招呼语内容写到DENTRY(n).TXT中并通过按键输入元件播放出来。
元件13100到13300： | 主要完成留言和对留言信息的收集。在13100中首先取一个随机数做为留言文件的文件名并给一个留言文件的保存路径，把这些信息写入到Vmslink(n).txt中以备之后的语音录制元件使用。最后在13200中把相关的内容写入到数据库中使之可以通过WEB页进行访问。
元件14000到14221： | 完成对各个项目的转接工作和转接内容的收集。在14000和14002中通过一定的规则查询数据库并把要转接的座席分机号提出做好在14003中的转接准备。14004到14221处理当电话转接占线或无人接听的指向和收集并写入数据库转接情况信息。
元件40000到43200： | 为夜间电话转接。


国家技术监督局

国家技术监督局语音查询系统

需求分析：
    对于国家技术监督局代码中心、编码中心来说，每天都会接到大量的咨询电话，而几乎每通电话都是同样几个问题的重复回答，因此我们可以把这种繁琐的事情交给语音系统去解决，用户可以根据自己所需咨询的问题，仅仅几个按键就可以迎刃而解。

功能介绍：
    1、查询代码、编码中心的电话、地址以及各分支机构的电话
    2、咨询条码注册，续展申请手续，胶片制作等
    3、交费方式及收费标准的查询

功能实现：
    基于AG32实现的国家技术监督局电话语音查询系统，仅仅利用几个简单功能元件就实现了它的应用。　　按键输入元件、数据库操作元件、物件指定元件、语音播放元件

开始接电话元件为1000
通过一系列的按键输入元件一层层的展示查询的菜单内容
一级菜单按键输入元件1001,3001,6001,7001，
二级菜单按键输入元件，如
    进入1001后，通过按键可以进入二级菜单咨询，二级输入元件为1002、2001
    进入3001后，通过按键进入二级菜单咨询，二级输入元件为3002、4001、5001。
    其中在查询分支机构电话时，用到数据库操作元件和物件指定元件2120、2121。
    首先用户在元件2001中，可以输入各地方的长途区号，将此按键值给变量V1；然后走到数据库操作元件2120，在程序三中输入select * from code where 长途区号='%%v1%%'获得此表的各项数据，如果成功则到物件指定元件2121，在程序二中将播放分支机构的文件名指定给dentry.txt,文件内容为：*^d:\voice;%%V2%%.wav^，其中V2为根据此长途区号索引到的文件名；最后到按键输入元件2122，播放分支机构电话的语音文件。如果失败，则到语音播放元件2130，播放长途区号错误的语音。

简要介绍
    利用天羚公司的AG32语音平台，不管多层语音菜单咨询如何繁琐，它都可以邦你轻松实现，并且可以随意修改，维护简单。


企业语音信箱和客户服务系统

需求分析：

企业语音信箱和客户服务基于一体。企业语音信箱其实是自动语音话务员，判断分机状态转接分机，可进入流程后直接输入分机号码，留言信箱，在外地就可听取留言并进行管理

实现功能：进行来电电话统计，转接分机号码并判断分机的状态是‘空闲’‘忙线’，统计转接分机的接通数和统计座席的接电话次数

技术实现：本系统用到AG32模块中的按键输入元件、数据库操作元件、物件指定元件、电话转接元件、语音录制元件、信箱操控元件

1200、1500数据库操作元件： | 统计第一次打入电话的电话号码、打入的时间、日期到10001元件
10001按键输入元件： | 播放招呼语“总机服务请按0、部门查询请按8、语音咨询请按9”进行选择，其中#、0、8、9这几个数字键设定为‘特殊按键’当用户按了这几个按键时会直接跳到对应的元件，进入此元件听招呼语同时可直接输入分机号码，转接分机，将输入的分机号码指定给变量1
10002电话转接元件： | 是10001元件按0转接总机，在‘监控选项’中设定 1、当总机无人接听跳到到10003元件，播放‘总机无人接听’跳到10001元件重新选择 2、当总机忙线中跳到10004元件，播放‘总机忙线中’跳到10001元件重新选择
10100数据库操作元件： | 根据10001元件输入的组号进行部门查询，到10200物件指定元件赋值分机号码，跳到10300
10400电话转接元件 | 是10300中选择的转接其他分机，进行查询其他分机号码，如果查询失败，跳到10600元件播放“分机全忙”
11000~11120元件： | 查询相关语音内容，通过物件指定11110元件将要播放的语音内容以格式“*^d:\ag32\tools\voice;%%v3%%^”写入到Dentry(n).txt文本中，通过11120按键输入元件[程序2]中设定播放招呼语Dentry(n).txt中的内容
13000~13300元件： | 留言并记录留言内容
14000~14200元件： | 查询分机号码并判断分机的状态是‘空闲’‘忙线’转接分机，统计转接分机的接通数和统计座席的接电话次数
16000~16400元件： | 输入信箱号码和密码听取留言
17000~17300元件： | 修改个人信箱密码
1200、1500数据库操作元件： | 统计第一次打入电话的电话号码、打入的时间、日期到10001元件


电话银行

电话银行/客户服务

需求：

电话银行是为了方便和满足持银行卡用户在不去银行的前提下，通过电话做到余额查询、转帐业务、利率查询、和传真索取的需要。本系统已经在多家银行成熟使用。各行都有些个性化的变化，以下是我们同商业银行的电话流程简要说明。
我们的语音平台可以满足对各种数据库的访问。可是由于银行的数据库是不能叫外来程序直接访问的。并在和我们沟通的时候也要加密的TCP/IP通讯，所以我们开发了外部通讯服务程序。

主要功能：余额查询、转帐业务、利率查询、和传真明细对帐单、人工服务。

技术实现：
以下是电话打入后，判断用户是否合法的判断过程：
电话打入后进入100000元件，这个元件用来播放银行的欢迎词并提示用户按键选择。例如：当用户选择1后，语音系统进入元件代号为4的语音播放元件，这个元件是用来计数的起始值为2，它是与元件代号为11的语音播放元件配合使用的，以达到非法用户在2次的账号和密码错误后自动掉断电话的功能。之后进入元件代码为5的按键输入元件，这里用户输入账号、密码并赋值为变量V1和V2。接着在元件代码为7的物件指定元件中把得到的值写到Vmslink(n).txt中，写入的内容通过元件代码10的程序连接元件的进入启动外部程序，当看到连接代码为101就知道是它的任务是判断用户是否合法，然后将Vmslink(n).txt的内容资料取出提交给银行服务器验证，当验证通过进入10100元件否则进入11元件。从而完成对用户合法性的判断。

    本语音系统主要使用了：语音播放元件，按键输入元件和文件播放元件来完成了整个的语音导航工作；使用程序连接元件完成了对打入电话者的验证、相关信息的提交、反馈信息的所取、还有和本系统配合完成一些动态指向的工作；物件指定元件主要工作是对Vmslink(n).txt的写入工作；还使用了传真发送元件、和数据库操作元件（由于商业银行的利率表是外部数据库管理所以我们是直接访问的）。

以下为Vmslink(n).txt的内容：

连接101代表程序连接元件的连接代码为101，t为如果成功后要去的元件代码，f为失败后要去的元件代码。

连接101
1,账号，密码　t:10100 f:11
2,账号，密码　t:20100 f:11
3,账号，密码　t:30100 f:11

111,账号，密码　t:11102 f:　　（存折户，账户余额查询）
112,账号，密码　t:11102 f:　　（存折户，当天交易查询）
113,账号，密码　t:11102 f:　　（存折户，最近一笔交易查询）


信箱操控

需求：用于学校、公司设定个人信箱

功能：
 在此例以学校信箱操控为例，实现每个人一留言信箱、可留言群呼、接收E_mail、发送与接收传真，主要用到的元件有按键输入元件、数据库操作元件、物件指定元件、文字播放元件、录制语音元件、邮件接收元件。

技术介绍：

1000按键输入元件： | 按1 学生信箱 按2 老师信箱 按#管理员(没有提示音)。
12000按键输入元件： | 进入学生信箱，选择按1听留言、按2更改密码、按3留言。
12100~12101元件： | 修改学生密码。
12300按键输入元件： | 进入学生听取留言。
13000按键输入元件： | 进入老师信箱，按1听取新留言、按2听取旧留言、按3接收E_mail、按4留言群呼、按6使用者设定。
13001~13007元件： | 查询信箱的留言数量，播放新留言XX条、旧留言XX条，再后到元件13010听取新留言或旧留言。
13108按键输入元件： | 选择重听、听下一笔、删除、转送其他信箱。
13204数据库操作元件： | 移动到下一条留言。
13205数据库操作元件： | 删除听完的留言。
13210~13215元件： | 输入要转发的信箱号码，进行完验证要转发的信箱号码是否存在，存在进行转发留言。
13400按键输入元件： | 进入到使用者设定中，按1变更密码、按2设定留言通知、按3添加群组代号、按4查询、按5、删除群组代号。
13405~13407元件： | 更改个人信箱密码。
13408~13420元件： | 设定留言通知状态。
14000按键输入元件： | 进入留言群呼，按1输入群呼代号、按2输入个人信箱代号。
14105~14111元件： | 输入群呼代号，当群呼代号存在时进行留言群呼。
14200~14205元件： | 输入个人信箱号码，查询输入的信箱号码是否存在，存在进行留言，并发送留言。
14600~14626元件： | 接收邮件，可实现听取有几封邮件，听取邮件内容后、可选择删除、听取下一封邮件，也可将邮件的内容转换成传真格式保存。接收邮件时必须在[设定]中 〈电子邮件设定〉中设定好‘内收邮件服务器’地址。
15000元件： | 进入管理员设定中，与老师信箱相同，多了一个添加老师信箱的功能。


公安部出入境

公安部、局；使馆等出入境、签证等自助查询

需求分析：

节省用户时间，通过电话查询出入境边防手续咨询

实现功能：

通过输入各地的电话区号，可查询到各省办证处的电话、工作时间、工作地点。对输入的元件代码进行统计。

技术实现：

用到的AG32中的按键输入元件、物件指定元件、语音录制元件、传真接收元件、传真发送元件、数据库操作元件、外拨电话元件。

95~99元件 | 统计当日访问的次数
1000按键输入元件 | 播放招呼语“公安部英文名称查询按1、各省办证工作时间、工作地点查询按2、办证手续咨询按3、出入境边防手续咨询按4、发送传真按9、人工服务按0”。
1010外拨电话元件 | 拨打分机号码，拨通到8100元件，没有拨通到1019元件。
1019外拨电话元件 | 当1010元件没有拨通是，做一个按电话r的动作将电话拉回。
1095~1099元件 | 进行出入境管理局查询，统计次项查询的次数。
1100~2099元件 | 进行英文名称查询，统计次项查询的次数。
2100~2104元件 | 输入出入境管理局查询区代码，查询、赋值、通过文字播放元件播放查询的相关信息。
3000~3007元件 | 办证手续查询，根据3000按键输入元件播放的招呼语选项选择按键、根据按键值到对应的元件播放信息。
5000~5005元件 | 单程传输查询
9000传真接收元件 | 接收用户的传真


电话防伪系统

需求分析：
许许多多的假货充斥着市场，因此人们需要能方便的查询到自己货物的真伪，电话防伪系统就应运而生了。本系统基于AG32平台，与多家系统集成商合作并开发多套。

功能介绍：
天羚电话防伪系统具体功能介绍如下：
1、 稽查人员可以输入防伪码，了解代码的真伪，同时可以知道此产品查询的次数。
2 、客户可以输入防伪码，了解代码的真伪，同时可以知道此产品已被查询的次数。

功能实现：
本系统用到AG32如下元件和参数
计数器参数，按键输入元件，程序连接元件，文字播放元件，语音播放元件，电话转接元件，数据库操作元件，物件指定元件。接电话起始元件为900。

1、稽查人员和客户都可以通过按键输入元件输入防伪码。
按键输入元件 如1800,3100

2、本系统防伪码的查询是通过算法实现的，因此系统在用户输入防伪码后，然后通过外部程序连接元件，通过外部程序判断此代码的真伪。外部程序判断后进入不同的元件，通过文字播放元件去告知用户此代码已查询的次数，通过按键输入元件可以要求多次进行查询如流程中：
外部程序连接元件：1810，3200
文字播放元件 2000 ~ 2004
按键输入元件 4000 ~ 4004

3、系统可以让用户选择直接转接人工。
人工转接元件 100

4、稽查人员进入系统必须输入证件号码和密码，允许输入的次数不能超过2次，系统首先采用了一个计数器，元件代号为900，在程序一中设置计数器为2；然后进入按键输入元件1000，输入稽查人员的证件号码和密码，赋值给变量V1，V2；再进入数据库操作元件1010，在程序三中输入语句select * from 稽查人员表 where 证件编号='%%v1%%' and 人员密码='%%v2%%' 如果正确进入物件指定元件1011，得到此稽查人员的查询次数，赋值给变量V3，再到数据库操作元件1012累计此稽查人员的查询次数，在程序三中输入语句update 稽查人员表 set 查询次数=(%%V3%%+1) where 证件编号='%%V1%%' 如果失败，再进入1020元件，在程序一中将计数器减一，然后回到稽查人员查询的起始元件1000，重新输入；当计数为0时，到语音播放元件5000，告知稽查查询次数超过，系统挂断。

简要介绍
利用AG32系统提供的几个功能元件，就可以达到电话防伪的目的，快捷方便。


社会保险系统

需求分析
随着人们保险意识的不断加强，社会保险也越来越受到人们的关注，人们需要方便快捷查询到个人和单位的交费和欠费情况以及退休金情况，北京天羚AG32系统很方便地帮你实现这方面的应用。并且已经和多家系统集成商合作开发了上百套这方面的应用。

功能介绍
1 查询职工养老金个人帐户，个人欠费情况以及退休金情况。
2 查询单位本年度交费及欠费情况
3 可以通过传真发送欠费通知单

功能实现
本系统既可以通过系统自带的数据库操控元件和物价比较元件去实现数据库查询方面的应用；也可以通过程序连接元件去实现，由于开发系统时需要与集成商的外部管理程序结合使用，因此下面介绍的社保系统以后面的方案为主。
系统主要用到的元件有：
按键输入元件，程序连接元件，语音播放元件，文字播放元件
发送传真元件；电话接入起始元件为100

1：首先通过按键输入元件100，根据不同的按键值走入不同的功能模块
比如: 按1 进入按键输入元件1100，要求输入个人帐号编码
按2 进入按键输入元件2100，要求输入社会保障号码

2：当输入社会保障号码后，进入程序连接元件，通过外部程序找到个人医疗帐户，然后跑到元件2300，播放个人医疗帐户信息，每一个程序连接元件都对应不同的外部程序代码，告之外部程序执行什么操作。
程序连接元件：1200,2200,3200，4200, 5200
文字播放元件：1300,2300,3300,4300,5300

3： 当输入单位编码时，可以通过外部程序生成传真文件，然后跑到发送传真元件6300，指定固定的传真文件后，就可以发送传真了。

4：如果外部程序未找到数据，跑到语音播放元件6400，播放数据未找到的语音文件。

简要介绍
本AG32系统可以轻松架构各种社保语音查询。结合程序连接元件可以实现复杂的数据查询应用。


心理测试

心理测试/有奖竞猜/知识问答。。。

需求分析
现代人的生活节奏越来越快，生活的压力也越来越大，因此需要有些娱乐的节目让人轻松一下，比如需要测试一下当前心情指数，需要了解自己属于哪类性格等等。现在您通过电话就可以马上心想事成。

功能介绍
1，可以选择多种类型的心理测试题目
2，可以对每道题的选项进行分数统计，根据统计值得出心理测试的结论

功能实现
由于心理测试对每道题每个选项的分数分配都不一样，而且每次选项后都需要累计分数，最重要的是根据累计分数得出结论。牵涉到复杂的运算和比较，因此建议通过外部程序实现累计和比较。
此系统主要用到的功能元件有：

按键输入元件，数据库操作元件，物件比较元件，程序连接元件，文字播放元件,语音播放元件，电话接入起始元件为1000

1，通过按键输入元件1000，进入心理测试栏目1001，选择测试题类。
将按键值给变量V1
2，然后走到数据库连接元件1004，获取此类的题库，在程序二中输入
select * from xlwav where xl_type='%%v1%%' order by [xl_id]
3，通过物件指定元件1005获取此类题的第一个语音文件； 将此语音文件写入dentry[I]中，走到按键输入元件1008，播放第一道题，按键输入此道题 的选择答案，将答案指定给变量发V3
4，在物件指定元件1010中将变量V3指定变量V4
5，通过数据库库操作元件1011，移到每二个题目记录，获取语音文件
6，在按键输入元件1015中得到第二个题目的答案按键值给变量V3
7，然后有物件指定元件获得每次答案的累计值，然后将累计值写入文件VMSLINK中
8，在数据库操作元件1011中，当最后一个记录时，可到程序连接元件1200，此时可在外部程序中实现分数的累计，然后得出结论，跑到文字播放元件1200，播放此次心理测试的结论。

简要介绍
此类题最大的技巧是将每次选题的答案写入文本文件VMSLINK中，然后通过外部程序得出结论。这样不管答题类型如何改变，都可以实现。


120电话转接

120 电话接续

需求：为节省时间，病人无须听完全部语音服务，只须在120专线接通，语音服务在“这里是120医疗急救服务专线”完毕时，病人即可按有关医院的序号，电话即可接通

功能：用户通过拨打120电话，转到要查询的医院的电话，查询医院的代号、地点、工作电话实现了统计来电号码，统计电话接通次数、未接通电话的医院代号与次数。

技术实现：

主要用到的元件有按键输入、物件指定、外拨电话、数据库操作、文字播放、语音播放元件。

1000元件 | 用户根据导航语的提示音键入要拨打的医院代号，并将按键值给变量1，不论输入哪个医院的代号都到1001元件。
1001元件 | 根据变量1查询医院的电话号码。
1002元件 | 是将1001元件查询到的电话号码赋值给变量5、并将其他相关的信息赋给其他变量。将外拨电话号码写入到vmslink(n).txt。
1003元件 | 利用外拨电话元件打电话。要拨打‘电话号码’有三种方式 1、直接指定要外拨的电话号码 格式：，，&，XX ‘，’系统在拨电话号码前先暂停1秒，两个逗号暂停2秒，依次类推 ‘&’做Flash(转接)动作 ‘XX’外拨的电话号码 2、由vmslink(n).txt提供 将要外拨的电话号码，事先在vmslink(n).txt文本中将格式写好 3、由变量提供 将已设定好的字串变量来提供外拨电话号码
1004~1005元件 | 处理拨通电话的流程。1004元件是当外拨电话接通时，用来统计电话接通次数，到1005元件统计来电记录，跳到2000元件释放外拨的电话线到2001元件。
2001元件 | 用到了‘元件自行计时’设定时间为固定时间600秒，循环播放语音当到600秒时自动挂断。
1009~1999元件 | 处理没有拨通的流程。
1100、1101元件 | 统计没有拨通的医院代号和次数。
1777元件 | 选择按1返回到主菜单、按2继续外拨。
1778~1781元件 | 查询医院的名称和电话号码，并通过文字播放元件1780播放语音。


中铁快运货运

需求：为了满足运输客户即时了解所委托运输的状况，及对客户的咨询服务，中铁 快运集团经过多方论证，最后采用天羚 50套AG32 电脑语音广场语音平台。

功能：本系统用到AG32如下元件按键输入元件、物件指定元件、数据库操作元件、电话转接元件、文字播放等元件，输入用户的货物票号，查询相关的信息，播放信息

技术实现：进入到电话语音查询系统后，按0 听取介绍、按1查询各地分机机构、按2查询到货票号、按3运价信息查询、按4查询营业网点、按5人工服务

200000 按键输入元件 | 进入中铁快运电话语音导航语，“根据按键值，执行对应之元件” 例如：按1到210000元件
201000 语音播放元件 | 中铁快运介绍
210000 按键输入元件 | 输入要查询的各地分机机构的区号，例如：输入区号020
211000 数据库操作元件 | 查询输入的区号是否存在存在了到元件211001，没有查到 元件210000重新输入
211001 物件指定元件 | 提取相关的信息，将要播放的语音文件存放在Voive(n).txt文本中
211009 文字播放元件 | 播放Voive(n).txt中的语音内容
220000 按键输入元件 | 按1查询到货票号、按2按包裹单号查询
221000 按键输入元件 | 输入快运11位单号 例如：输入12345678912
221100 数据库操作元件 | 查询输入的11位货物单号是否正确
221101 物件指定元件 | 提取查询的货物单号的信息
221109 文字播放元件 | 播放相关的信息
222000~222109 | 按包裹单号查询
222120 按键输入元件 | 选择继续输入快运单号、查询发货城市区号
222180~222185 | 按发货城市的区号依次查询票号、发货站点
240000 按键输入元件 | 选择按到达城市查询或传真发送
241000~241109 | 运价信息的查询，输入到达城市的区号进行查询、提取价格信息，播放价 格
242000 传真发送元件 | 传真发送货运单
250000 语音播放元件 | 查询营业网点


110 接警

需求分析：用户电话打入显示用户电话号码及具体地址，之后转接给人工并同时录音。

功能实现：通过外部程序判断是否可以转接电话，实现三方录音，并记录录音内容。

技术实现：本系统用到AG32功能模块中的数据库操作元件、程序连结元件、外部程序 连接元件、外拨电话元件、物件指定元件、语音录制元件

100 数据库操作元件： | 实现统计来电号码。
1000语音播放元件： | 播放接警招呼语语音，到2600元件。
2600数据库操作元件： | 判断是否可转接电话，当判断不可转接电话时到元件2700元件修改数据将数据还原为100，状态变为可接电话，并统计数据，当判断可转接电话时到2601数据库操作元件，统计通道号为变量3数据，跳到2603元件。
2603程序连结元件： | 供外部程序计算数据，如果连结失败到2643数据库操作元件修改通道号为变量3的数据，然后到2644语音播放元件播放“人工正忙，无法接听您的电话，请稍候再拨”后挂断电话。
2605外拨电话元件： | 转接电话分机号码为220，当外拨成功到3001外拨电话元件，跳到2606物件指定元件，此功能实现三方通话。
2606物件指定元件： | 在[程序1]中将唯一值给变量6用于存放录音，将录音文件的存放路径”d:\record\%%V6%%.wav“写到Vmslink(n).txt文本中，到元件2608。
2608语音录制元件： | 将三方通话录音，并存放在Vmslink(n).txt中指定的录音文件的存放路径，成功后跳到2610元件。
2610数据库操作元件： | 将三方通话录音写入到数据库，跳到2700数据库操作元件还原电话状态。


财政部金融控管交易中心语音查询系统

机房巡查登记系统

需求：通过拨打指定的电话输入工号，实现自动签到、记录机房信息、查询签到情况、查询机房的信息。对机房电话号码进行识别，结合网上查询管理

系统功能：

1. 每个接入网点指定一部电话作为网点代表电话。维护人员在指定的网点代表电话拨打XX电话签到，并输入进入机房的原因等信息。

2. 维护人员在语音的提示下输入机房的状态数据，这些数据可统一存到数据库中。

3. 管理人员打入电话听取维护人员的签到情况及机房状态。

4. 可在数据库中加入各种信息供维护人员通过电话方式查询

使用元件：

物件指定元件、按键输入元件、数据库操作元件、文字播放元件、语音录制元件、语音播放元件

技术实现：

元件代号 功能介绍

1000 | 语音系统的起始元件，和元件10200配套使用，作用是实现在10000连续3次输入错误的工号后，系统将自动挂断电话。
10000 | 物件指定元件，作用是将开头的语音文件写入到Dentry.txt文本
10001 | 按键输入元件，播放Dentry.txt中的语音内容输入工号将输入的工号给变量v3,到元件10050元件
10050、10051 | 播放输入的工号后，听到提示音后可进行选择按1重新输入、按2确定输入的工号。
10100 | 数据库操作元件，用于查询输入的工号是否正确，正确跳到20000元件，不正确跳到10200元件播放输入的工号不正确请重新输入。
20000 | 作用同10000元件，在[程序1]中的指定变量设定中，将日期指定给变量1、时间指定给变量12、来电号码指定给变量2
20001 | 播放导航语’ 签到请1，记录机房信息请按2，查询签到情况请按3，查询机房信息请按4’，当按1时会跳到21000元件、按2跳到22000元件、按3跳到23000元件、按4跳到24000元件。
21000~21040 | 之间的元件实现签到，21000数据库操作元件自动验证签到人员 的电话号码是否是指定网点代表电话，如果不是跳到20010元件播放‘不是相应机房电话’挂断电话。是代表电话到21021听到语音提示后输入进入机房的原因，21030数据库操作元件将数据记录到数据库中。21041元件是让签到人员选择返回总菜单按*号件，结束请挂机
22000~22233 | 之间的元件实现记录机房信息。 22000数据库操作元件同10100元件。 22019、22022、22024、22026、22028、22030、22032、22034物件指定元件分别将不同的语音文件写入到Dentry.txt文本中。 22020、22023、22025、22027、22029、22031、22033、22035按键输入元件分别播放上边Dentry.txt文本中的语音用户根据语音提示选择相应的按键。 22040数据库操作元件将用户输入的机房状况信息写入到数据库中。
23000~23028 | 查询签到情况。 23001按键输入元件查询人员输入密码 (将输入的密码给变量4)，到 23010元件查询该员工是否有权查询信息，如果没权跳到23011元件播放’该员工无权查询信息’挂断电话。如果有权跳到23016元件输入机房代号(给变量8)，23018元件查询结果不存在跳到23020元件播放’该机房不存在’挂断电话。存在到23018查询机房最近一次签到情况，到23022元件根据签到工号查询姓名。 23026文字播放元件’**机房*月*日*时**工号姓名来签到’ 23028按键输入元件选择重听或返回总菜单。
24000~24026 | 查询机房信息。 类似查询签到，先验证密码在验证机房代表号码，通过24025文字播放元件播放查询到的机房状态信息。
30000~30010 | 录制流程中所有的语音。根据给出的语音文件号录制相应的语音文件通过10001元件按键输入“*#*”按键，听到提示音后键入语音文件号，录制完一段语音后按#结束后，提示音“重听请按1，重录请按2、取消请按3、确定请按0”当按完0键后会继续录制下一语音文件最后全部录制完成后直接挂机，所有的语音文件都存放在c:\voice,所有的语音文件格式是‘wav’


车站、机场 电话语音客户服务系统

火车站电话语音客户服务系统

需求：铁路电话语音查询系统， 具人性化设计，真人语音代替了僵硬的电脑发声；可查询包括全国 列车时刻查询，中转车站，票价及晚点，临客查询。服务旅客，提升形象! 还可结合网上查询管理

系统功能： 火车站 电话语音系统应答 功能流程：

“您好，这里是火车站电话语音客户服务系统

列车到开时刻查询 请按1

列车票价查询 请按2

目的站车次查询 请按3

售票网点查询 请按4

旅客旅行常识 请按5

行包查询 请按6

车站介绍 请按7

人工服务 请按8

重听 请按0 ”

使用元件： 程序连接元件、物件指定元件、按键输入元件、数据库操作元件、文字播放元件、语音录制元件、语音播放元件

技术实现：

元件代号 功能介绍

10000 招呼语

1——》11000 列车到开时刻查询

2——》12000 列车票价查询

3——》13000 目的站车次查询

4 ——》14000 售票网点

5——》15000 旅客旅行常识

6——》16000 行包查询

7——》17000 车站介绍

8——》18000 人工服务

*——》 10000 重听

11000 列车到开时刻查询
1——》11100 发车查询
2——》11200 到车查询
3——》11300 晚点信息
4——》11400 加开列车

11100 发车查询
1——》11110按车次查询
2——》11120按方向查询
0——》11000上一级
11110 按车次查询（输入车次数字部分）
11111 物件比较 11112 ~ 11114查询数据库
11115 赋值》11116 放音》11117 按键输入》11116重听

11120 按方向查询
1——》11121哈尔滨方向
2——》11122鹤岗方向
3——》11123双鸭山方向
4——》11124牡丹江方向
5——》11125富锦方向
0——》11100
11200 到车查询
1——》11210按车次查询
2——》11220按方向查询
0——》11200上一级 类似 发车查询 11210~11228
11300 晚点信息查询（输入日期——》11300~11340 元件）
11400 加开信息查询（输入日期——》11400~11440 元件）

12000 列车票价查询
1——》12100 按车次查询
2——》12200 按始发、终到站查询
0——》10000上一级

12100 按车次查询（输入车次——》12101）
12101
1——》12110全程查询
2——》12120站站查询
0——》12100上一级
12110 程序连接——》12111 （复杂查询计算生成要播放的语音信息）
12111 播放信息——》12112
12200 按始发、终到站查询（输入始发站电话区号，终到站区号——》12210 ）
12210 程序连接——》12220 （复杂查询计算生成要播放的语音信息）
12220 播放信息——》12230

13000 目的站查询（输入目的站邮编/区号——》13100）
13100 程序连接——》13200 （复杂查询计算生成要播放的语音信息）
13200 播放信息（报出5个直达，如果没有，报出5个中转，再选择）

14000 售票网点查询 ~

15000 旅行常识 ~

16000 行包查询 ~

17000 车站介绍

18000 电话转接

设定流程图例：

结合“触摸屏”，实现多方位的客户服务；旅客一个电话可查询到所需；来到车站，更多了一种方式：

机场电话语音问询服务系统 实例：

您好，这里是三亚凤凰机场航班查询系统按航班号

查询当日航班 请按1
按城市电话区号当日航班 请按2
航班计划查询 请按3
旅客民航常识信息 请按4
人工服务 请按5
重听 请按0

流程图例：

北京天羚季德科技有限责任公司
电话：010-62131778 62136916 62145328 天羚语音首页