电脑语音广场

WWW.TeleLink.com.cn

以IVR 为基础，以呼叫中心为功能导向，以一体化IP PBX 通信呼叫中心平台为目标

AG32 ® 电脑语音广场 ® 电话呼叫系统流程生成器 辅助使用手册

第1章 安装 1-0

1.1 电脑语音广场内容 1-1 ［内容及配置］

1.3 软件安装 1-3

第2章 软件包功能介绍 2-0

2.1 电话语音管理程序功能介绍 2-1

    流程设定 　线上模拟 语音设定 　电话设定 传真线设定　 电话监视程序

2.3 应用软件备份程序 2-3

2.4 应用软件载入程序 2-4 2.5 讯号模拟程序 2-5

2.6 传真观察员 2-6 2.7 电话监视程序 2-7

2.8 语音软件生成器 2-8　 ［用来开始编辑制作和生成应答业务流程！］

2.9 语音侦测程序 2-9 2.10 语音设定程序 2-10

2.11 电话语音模拟程序 2-11

2.12 电话设定程序 2-12 [接听电话选项，电话选项]

2.13 传真线设定 2-13

第3章 语音软件生成器 3-0　［开始制作电话应答流程］

3.1 语音元件功能表 3-1 [ 增加、修改、删除元件 , 特殊音侦测设定]

3.2 工作日志 3-2　［用于个人语音信箱］

3.3 系统设定 3-3

元件资料路径设定 来电设定 元件设定 传真设定 电话设定 时间设定维护设定 电话线监控设定 外部程序沟通设定 拨号文件功能设定 外拨设定 其它设定 设定为接电话元件

第4章 各种语音元件功能 4-0

4.1 元件基本设定 4-1 | 4.2 只播放语音元件 4-2
4.3 按键输入元件 4-3 | 4.4 语音录制元件 4-4
4.5 电话转接元件 4-5 | 4.6 发送传真元件 4-6
4.7 远端遥控元件 4-7 | 4.8 程序连接元件 4-8
4.9 语音切换元件 4-9 | 4.10 文字播放元件 4-10
4.11 拨电话元件 4-11 | 4.12 通道连接元件 4-12
4.13 收传真元件 4-13 | 4.14 邮件收发元件 4-14
4.13 数据库操作元件 4-15 | 4.14 物件指定元件 4-1 6

第5章 生成器的其他功能 5-0　［拨号，系统语音，语音信箱］

5.1 文本文件 DIAL.TXT 5-1　［使语音系统实现拨号，制作拨号任务列］

5.2 中文文字转语音 5-2　　　5.3 中文 TEXT-TO-FAX功能 5-3

5.4 侦测是人、答录机或传真机接电话 5-4

5.5 三方通话功能 5-5

5.6 听取留言、远端遥控 5-6　　　5.7 系统语音 5-7

第6章 使用语音、传真范例 6-0

第7章 电话语音查询系统 7-0

7.1 一般的语音查询应用 7-1

第8章 电话语音信箱系统 8-0

第9章 AG32 简要培训 9-0

第10章 其他语音系统及相关知识 10-0


AG32 安装

<电脑语音广场> 第1章 安装

上一节 下一节 上一章 下一章 回总目录

1.1 电脑语音广场内容 1-1

1.2 所须个人电脑配置 1-1

1.3　软件安装 1-3

1.3.1 桌面

1.3.2 使用资源管理

1.3.3 检查是否安装成功

1.4 增加线数 1-3


ch2

电脑语音广场 第2章 功能介绍

2.1 电脑语音管理程序功能介绍 2-1

2.1.1 元件设定 2.1.2 线上模拟 2.1.3 语音设定 2.1.4 电话设定

2.1.5 传真线设定 2.1.6 电话语音监视程序

2.2 电话语音自动外拨系统

2.3 应用软件备份程序 2-3

2.4 应用软件载入程序 2-4

2.5 讯号模拟程序 2-5

2.6 传真观察员 2-6

2.7 电话监视程序 2-7

2.8 语音软件生成器 2-8

2.9 语音侦测程序 2-9

2.10 语音设定程序 2-10

2.11 电话语音模拟程序 2-11

2.12 电话设定程序 2-12

2.12.1 接听电话选项 2.12.2 打电话选项

2.13 传真线设定 2-13


语音软件产生器

《电脑语音广场》 第3章 语音软件生成器

3.0 语音软件产生器 [开始编辑应答流程]

3.1 语音元件功能表 3-1

3.1.1 增加、修改、刪除元件

3.1.2 特殊音偵测设定

3.2 工作日志 3-2

3.3 系统设定 3-3

3.3.1 更改元件流程路径 3.3.2 使用者管理 3.3.3 使用者设定

3.3.4 传真设定 3.3.5 电话设定 3.3.6 时间设定

3.3.7 维护设定 3.3.8 电话线监控设定

3.3.9 外部程序沟通设定 3.3.10 拨号文件功能设定

3.3.11 外拨设定 3.3.12 其它设定

3.3.13 设定为接电话元件 3.3.14 数据库设定 3.3.15 电子邮件设定


ch4

《电脑语音广场》 第4章 各种语音元件功能

4.0 各种语音元件功能 4-0 | 4.1 元件基本设定 4-1
4.2 只播放语音元件 4-2 | 4.3 按键输入元件 4-3
4.4 语音录制[留言]元件 4-4 | 4.5 电话转接元件 4-5
4.6 发传真元件 4-6 | 4.7 远端遥控元件 4-7
4.8 执行程序元件 4-8 | 4.9 语音切换元件 4-9
4.10 文字播放语音元件 4-10 | 4.11 拨电话元件 4-11
4.12 多方会谈元件 4-12 | 4.13 收传真元件 4-13
4.14 个人元件设定 4-14 | 4.15 数据库操控元件 [对数据库操作]
4.16 物件指定元件 [对变量赋值] | 4.17 物件比较元件 [变量参数比较]
4.18 邮件收发元件 [在局域网内收发邮件] | 见５０ＡＰ示例


ch5

《电脑语音广场》 第5章 生成器的其他功能

5.1 文字文件DIAL.TXT 5-1 [拨号任务文件]

5.2 中文文字转语音 5-2

5.3 中文TEXT-TO-FAX功能 5-3

5.4 侦测是人,答录机或传真机接电话 5-4

5.5 三方通话功能 5-5

5.6 听取留言、远端遥控 5-6

5.7 系统语音 5-7


ch6

《电脑语音广场》 第6章 使用语音、传真范例

6.1 应用范例 6-1

6.2 线上模拟测试 6-2

6.3 执行一种应用范例 6-3


ch8

《电脑语音广场》 第8章 电话语音信箱系统

8.0 电话语音信箱系统 8-0


外部程序开放性

AG32 的开放性 和 与外部程序连接说明

AG32语音生成器是一个开放式的语音生成平台，它可以与任何外部程序配合执行，可以由外部程序去控制语音系统的流程走向，而应用程序开发者无需去了解语音卡的硬件操作。即可设计出一套专业的电话语音系统。

AG32由多个元件模块组成，每个模块都是一个子程序，模块的功能参数设定简易
，模块之间都有功能完成后走向的设定，例如，按键输入元件完成后走到数据库操作元件。
AG32的开放式集中体现在(程序连接元件)，当AG32程序执行到此功能元件时，一般系统立即产生二个文件，它们是REQ(N).TXT、EXEREQ(n).TXT,其中N代表语音卡的第几线，REQ是一个空文件，用来通知您的应用程序执行操作，EXEREQ内含有需要执行操作的内容代码，例如内容为（420，c:\path,2003/12/18 pm 12:18:18）
其中420为可定义的程序运行某种操作的识别代码；后面为目录和时间。

这个功能元件有二个出口，一个是等待时间，如果外部程序在一定的时间内没有回应；另一个是外部程序发出的回应，即产生一个回应文件EXEACK(n).TXT，可以是一个空文件，AG32在等待时间内发现此文件，会立即删除此文件，并根据GOTOBOX(n).TXT内设定的元件内容走到此元件去执行；所以外部程序在生成EXEACK(n).TXT之前还必须生成GOTOBOX(n).TXT和一些必要的文件，比如VOICE(n).TXT(此文件用来组织放音的信息)，VMSLINK(n).TXT，DIAL.TXT(让AG32自动往外拨号)等；

所以外部程序与AG32沟通需要如下动作：为了实时监视REQ(n).TXT，一般程序采用一个TIMER计时器，执行操作如下：
[
IF FileExists(req[i].TXT)
then
//读取文件exereq[i].TXT内容给字符串ls_Emp_exereq[i]
//读取文件VMSLINK[i].TXT内容,此文件内一般含有来电者的按键内容
//删除文件exereq[i].TXT，req[i].txt，如不删除您的时钟将重复操作

filedelete(exereq[i].txt)
filedelete(req[i].txt)
//执行您的程序操作，例如对数据库进行操作，获取必要的数据信息
{
...........
}
//务必请生成如下两个文件 GOTOBOX(n).TXT，EXEACK(n).TXT和一些所需其它文件，比如VOICE(n).TXT(此文件用来组织放音的信息)，VMSLINK(n).TXT，DIAL.TXT(让AG32自动往外拨号)等；

请注意EXEACK(n).TXT必须最后生成。
]
到此一次沟通完成。
利用循环语句完成多线路的处理

这是一种利用文本实现沟通的最简易的方法，适合任何程序；当然AG32也提供动态连接库(DLL)的沟通方式更有效率。但是对一般的应用，文本字符串沟通的方式最实用和简易。DLL方式在此不做说明，请电话咨询。

现在，对某些呼叫中心应用，AG32 也开放windows socket 端口，以使用户程序实时了解线路状况并采取相应的操作，如当坐席分机振铃时，用户程序可以收到信息，以便及时调出客户服务资料等应用；同时也提供基于soap 的webservice 信息访问！


AG32 快速数据库语音查询例程

AG32 电话语音系统应用平台包含了 GUI 电话流程编辑环境，语音通讯管理服务器，AG32 集成工作室（软件产生器,流程载入备份管理工具，传真管理工具，实用系统模拟器，信号侦测工具，语音管理工具等）；AG32 可使各个技术层次的程序员或应用级人员能够快速部署即使最复杂的电话语音应用方案，过去得花高级程序员几周甚至几月时间才能创建的应用程序，现在一般应用人员只要几小时或几天就足够了；而且由于AG32 的多年稳定性检测，维护的方便性，更免去了客户的后顾之忧，应用成本大大降低

自动化平台软件 AG32 经过多年历练;功能齐全但简单易用,尤其便于维护;总体使用成本明显优于同类产品.交付用户使用的速度绝对快于任何竞争对手!

AG32 通用电话语音系统软件,本软件主程序含有17个多功能元件模块[P1~P17]

一个简单的查询系统设定可由四个模块元件组成，元件都有一个代码表示，并且含有几个子程序：

1：按键输入元件[播放语音，并且接收DTMF电话按键，把按键值放入一个变量或写入连结文件],元件排序:P 4

2：数据库操作:访问数据库 [使用 通用的SQL 语句] 元件排序:P13

3：指定赋值:取数据库字段的值并赋给变量，定义需播放的语音文件，变量赋值等 元件排序:P14

4：播放语音 [包括文本转语音] 元件排序:P 5

电话语音主程序界面: [正常运行时可以隐藏为右下角的一个小闪烁绿标]

流程设定> 流程产生器 设定图如下： [每一个元件模块如下图 001000为按键输入元件P4，可由6 位数为代号代表，方便记忆，一般可从1到 999999，不够6位，前面都是0；一个简单的系统我们习惯上把开始的定义为1000，不同的功能菜单，客户在生成使用的时候最好能间隔分开例如1000~1900，2000~2900等，因为所有元件排队是按顺序排列的]

双击某一个元件,或元件>修改 就可以改变设定.

1：按键输入元件P4 功能为： 您可把按键值或常数指定给变量，留作下一元件模块使用。例如下一个元件为P13《程序二》 设定：选定{按键值指定给变数} 第一次按键指定给V1，下页进入P4 的《程序3》

P4 的《程序3》

一般选取《依据按键值，执行对应的元件》您可以定义一些一位的特殊按键，以便使用户进行其他项。<程序2>已经由用户输入了按键，此处定义按键完成后到哪个元件去执行。下图显示：其他 >>13000 元件和未输入等几个选项；表示： 用户只要输入了非0和*按键值，都会进入13000 元件 ； 例如13000 元件为查询数据库；

[挂断音/特殊音设定对所有元件定义都一样。]

2: 数据库的联结设定须首先在 [设定S]》资料库设定内设定　数据源名称，访问者及密码。 数据源设定在《控制面版》32 ODBC 中设定。首先保证此数据源联结正常，否则将不能正常访问数据。

选取《查询》：联结数据源名称，及查询的SQL语句。此处也可执行任何标准的SQL 语句，包括 SELECT、DELETE,UPDATE 等; 执行成功与否根据《程序三》的元件走向进入其他元件节点。

3: 本元件 的《程序二》 取数据库值 和对变量 或文件赋值

上一步数据库操作已经定位了数据库的记录，把所查询到的纪录指向了 一个临时表内，例如table1

[本系统每线可提供30个临时数据表，供用户使用]

本元件即希望取出某一字段/栏位的数据，并赋值

指定设定：型态》栏位：选择TABLE1，栏位名称为PRICE，指定给V2, 意思是把TABLE1 的PRICE 字段内容取出，且指定赋值给变量参数 V2, 然后按添加箭头，在下面的表内显示。

您也可以按修改按钮，修改；也可以赋值给到一个文件，例如：voice1.txt[1,代表第一线路]

4: 文字/语音文件放音: 此模块可以实现放音的功能， 无论是文本文字信息，语音文件，日期，金额，数字或是他们的组合 都可以按用户的要求顺序播放。 用户也可以加载其他 TTS 引擎，配合此元件使用，得到需要的效果。

以上四个元件的举例是一个简单又实用的应用，用户可以安排多重按键输入元件模块，实现多级菜单的语音查询。少则 几个元件，多至上千个模块组合，整合 语音/传真/EMAIL 应用，完全可以方便的生成用户的主要业务流程。

呼叫中心的主流 IVR 应用，立刻手到擒来。 更重要的是： 未来的业务流程改变，维护特别的简单！ 昂贵的维护费用从此省却！

欢迎即刻选用我们的产品。

在 产品出货光盘内，AG32 同时还提供几十多种不同行业不同种类模板，供用户参考。

www.telelink.com.cn 北京天羚季德科技有限责任公司 010 62145328 62131778 62186575 转611

www.telelink.com.cn 北京天羚季德科技有限责任公司 010 62186575 62131778


AG32

AG32 3.0 简要培训手册 电脑语音广场 各程序菜单说明 [可能对不同语音卡有所不同]

传真观察员 ：浏览各类型的传真文件

传真设定程序 ：设定/检测传真线路的参数

电话监视程序 ：通过窗口观察电话应答流程,可观察到流程是否完善

电话语音管理程序：主运行程序，不要与软体产 生器一起运行。

语音软件产生器 ：设计电话应答流程，所有元件在此 体现和被组合。

电话语音模拟程序：使用此程序，利用语音卡的 PHONE 口的电话机，模拟电话打入 的动作，您不接电话线即可编程 [对天羚语音卡有效]

讯号模拟程序 ：设定完流程后，利用此程序可以 按照您预定的用户输入流程，实现 多线程的模拟测试。[仅天羚卡适用]

语音侦测程序 ：设定和测试电话线路上的各种讯号[仅天羚卡适用]

电话语音备份程序/ 电话语音载入程序：当您设计完流程后，利用此程序可以备份和载入系统不会因系统的损坏而丢失流程

Ag32 结构
AG32 17 个语音/传真功能元件

元件盘里共同的事件

元件盘里共同的设定：

应用事例

下面我们利用几个元件说明如何实现简单的查询系统

1: 按键输入元件

2: 程序连结元件 [在 AG32 3.0 后,可用 P13/P14/P15 组合，无需再依赖外部程序]

3 :文字播放元件 [或语音播放元件]

：按键输入元件[播放语音，并且接收DTMF电话按键，把按键值放入一个变量或写入连结文件],元件排序:P 4

2：数据库操作:访问数据库 [使用 通用的SQL 语句] 元件排序:P13

3：指定赋值:取数据库字段的值并赋给变量，定义需播放的语音文件，变量赋值等 元件排序:P14

4：播放语音 [包括文本转语音] 元件排序:P 5

电话语音主程序界面: [正常运行时可以隐藏为右下角的一个小闪烁绿标]

流程设定> 流程产生器 设定图如下： [每一个元件模块如下图 001000为按键输入元件P4，可由6 位数为代号代表，方便记忆，一般可从1到 999999，不够6位，前面都是0；一个简单的系统我们习惯上把开始的定义为1000，不同的功能菜单，客户在生成使用的时候最好能间隔分开例如1000~1900，2000~2900等，因为所有元件排队是按顺序排列的]

1：按键输入元件P4 功能为： 您可把按键值或常数指定给变量，留作下一元件模块使用。例如下一个元件为P13《程序二》 设定：选定{按键值指定给变数} 第一次按键指定给V1，下页进入P4 的《程序3》

P4 的《程序3》

一般选取《依据按键值，执行对应的元件》您可以定义一些一位的特殊按键，以便使用户进行其他项。<程序2>已经由用户输入了按键，此处定义按键完成后到哪个元件去执行。下图显示：其他 >>13000 元件和未输入等几个选项；表示： 用户只要输入了非0和*按键值，都会进入13000 元件 ； 例如13000 元件为查询数据库；

[挂断音/特殊音设定对所有元件定义都一样。]

2: 数据库的联结设定须首先在 [设定S]》资料库设定内设定　数据源名称，访问者及密码。 数据源设定在《控制面版》32 ODBC 中设定。首先保证此数据源联结正常，否则将不能正常访问数据。

选取《查询》：联结数据源名称，及查询的SQL语句。此处也可执行任何标准的SQL 语句，包括 SELECT、DELETE,UPDATE 等; 执行成功与否根据《程序三》的元件走向进入其他元件节点。

3: 本元件 的《程序二》 取数据库值 和对变量 或文件赋值

上一步数据库操作已经定位了数据库的记录，把所查询到的纪录指向了 一个临时表内，例如table1

[本系统每线可提供30个临时数据表，供用户使用]

本元件即希望取出某一字段/栏位的数据，并赋值

指定设定：型态》栏位：选择TABLE1，栏位名称为PRICE，指定给V2, 意思是把TABLE1 的PRICE 字段内容取出，且指定赋值给变量参数 V2, 然后按添加箭头，在下面的表内显示。

您也可以按修改按钮，修改；也可以赋值给到一个文件，例如：voice1.txt[1,代表第一线路]

4: 文字/语音文件放音: 此模块可以实现放音的功能， 无论是文本文字信息，语音文件，日期，金额，数字或是他们的组合 都可以按用户的要求顺序播放。 用户也可以加载其他 TTS 引擎，配合此元件使用，得到需要的效果。

除了文字播放，用户也可选择其他如发送传真，或继续其他元件；不同的组合将生成优美的语音传真系统；简单如三个元件，复杂如3千个元件组合，您都会应付自如


天羚语音卡及语音侦测程序

北京天羚季德科技有限责任公司

天羚 PCI语音卡 的安装注意点：

当语音卡插入pc 后，在windows 2000 下会发现一个设备，安装驱动指定指向 光盘根目录\WIN200 安装设备驱动；完成后才安装 AG32 或其他应用程序[管理语音卡的程序]

www.telelink.com.cn


东进DN语音卡的安装

2：东进DN 语音卡的安装

注意：当东进语音卡插入pc 后，在windows 2000 下会发现一个设备，安装指定指向 DJNADK V1.XXX \\WIN2000 或光盘根目录\WIN2000安装设备驱动；完成后可能在设备管理器内有一个问号？ ；不要担心，没有关系 ！

完成后再安装驱动光盘 DJNADK V1.XXX \\ DISK1 或SDK 下内容，重起并按图设定 。

在程序菜单：

并可在服务内设定为自动启动方式。


Intel-Dialogic语音卡的安装

美国 intel-dialogic 语音卡的安装：

1: 安装 光盘下的光盘驱动程序 SR6.0 或 5.11 版本 或其他版本[不能混合安装]

注意：当dialogic 语音卡插入pc 后，在windows 2000 下会发现一个设备，

不要安装任何相关驱动，忽略或取消

安装INTEL_Dialogic 驱动光盘内的 setup, 只需选择最小安装[22M](minimum 或 typical)

安装以前请停止其他应用程序，如防病毒软件等；完成以后请按图执行：

在程序菜单：

For D4PCI UF: 设定下次自动启动方式：

For D4PCI 设定下次自动启动方式：

其他系列语音卡也、并可在类似系统服务内设定为自动启动方式。


三汇SH语音卡的安装

2：三汇 语音卡的安装

注意：语音卡插入pc 后，windows 下会发现一个设备，先取消！类似dialogic

然后安装三汇驱动程序 shcti5.XX, 会自动安装语音卡的驱动

完成后可以启动如下程序，配置语音卡

在程序菜单：

如安装完成语音卡后，可以启动天羚AG32 程序，就无需配置，意味着出厂前已经配置好三汇语音卡；如不能启动

就需要启动此程序，点击缺省配置，如语音卡安装正常，就会显示正常的语音卡信息。然后点击应用即可


ch8

附录 4： 电话语音卡及其他语音系统

自动总机系统自动转接外来的电话到分机，若无人接听或忙线中，来电可留言，留言后自动呼叫 手机或发送短信、EMAIL等。每一位公司职员有一个专属的语音信箱，以听取留言。自动系统能提升公司形象，节省总机人力。

自动总机系统其功能包括：

  1. 转接电话

  2. 留言、留言后可以设定为自动呼叫Mobile。

  3. 远端遥控听取留言。

  4. 播放招呼语，不同时段提供不同总机语音或走不同路径。

总机系统的种类

总机系统分为两类，一为电子交换机（PABX），二是按键式电话系统

（Keyphone System）。

1． 电子交换机（PABX）

分机线一般为二芯电话线，分机线可接一般的电话线（如家用电话机）、传真机或数据机，拨外线的方法为按 0或按9接到外线。

2． 按键式电话系统（Keyphone System）

分机线一般为四芯电话线，分机线不可接一般的电话机（如家用电话 机）、传真机或数据机，拨外线的方法为按不亮键接到外线，接到本系统的所有分机线，必须加装音频卡，将之转成可接一般电话机可以使用的分机线，

音频卡系由按键电话系统提供，各厂家不同。两者之间差别表列如下：

 | 电子交换机 PABX | 按键式电话
分机的电话线 | 一般为二芯线 | 一般为四芯线
分机线可接一般的家用电话机、传真机吗？ | 可以 | 不可以
分机线的电话机 | 可接家用电话机 | 特殊按键式电话机
分机拨外线的方法 | 按 0或9接到外线 | 按不亮键接到外线
外线来电时，必须能设定优先响那几条线分机 | 是 | 是
自动总机系统 | 直接接到本系统 | 必须加装音频卡

适合作自动总机系统的总机系统，必须符合以下条件：

1． 接到系统的分机线为单机，即分机线可接一般的家用电话机、传真机或数据机。

2．外线来电时，必须能设定优先响铃的分机，如果原来设定外线来 电时，所在分机都一起响铃，改成自动总机系统时，必须设定优先 响铃是那几条分机。

3．任一分机A，打电话到本系统所接分机B，分机A按键，分机B 可听到按键音，如此才能经由分机听取留言。

电子交换机 PBX的自动总机装线法：

外线 >电子交换机>优先响铃的前几条分机线 >本系统

一般的总机系统可设定外线来电时，最优先响的分机线，自动总机系统就是将这些最优先响的分机线接到语音卡上。

按键式电话系统的自动总机装线法：

外线按键式电话系统[KEYPHONE SYSTEM]

最优先响铃的分机线经音频卡接入本系统

注意：

某些按键式电话 KTS的总机系统，无法将分机的按键音（DTMF）传到另一分机，即无法透过一个内线的分机电话，

打电话到本系统所接的任一分机，以听取留言。须透过分机，拨外线，打电话到本系统听取留言。

数字电话系统 开放 CTI 接口的自动总机系统，需通过 CTI LINK 控制

自动总机系统电脑配备

自动总机系统，须使用几片四线语音卡呢？须使用什么样的电脑配备呢？由于只有外线来电才会占用到语音线，

本系统转接到其分电话分机后，与分机拨外线，都不会占用到语音线，考虑同时会有几条外线来电，即为所须使用的语音线数。

一般而言，外线数目的 1/2（甚至于1/3）即为所须使用的语音线数，四线语音卡可同时处理四条外线来电，即：

所须使用的四线语音卡片数=（外线数目）/2/4

如外线 8条须使用一片四线语音卡。

所须使用的语音卡片数，与建议使用的电脑配备如下

  • 外线数目

    使用的语音卡片数

    建议所须使用电脑配备

    2--8

    1-2

    C2.0 以上，含64MB以上内存

    -16

    2-4

    C2.0 以上，含128MB以上内存

    17-24

    3-6

    P2.4 以上，含512MB以上内存

    25-32

    4-8

    P2.8 以上，含512MB以上内存

所须使用的其它电脑配备，如下：硬盘建议可用空间120MB以上及显示器、器、中文Windows/NT/2000/XP/2003 和鼠标；因一般电脑只剩3-4个槽可插ATX PCI BUS 的语音卡，若插4片以上的语音卡，用槽较多（10-20个槽）的工业电脑。

Voice mail port设定 [交换机语音信箱端口]

设定程序

设定流程同一般设定，但必须把所有监控过程，都 Disable 掉

．系统设定键〉人工总机页〉转接人工总机选项的监控转接过程取消设定。

2．将在分机设定内所有分机的监控转接过程设定取消。

3．设定>来电挂断设定> 新增一组挂断音，侦测使用Voice mail port 之后挂断音的新频率。

4.3 注意事项

在自动总机系统之中，有些设定选项是以 输入即表示启用û 之意来设定，对于这些设定若不需要使用，

请将这些栏位空白。

这些栏位如下：

系统设定内> 系统参数页的> 登入密码 栏位。人工总机〉 页的 人工总机顺序 ，转接分机页的分机前置码 ，分机的后置码

及 拉回转接控制码栏位，以及 其它设定 内的 外拨前置码 栏位。

使用交换机 Voice mail port 功能时请将人工总机及各分机的 监控转接 都取消掉并在 接电话后的延迟 栏，

输入一小段时间[50]，以配合交换机自行拉回动作的延迟。

通道的设定功能中，通道和处理模式，以单一功用（单纯接电话或单纯外拨）最好，否则易冲突。若要有此多重功能，

请尽可能的将其设定在最后几通道，防止占线情况，并在 系统设定 中来电的 等待铃响数 栏位设大一些（2即可），可预防上述状况发生。

使用交换机 Voice mail port 功能时，请务必将所有要使用的线路及接自动总机的线路都设定好（请洽各交换机厂商），

并重新侦测挂断音等频率，因为此功能会更动交换机上的一些声音频率。

使用 Voice mail port 功能时，最好将拉回的代码，设为一码。如忙线设为AXXX表该分机XXX号码无人接听，

设为 BXXX并在其相对的代码，设定在工作的作息表按键值内。而其按键长度设为4（分机号码长度＋1）

语音侦测程序 [天羚语音卡适用，其他如DIALOGIC 提供的pbxexpert等测定程序]

语音侦测程序是使用者在规划一套语音系统时，所必须使用到的应用程序。

它除了支援多种的工具供系统开发时使用，并且还可调整系统上的一些设定，其功能大致如下:

· 提供语音文件的录制、播放及切除等功能，以便使用者录制系统所需的语音文件。

· 提供语音文件转换功能，可转换多媒体.WAV语音文件，增进两者的互通性。

· 能智能学习当地局线或交换机的挂断音讯号，并设定来电挂断的讯号特性。

· 能智能学习当地局线或交换机的回响铃、忙线音等讯号，并设定打电话或转接电话的讯号特性。

· 提供检查语音文件功能，以确定所录制的语音文件不会被误判成按键音或挂断音。

AG32 程序菜单介绍

AG32 电脑语音广场 IVR 语音平台软件及呼叫中心系统提供高层次的使用介面，能简化应用软件的开发过程及缩短开发时间，轻松地完成多线语音的处理作业。另外语音范例程序提供完整的原始流程及说明，能让初学者轻易地就会制作编写语音应用软件，并且无需编制程序，就像使用office 一样简单，开放的设计，让使用其他语言的工程师可轻易集成

AG32

文本框: 语音流程产生器 ? 一套用于产生互动式语音回复的语音流程产生器 ? 完全整合的功能列表 ? 内建数据库及访问能力 ? 可与外部程序连结 ? 由选购的外挂模组可达到文字转语音的功能 ? 与TAPI完全相容，适用于Windows 98／NT/2000平台

文本框: 程序执行及监控 ? 模拟侦测程序可用于除错 ? 可线上即时监控线上流程 ? 可自行设定每条电话线执行不同或相同的电话流程 ? 可同时执行多个应用软件 ? 每部电脑最多可接128条电话线同时动作

文本框: 语音流程控制 ? 自动侦测语音及传真信号 ? Caller ID及PABX的数据侦测与设定 ? 电话转接操作 ? 会议功能 ? 特殊信号处理

UMS 企业统一通信系统：[TOFFICE，Ecrm]

Telephony Office, Total Office, eCRM Based Office IPPBX

其他桌面功能： 扫描传真 （Scan to fax） 电脑通话 （IP Talk） 电话回叫 ( Call me back) (Call Me later)

电子商务的基础：

《企业统一通讯系统+统一消息即时传递/信息管理》

统一消息系统功能：

个性化的问候语

单一，本地化的语音和传真号码

Follow-me 能力

POP 邮件侦测

安全的在线登录

电话遥控操作

自动通知信息的到来，传真/语音/email

语音邮件集成[电话，扫描立即传真，语音信箱，IP 通

文本框: 浏览器 (GUI)

文本框: 个人信息中心,个性化资讯中心。企业统一的客服界面

利用AG32 也可实现自动总机/语音信箱功能，设置界面图：


安装说明简要

用户自助安装语音系统安装步骤引导：

一：安装好操作系统 [windows 98/NT/2000/2003],PCI 卡一般不支持 98

二：打开电脑机箱，插入并固定好语音卡，启动电脑。。。安装硬件启动程序和驱动库

三：安装AG32［可根据光盘自引导安装：运行　ＩＮＳＴＡＬＬ．ＥＸＥ］

四：安装相关应用程序［可根据光盘自引导安装：同上］；如没有则走下一步

五：先安装加密狗驱动，后再插上加密狗［如没有提供，意味着是板卡序列号加密或试用版］

六：重启电脑，如程序>>电脑语音广场>>软件产生器 可运行>下一步; 否则进 “九“

七：软件产生器可执行代表全部安装正确，可看到流程内容进“十”；如空白：下一步

八：参考 ５０ＡＰ说明，载入一个流程或参考其他提供的说明；再测试。进 “十”

九：检查语音卡是否安装好［见不同语音卡之安装说明］和加密狗是否安装，进 “十”

十：开始　〉所有程序　〉电脑语音广场〉电话语音管理程序　［语音系统主运行程序］，会看到右下角有绿色图表闪烁，点击可在《电话设定》内设定线路的接电话元件号〉对应于软件产生器内的元件代号［例如１０００］，即打入电话后进入执行的功能元件代号。如没有则此时打入电话，刚接通又挂断－这种情况还有两个可能：Ａ：没有找到语音文件　Ｂ：软件产生器内＞设定〉其他设定〉外部程式沟通目录　不存在。

AG32 平台安装完成，另请参考相关[AG32 文档，或手册、附件]或请求天羚技术支持

光盘 目录说明：

1: [AG32] | AG32 主程序安装目录，包含19个程序子目录和几个程序例程，延续旧版做法,AG32安装程序也包含[driver]内容，无需重复安装。
2: [TTSAPP] : | 内含一个额外提供的中文文字转语音的支持微软语音引擎的语音库及测试程序，可在适当情况下安装此程序
3: [SanHui]: | 含有三汇语音卡的驱动应用程序，动态连接库或其他版本信息
[DJNADK...] | 含有国产东进DN系列语音卡的驱动程序，驱动库或带版本信息的目录
[DIALOGIC...] | 本目录下含有美国 DIALOGIC系列语音卡的驱动程序,如没有此目录，请征询语音卡提供商;如果为压缩程序，请解压缩后再安装
4: [工具软件] | 本目录下含有一些常用工具软件，有些需要注册才能完整使用
5: [50AP] | 含有天羚公司收集的基于 AG32 的各种例子，供集成商、用户参考
6: [MICRODOG] | 加密狗的驱动程序
7: [UserApp] | [“以用户相关信息命名的目录”]：内含一些相关服务内容,有个性化成分

[以上目录如不存在，则意味着非必须]

文档：

1：AUTORUN.INF : 引导文件

2： INSTALL.EXE ： 安装执行程序

3： SETUP.BMP ： 位图文件

4： TELELINK.GIF.ICO： 位图文件

5： 安装说明.chm 语音卡的说明WEB 页

6： LICENSE.TXT 天羚软件包授权书

7： README.txt 说明文件

如何判断语音卡及软件是否正确安装: 能够执行语音侦测程序,或如软件产生器等软件.


ch7

《电脑语音广场》 第7章 电话语音查询系统

电话语音查询系统 7-0

7.1 一般的语音咨询查询应用 7-1

7.1.1 电信业务语音查询系统

7.1.2 成绩单语音查询系统

7.2 计费的语音查询应用 7-2

7.2.1 股市分析语音系统（会员制）

7.3 讯息即时回报的语音查询应用 7-3

7.3.1 股市成交即時回报系统

7.3.2 银行存款余额查询系统


AG32 电脑语音广场内容

<电脑语音广场> 第1章 第一节 电脑语音广场内容

AG32 电脑语音广场内容

AG32 电脑语音广场包含：

1: 电话语音卡：二、四或八线电话语音卡(可扩展，传真为选购项目)。

2: 语音软件产生器，含中文转语音(Text to speech)、

中文转传真 (Text to Fax) 软件、流程载入及备份程序

3: 各类电话语音、传真应用范例。

4: 软件光盘及加密锁或序列号。

5: 电脑语音广场使用手册。

所须个人电脑配备

        1. IBM PC/AT/ATX 相容电脑，含64MB以上内存。

        2. 所需硬盘空间 20 GB以上。

        3. VGA显示器, 鼠标

        4. 中(英)文 Windows 98/NT/2000/XP/2003。。。

建议使用电脑配备如下:

所需使用的语音卡线数 | 建议所需使用电脑配备
1-12 | C 2.0 ，含64MB以上内存
13-24 | Pentium 4 2.4，含128MB以上内存
25-32 | Pentium 4 2.8，含256MB以上内存
33-64 | Pentium 4 2.8， 含512MB 以上内存

注意:因一般电脑只剩2、3个ISA/或PCI 槽可插语音卡，若需卡数超过ISA/PCI槽数目，则必须用扩充槽数较多的工业电脑[工控机]。

硬件安装请参阅硬件安装手冊


AG32 软件安装

<电脑语音广场> 第1章 第二节 软件安装

1.3 软件安装 [软件提供方式可能是光盘，也可以通过公司网站下载压缩文件]

[对于INTEL-DIALOGIC,DN或其语音卡硬件的安装请参考各自的硬件手册]；在安装前，有可能请先作一份备份;WINDOWS 98/NT/2000/XP安装方式: [Win2000 等可在启动光盘时自动运行，如是下载的安装文件请解压缩以后按照指引安装]

1.3.1 桌面

在中文WINDOWS 98/NT/2000/XP/2003桌面上按【开始】键，选择【执行】。

在【执行】对话框中的指令行输入\Ag32\disk1\SETUP.exe或光盘:\install.exe按【确定】按钮后，按照默认下一步安装：

出现点击 Next 下一步进入以下画面：默认将软件建立在AG32子目录。

选择欲安装的磁盘目录，预设为将软件建立在AG32子目录下，再按【下一步】。选择欲安装的文件类別，再按【下一步】，如果不需要中文转语音的功能，可选择不安装中文转语音之语音库(约10 MB)，以节省硬盘空间。

[ 以上安装菜单可能有所变化，请选择需要的选项安装 ]

【安装语音驱动程序】：不同语音卡的语音驱动程序 [第一次必须安装]

【安装传真驱动程序】：传真驱动库程序 [第一次必须安装]

【安装传真打印机】 ：Fax Print驱动程序

【安装系统语音文件】：系统语音文件

【安装中文转语音文件】：中文转语音文件

选择安装默认文件夹名称，再按【下一步】即开始准备复制文件

开始复制文件直到完成。

选择立即重新开机，即安装完成。

1.4 增加 删除线数 [对大部分语音卡，软件可自动识别所需安装的线数]

如需要增加语音线数，例如由4线增为8线，请依照以下步骤进行。

<步骤1>

参考硬件安装手冊，将所有硬卡的I/O地址、内存地址及中断设定设为相同，并正确地设定卡号。

<步骤2>

重新设定【系统设定】、【电话线监控设定】将新增的线号，例如5,6,7,8用鼠标快速点击二次，第5,6,7,8线颜色将会变为使用中，若想停止某几线，则用鼠标快速点击二次，颜色将会为非使用中。

<步骤3>

天羚语音卡需要执行语音侦测程序，再依次个別测试和设定接到本系统的所有新增的电话线特性，若每条电话线的特性相同，

则在【全设定】选项中打勾设定所有电话线。

注意:未使用的硬卡不用拔走，未使用的电话语音线将不会接电话或打电话。


UMAX Hub 10 Software

<电脑语音广场> 第1章 第二节 软件安装

1.3 软件安装 [对于INTEL-DIALOGIC,DN或其语音卡硬件的安装请参考各自的硬件手册]；在安装前，有可能请先作一份备份;WINDOWS 98/NT/2000安装方式: [win2000 可在启动光盘时自动运行]

1.3.1 桌面

在中文WINDOWS 98/NT/2000桌面上按【开始】键，选择【执行】。

在【执行】对话框中的指令行输入\ag32\disk1\SETUP.exe或光盘:\install.exe。

按【确定】按钮后，出现以下画面：

按【下一步】按钮后，出现以下画面：将软件建立在AG32子目录。

选择欲安装的目录，预设为将软件建立在AG32子目录下，再按【下一步】。选择欲安装的文件类別，再按【下一步】，如果不需要中文转语音的功能，可选择不安装中文转语音之语音档(约10 MB)，以节省硬盘空间。

【安装语音驱动程序】：AG32语音驱动程序

【安装传真驱动程序】(Fax Daughter Board)：传真子卡驱动程序

【安装传真打印机】：Fax Print驱动程序

【安装系统语音文件】：系统语音文件

【安装中文转语音文件】：中文转语音文件

选择安装文件夹名称，再按【下一步】即开始准备复制文件

开始复制文件。

设定硬件中断号码，共用内存地址，I/O口地址，选择不会与现有硬件相冲突的地址，若有更改设定则相对硬件也要作同样的调整，详细调整方式请参阅硬件安装手冊。

若有选取【安装传真驱动程序传真子卡】，将会出现下列画面，

设定连接端口，共用内存地址及中断号码，按【OK】。

选择立即重新开机，即安装完成。

1.3.2 使用资源管理器

选择:\SETUP.EXE,或 install.exe

1.3.3 检查是否安装成功 [对于天羚语音卡,其他如INTEL,DN 卡请参考相应的管理工具]

在安装完后，重新开机，使用【控制台】下的【多媒体】检查。

检查波形声卡驱动程序是否安装成功，如果未成功，请使用电脑语音广场世纪版下的语音设定程序，检查 I/O、IRQ、Memory与卡上设定是否相同按【OK】再重新开机。

如果安装成功，因为语音卡也可当作声卡使用，所以使用者可使用Windows所附的录音程序播音或录音，请在【控制台】的【多媒体】将重播录音的默认装置设成　TALKS Playback 1及TALKS Record 1，

如下图所示：

注意：为避免系统及语音的应用程序共用同一个波形驱动程序，建议关闭掉声音事件的配置，

您可在【控制面板】下的【声音】中设定，将配置设成无声，如下图所示

1.4 增加线数

如需要增加语音线数，例如由4线增为8线，请依照以下步骤进行。

<步骤1>

参考硬件安装手冊，将所有硬卡的I/O地址、内存地址及中断设定设为相同，并正确地设定卡号。

<步骤2>

重新设定【系统设定】、【电话线监控设定】将新增的线号，例如5,6,7,8用鼠标快速点击二次，第5,6,7,8线颜色将会变为使用中，若想停止某几线，则用鼠标快速点击二次，颜色将会为非使用中。

<步骤3>

执行语音侦测程序，再依次个別测试和设定接到本系统的所有新增的电话线特性，若每条电话线的特性相同，

则在【全设定】选项中打勾设定所有电话线。

注意:未使用的硬卡不用拔走，未使用的电话语音线将不会接电话或打电话。


电脑语音广场功能介绍

<电脑语音广场> 第2章 第一节 电脑语音广场功能介绍内容

功能介绍

AG32语音传真 呼叫中心平台 工具的图示如下

    1. 电话语音管理程序功能介绍

执行开始\程序集\电脑语音系统产生器\电话语音管理程序，执行后即开始

做接电话 及打电话的工作

2.1.1 流程[元件]设定

按下此图示，执行电话语音软件生成器，提供多种不同功能的元件，在屏幕上架构各种语音元件关系和设定各语音元件功能，即可生成各种语音、传真 应用( 详细内容请参考第三章)

2.1.2 线上模拟 [特定语音卡]

按下此图示，执行电话语音模拟程序，模拟电话按键，可不用接电话机，即可模拟流程。 （详细内容请参考2.11节）

2.1.3 语音设定 [特定语音卡]

按下此图示，执行语音设定程序，设定语音卡的I/O位置，内存位置及中断号码。（详细内容请参考硬件安装手冊）

2.1.4 电话设定

按下此图示，执行设定各语音线，接听电话和打电话的日期时段及假日。（ 详细内容请参考2.12节 ）

2.1.5 传真线设定 [含总线的语音传真无需设定，自动对应选取]

按下此图示，执行设定语音线与传真线的并联设定，可以以一对一的方式设定语音传真线，并且可以任意组合一对一的语音传真，此设定仅用于多线传真。( 详细内容请参考2.13节 )

2.1.6 电话语音监视程序

按下此图示，以执行电话语音监视程序，为一电话语音监督程序，负责显示其执行过程于屏幕中，让使用者清楚地了解语音元件的执行流程，以达到监控的目的。（ 详细内容请参考2.7节 ）


应用软件备份程序

<电脑语音广场> 第2章 第三节 应用软件备份程序

2.3 应用软件备份程序

将您架构好的应用软件，用应用软件备份程序，备存到磁盘，光盘，USB或硬盘，下次需要时再用应用软件载入器载回系统 ，可保存已经设定好的运行参数。

【注意：备份程序会清除欲储存到路径内的所有文件内容。】

将您架构好的应用软件 流程备份存到磁盘，可移植到另一台电脑或在同一台电脑的硬盘驱动器也可以作备份。

a.准备几片已格式化(Format)的空白 光盘或其他介质例如USB 或硬盘。

b.关闭语音软件生成器、语音管理程序后，执行应用软件备份程序，按【继续】按钮后，出现以下画面，输入要储存到的驱动器及目录、叙述及元件范围，及要储存元件的来源目录按【确定】按钮:

【元件范围设定】

可选择全部元件及部份元件并根据你所选择的元件去做备份。您可选择想要备份元件到什么目录，则出现以下画面：

若所指定之目录已存在，则会询问是否要复盖？若要复盖就继续执行备份动作，若不复盖则不继续做备份动作。


应用软件载入程序

  • <电脑语音广场> 第2章 第四节 应用软件载入程序

    2.4 电话语音载入程序

    执行电话语音载入程序，出现

    步骤一： 选择要载入的路径

    步骤二： 选择保留或不保留目前的应用软件，选择不保留，则系统将删除原有应用软件。

  • 如果选择保留，则系统将原有应用软件与新的应用软件并存，不过号码相同的语音元件将被新的应用软件取代

    •


信号模拟程序

<电脑语音广场> 第2章 第五节 信号模拟程序

2.5 信号模拟程序 [对天羚卡有效]

可模拟外电进来时，一连串按键的信号，让系统自动执行，例如：语音系统设定2响接电话，则在字串中填入2个“R”或“r”。接著按键可自行填入流程中需要的按键值，但流程中元件与元件间可能会等待的时间需自行预估等待的时间，填入多少个“，”号。因为此模拟程序只负责送信息，并不负责等待外部程序是否已回应，所以外部程序可能会处理多久，需事先预估，然后在字串中填入适当的“，”号，再进行下一步骤。当一通电话流程结束后，模拟程序即会自动再回头重复字串的动作。(详细说明可参考附属应用程序使用手册)

若每个线路所需模拟的键皆相同，可填入欲模拟的字串【Set All】，再按【Start All】即开始模拟。

<电脑语音广场> 第2章 第五节 信号模拟程序


2

<电脑语音广场> 第2章 第六节 传真观察员

2.6 传真观察员

对传真文件作检视、编辑或打印。

<电脑语音广场> 第2章 第六节 传真观察员


2

<电脑语音广场> 第2章 第七节 电话监视程序

2.7 电话监视程序 [第三方工具]

其主要功能为显示侦错信息，于窗口中或将信息写入Ch(n).log文件中。例如：语音管理程序会将语音流程显示在窗口中，以达到侦错的目的；外部程序也可透过API的方式，将自己的信息显示在窗口中。

功能说明：

【打开侦错窗口】：打开欲监控的窗口。

【执行】：可设定是否要在每次监视程序打开后，自动执行某一程序。

【记录文件】：设定打开或关闭，将信息写入纪录文件功能，或清除目前窗口的所有信息。

【窗口】：设定窗口排列显示方式。


语音软件生成器

<电脑语音广场> 第2章 第八节 语音系统生成器

2.8 语音软件系统生成器 [业务流程制作生成工具]

语音软件生成器，提供多种不同功能的元件，在屏幕上架构各语音元件关系和设定各语音元件功能，即可生成各种语音、传真软件

详见第三章 语音软件生成器、第四章 各种语音元件功能。


语音侦测程序

<电脑语音广场> 第2章 第九节 语音侦测程序

2.9 语音侦测程序 [对天羚语音卡有效]

语音侦测程序是使用者在规划一套语音系统时，所必须使用到的应用程序，它除了支援多种的工具供系统开发时使用，并且还可调整系统上的一些设定，其功能大致如下:

  • 提供语音文件的录制、播放及切除等功能，以便使用者录制系统所需的语音文件。

  • 提供语音文件转换功能，可转换多媒体.WAV语音文件，增进两者的互通性。

  • 能学习当地局线或交换机的挂断音信号，并设定来电挂断的信号特性。

  • 能学习当地局线或交换机的回响铃、忙线音等信号，并设定打电话或转接电话的信号特性。

  • 提供检查语音文件功能，以确定所录制的语音文件不会被误判成按键音或挂断音。

  • 系统当机时自动重置(Auto Reset)电脑的设定。

(详细说明可参考附属应用程序使用手册和硬件说明.htm )


语音设定程序

<电脑语音广场> 第2章 第十节 语音设定程序

2.10 语音设定程序 [对天羚语音卡有效，现在的PCI 总线无需设定]

语音设定程序为设定或删除语音卡装置的中断号码，共用内存位置及IO端口位置。

当变更硬件设定时，除了要调整电话语音卡上的 Jumper 外，还必须使用硬件介面设定程序作软件上的变更，其设定画面如下：

按下Configure后出现以下画面：

设定I/O端口位址、中断号码及共用内存位置，按OK更新开机，其设定值才会生效。

按【确定】即可使用电脑语音广场系统的其他程序。

(详细说明请参考硬件安装手册)


电话语音模拟程序

<电脑语音广场> 第2章 第十一节 电话语音模拟程序

2.11 电话语音模拟程序 [对天羚语音卡有效]

  • 可对每一线作线上模拟电话的按键输入及接电话、挂电话的动作。

    •

    按一下可模拟拿起电话，再按一下即挂断电话。

    模拟按键的输入

    注意：必须先打开电话语音管理程序才能执行。


电话设定程序

<电脑语音广场> 第2章 第十二节 电话设定程序

2.12 电话设定程序

    1. 接听电话选项

  • 【接听电话】: 要(打勾)不要接听电话，若维持原设定则由系统设定的接电话语音元件来接听电话，可修改、删除或增加接听电话的月份、日期及时间。

  • 【新增】【修改】

    •

  • 【前往元件】：

  • 根据系统设定：接电话语音元件由系统決定。

  • 自行设定：接电话语音元件由使用者決定。

  • 【假日】：设定特别假日的接电话语音元件，例如五月三十一

  • 日由语音元件100接听:

  • 【新增】：可按新增继续新增假日。

    •

    选定欲新增之日期，按【确定】

    【删除】：删除某假日。

    【设定所有语音线】：打勾则以上之设定对所有语音线都有效。

    2.打电话选项

    可【修改】、【删除】或【增加】打电话的有效时间。

    •

    【执行外拨】: 设定要(打勾)不要打电话出去(针对DIAL.TXT)。

    【执行工作日志】: 设定要(打勾)不要侦测系统的工作日志，使用留言转递及

    留号待传式传真，及回复自动点灭留言灯时才有效，正常执行本系统时，若没

    有设工作日志，则不选【执行工作日志】(不打勾)，执行速度较快。


传真线设定

<电脑语音广场> 第2章 第十三节 传真线设定

2.13 传真线设定 [对天羚语音卡有效]

    •

    可设定语音线与传真线如何搭配（多线传真才有此设定）


语音软件生成器

<电脑语音广场> 第3章 语音软件生成器

第3章 语音软件生成器 [程序图标可能稍有变化]

语音软件生成器，提供多种不同功能的元件，在电脑屏幕上架构建立各语音元件关系 和设定各语音传真元件功能，即可产生各种语音传真流程软件。

图示

  1. 只播放语音元件: 只播放单一语音用。

  2. 按键输入元件 : 接受电话按键，依照按键跳到所设定的元件。

  3. 语音录制元件: 留言录音用途

4. 转接元件： 转接分机。

5. 送传真元件：发送传真。

6. 远端遥控元件：听取留言，更新设定。

7. 执行程序元件： 经由此元件通知外部程序，与系统作沟通。

8. 语言切换元件： 经此元件切换成另一种播放语音。

9. 文字播放元件：经此元件播放中文文字语音(语音文件在VOICE(n).TXT)。

10. 打电话元件： 发送 DTMF 电话按键。

11. 语音线连接元件：将两条电话线相接在一起用[需要特殊语音卡或配件]。

12. 收传真元件 ：收传真。

13. 数据库操作 ：可通过标准的SQL 语句访问数据库

14. 物件指定元件：可对变量，文件进行赋值

15. 物件比较元件：对变量、常数进行比较

16,17 [image] ,邮件收发： 需要邮件服务器的配合，进行邮件的接收

语音元件一览表

语音元件一览表列出所有语音元件

用鼠标在左边显示的元件快速按两下，即可进入此元件的功能设定，当您架构好各元件的功能和相互关系后，会自动在屏幕右方显示树状结构图。

语音元件架构图示(树状结构图)

语音元件架构图示列出树状结构图，当您架构好各元件的功能和关系后，在语音软件产生器右边「语音元件架构图示」会自动显示树状结构图如下：

1. 接电话元件。

2. 元件号码前面的符号：

【n】括号內容：表示依照按键跑到对应元件去执行

【End】：表示元件执行完后到对应元件去执行

【～】：输入其他按键完毕，跳到此元件

【FailTo】：表示元件执行失败后到对应元件去执行

如上表： 在元件1000 在电话上按0 执行电话转接元件2000。在电话上按# 执行信箱操控元件8000。

语音软件生成器的设计流程步骤: [首先请准备好客户打电话进入的应答流程]

<步骤 1> 建立新的元件 [可以是 0 到 999999 六位数的任何一个数字]

执行语音软件产生器，选【语音元件设定】的【增加元件】，建立新的元件，设定【元件功能】。

[不同的元件号码间可以空开一些，例如1000 完成后，下一个 1010，准备以后可以插入元件，浏览的比较清晰]

<步骤 2> 准备资料

录制或指定所选元件【招呼语】的语音资料，按键输入元件的语音在程序二内定义。

<步骤 3> 设定各元件的功能选项

逐一设定每个元件间相互关系及功能，以完成一个树状结构图:

<步骤 4> 设定树状结构图的起始元件为接电话元件

用鼠标在语音软件产生器，左边显示的元件(语音元件一览表)中，选树状结构图的起始元件，在【系统设定】中选【设定为接电话元件】后，将自动在右边显示树状结构图，供您察看某些元件之间的先后关系是否建立。

<步骤 5>

关闭语音软件产生器，并执行【电话语音管理程序】【语音模拟】或打入电话，即可模拟整套功能。

[可参考 如何开始快速制作一个电话流程 ]


语音信箱功能表

<电脑语音广场> 第3章 第一节 语音元件功能表［如何制作语音流程　］

上一节 下一节 上一章 下一章 回总目录

打开　＜语音软件生成器＞：

3.1 语音元件功能表

3.3.1 增加、修改、删除元件

增加元件

先设定元件号码及叙述。

建立新的元件，它会产生如图示的元件精灵，你可以在元件功能的地方选取元件的种类，按【下一步】可设定元件的內容。

【确定】: 确定新的元件设定。

【取消】: 取消建立新的元件。

修改元件

可在语音元件一览表按左键两下、或在功能表上选择修改元件，修改【元件号码】、【元件种类】和【元件设定】。

【确定】: 确定修改后的输入。

【取消】: 取消修改元件。

删除元件

先选一个要删除的元件，再选此项，将删除被选的元件，会出现以下画面，按【确定】按钮才会删除。

3.1.2 特殊音侦测设定 [用户自定义信号音，如传真信号音等]

按【特殊音侦测设定】按键，可设定侦测到挂断音(来电挂断)或特殊音时，如挂断电话、改变语音流程(到指定的元件去执行)或忽略不管。所谓特殊音，是指特殊的信号，如传真机之应答声(Answering Tone)或特殊之控制信号等。

系统在进入元件，开始执行元件所设定之功能，至离开元件(执行完【招呼语】与【应答功能】时)，到下一个元件继续执行前，若侦测到来电挂断的挂断音、传真机之应答声(Answering Tone)或特殊之控制信号时，会根据在元件【特殊音侦测设定】的设定，改变语音流程。挂断音与特殊音，在语音侦测程序的【设定】、【来电挂断设定】选项做设定。若核选【是否计时】，将依照此元件在【是否计时】所设定的去执行。

a.挂断选项

设定侦测到来电者挂断电话时采取之对策：

系统从进入元件开始，至离开元件(执行【招呼语】与【元件功能】时)，到下一个元件继续执行前，若侦测到来电挂断的挂断音时，可采取之对策：

立即挂断电话：若侦测到来电者挂断电话的话，则挂断电话。

忽略不管： 侦测到来电者挂断电话时，忽略不管。

跳到语音元件：侦测到来电者挂断电话时，到那个元件去执行，可到一个执行元件去计算来电到挂断电话时的时间长短。

b.特殊音选项

设定侦测到特殊音时采取之对策：

特殊音与挂断音类似，您可设定第一组到第三组等三类的特殊音，系统从进入元件开始，至离开元件(执行【招呼语】与【元件功能】时)，到下一个元件继续执行前，若侦测到此组特殊音时，可采取之对策：

  • 直接挂断：侦测到特殊音时，直接挂断。

  • 忽略不管：侦测到特殊音时，忽略不管。

  • 跳到语音元件：侦测到特殊音时，到那个元件去执行。

某些电话通知、传真行销的应用，打电话出去，须自动侦测接电话的是人、电话答录机或传真机，如果是人接电话，则播放语音，介绍产品或其它通告，如停话通知﹔如果是电话答录接电话，则在播放语音的当中，听到电话答录机的哗一声后，自动重头播放语音，如介绍产品或停话通知，以便答录机录下完整的语音內容﹔如果是传真机接电话，则自动传送传真资料，如产品目录通知的传真资料，这些电话行销、传真行销的应用，须设定电话答录机的特殊音和传真机的特殊音。

特殊音的设定，在语音侦测程序的【设定】、【来电挂断设定】，按【增加】按键，在【型态】选第一组(第二组或第三组)特殊音，填入数值，即可以增加一组所选要设定电话线的特殊音侦测设定。


工作日志

<电脑语音广场> 第3章 第二节 工作日志

3.2 工作日志 [配合语音信箱功能使用]

工作日志

系统提供查询工作日志，查看目前系统所有的行程表。

【删除】：删除一笔工作日志，先选一笔所要删除的工作日志。

【全部删除】：删除所有工作日志內的记录

在工作日志上可查看行程表行程、传真传送、传真通知、留言传送、留号传送或灭留言灯的工作进度。并可查看各笔行程的拥有者或留号待传的传真机号码。可以选择删除一笔或全部删除，以手动方式对工作日志做即时的维护。


系统设定

<电脑语音广场> 第3章 第三节 系统设定

3.3 系统设定

系统设定将影响到所有元件的设定。若有更改，且电话语音管理程序也正在执行，请务必在结束软件产生器后，在语音管理程序中，按一下【更新设定】，其设定值才会有效。

3.3.1 文件〉更改电话流程路径

【更改电话流程】：此提供元件流程资料的路径，可由不同的目录提供，使用者可将各种不同的流程储存在各种不同的路径之下，然后可利用此功能变更或新增新的资料元件路径，方便使用者随时变更语音元件的流程。在电话语音管理程序运行的时候不能更改此路径

3.3.2 工具〉使用者设定

【远端遥控功能】：进入远端遥控流程 [相对应用在信箱操控元件]。

远端遥控功能若被启动，当系统接电话后，远端可以按「#」开始远端遥控功能，按键1~7、0、# 分别控制听取新的留言、听取旧的留言、听取工作日志、更改问候语、传送留言、修改答录机设定、个人元件设定、其他元件及挂断，上图中在各按键打? 分别设定该按键之遥控功能，但按「6」只有在接电话元件有效。

使用者管理可用在企业自动总机，语音信箱系统； 使用者代码即是语音信箱的号码

3.3.3 工具〉使用者管理〉设定

按下管理员设定后将出现“管理资格确认”画面，但是第一次执行管理员设定，不会出现此画面，会直接进入“管理员设定”画面，等有设定好了管理员，才会有“管理资格确定的画面”出现。

【管理员设定】：设定管理员的元件号码，此元件号码为个人信箱号码，管理员密码为个人信箱的密码。

【使用电脑进入电脑语音系统时需要密码保护】：此选项若打勾时，则一执行语音软件产生器即会要求输入管理员信箱及管理员密码，但是若没有选择或设定管理员信箱的话，此功能如同不打 。

【变更管理员信箱】：可提供变更新的管理员信箱，若不填入信箱号码，且在“现在管理员信箱”设定里就没有设定信箱号码，则视同不启动密码保护功能。

3.3.4 设定〉传真设定

传真自动回复方式

线上即时式(One Call Fax Retrieval)：

  1. 设定成来电索取传真资料，必须从传真机拨号，并即时收取传真。

  2. 留号待传式(Two Call Fax Retrieval)：设定成来电索取传真资料，可由一般电话机拨号，留下传真号码，系统再根照此号码送传真资料。

  3. 您可以【线上即时式】和【留号待传式】都选，表示来电索取传真资料，可从传真机或由一般电话机拨号进来，在此情況下，系统会询问来电者要立即传真或留下电话号码，稍后由系统拨号传送。

解析度

选择传真解析度是高解析度(200x200)或低解析度(100x200)。

功能设定

【一次最多可索取的传真文件数目】：最多容许给几个传真资料。

【使用传真封面页】：送传真资料要不要先送封面，按【选择封面页】可编辑封面页文件名。

【留号待传式之功能选择】：如果传真自动回复是留号待传时，则可设定禁止使用的传真码，如设定002表所有国际电话号码，均不能做为传真自动回复之传真号码。

【可使用之长途码】：表示留号待传时，电话的长途码若是被允许的传真长途码，则此留号待传则可自动回复。例如：022,021

【禁止索取传真长途码】：指传真自动回复是留号待传时，设定禁止索取传真的国內长途电话号码。例如：010,020

传真设定

按【设定】：

传真机喇叭：

【模式】：选传真机动作时喇叭要不要出声或在连线后关掉。

【音量】：选低、中或高。

传真线设定：

【拨号型式】：拨传真电话采用【复频式】或【脉冲式】方式。

【不判断有无拨号声，一律拨号】：不等电话拨音，即打传真电话。

【初始字串】：送传真时先执行的数照机命令(AT command)， 如设S7=45表传真打电话后， 等45秒才算超过时间。

【我方的传真号码】：设定您传真的內设号码，这号码将传给对方传真机。

【送件者名称】：此功能是设定您传真的传送者名称，并将此名称标示在传真的文件头。

Windows中的传真设定

本系统之单线传真使用之资源为，占用个人电脑的通讯端口COM4，中断要求10，此传真装置的硬件设定可参考硬件安装手冊。

传真封面页设定

按下“选择封面页”出现下面画面：

此为设定封页的第一页。

传真文件格式有两种：內定传真文件或文字文件。

內定传真文件的选项：可为传真文件的各种文件，格式如 PCX、DCX、TIF文件等等。

文字文件选项：此文字文件必须是TXT文件。

3.3.5 设定〉电话设定

拨号型式：打电话用按键式或脉冲式方式。

脉冲拨号速度：10PPS或20PPS。

打电话选择：不判断有无拨号声，一律拨号。

转接分机：在使用交换机(PABX)转接分机时，拨号前之判断。

不判断有无拨号声，一律拨号：打勾表示不等拨号音，立即拨号。

留言灯设定：

系统要点亮或熄灭分机上的留言灯，必须经过交换机来控制。对于留言灯的点亮或熄灭，分别有一个控制字串，为点灯字串和熄灯字串。这两个字串可以使用 %s 字元来代表该分机的分机号码，而s必须是小写。例如控制分机331的点灯字串是 “A1331”，熄灯字串是 “A0331”，则可分别设定为 “A1%s” 及 “A0%s”。

【一个逗号暂停的时间】：电话号码中一个「，」表示暂停的时间(秒)。

按【更多设定】钮可作自动总机功能的转接电话设定：

转接选项：

【转接时间(毫秒)】：转接时间(Flash time)以毫秒计算。

【转接前置码】：有些交换机在转接时，必须加入的特定号码。

【转接须按两次】：有的交换机转接时要按两次(Double Flash)，则在此打 。

【按两次间之间隔时间(毫秒)】：转接时两次Flash间隔时间。

转接时无人接听选项：

【转接拉回时间(毫秒)】：转接无人接听时，要拉回的转接时间(Transfer back flash duration)。

【转接拉回按键码】：转接无人接听时，拉回要按的号码。

【转接拉回须按两次】：有的交换机，无人接听转接拉回时，要按两次Flash，则在此打勾。

【按两次间之间隔时间(毫秒)】：无人接听转接拉回时，两次Flash间隔时间。

转接时忙线选项：

【转接拉回时间(毫秒)】：转接忙线时，要拉回的转接时间。

【转接拉回按键码】：转接忙线时，拉回要按的号码。

【转接拉回须按两次】：有的交换机转接忙线拉回时，要按两次Flash，则在此打 。

【按两次间之间隔时间(毫秒)】：转接忙线拉回时，两次Flash间隔时间。

以下提供几种交换机，在系统设定中的电话设定:

交换机

转接时间(毫秒)

无人接听、忙线的转接拉回时间(毫秒)

其它设定

Panasonic 308

300

300

。

Panasonic 616

600

600

。

Philip D50

300

300

。

TAMIC-824

300

300

。

TELEX 1001

300

300

Siemens

100

100

这些交换机机型的设定建议值，存在\AG32\PBX.INI或dialogic.ini,dn.ini文件中，您可用WINDOWS的记事本，列出其它交换机的设定值。

3.3.6 设定〉时间设定

      1. 来电留言时，可录制的最长时间：留言或远端遥控更改招呼语最长的录音时间，以秒计算。

      2. 远端遥控时，等待按键的时间：远端遥控时，等待按键的最长时间，以秒计算。

3.3.7 设定〉维护设定 [主要用于独立语音信箱的使用]

留言文件维护

维护设定分为五个选项：

【启用系统维护】：可设定系统维护时间，即当系统的时间到达系统维护所设定的时间时，将会同时去维护留言文件、拨号文件、传真文件以及硬盘空间的维护，若启用系统维护，则启动留言文件维护、拨号文件维护、传真文件维护、及硬盘空间维护等选项，将被取消。若启用系统维护沒有选择，则启动留言文件维护、拨号文件维护、传真文件维护、硬盘空间维护可个别设定。

【启动留言文件维护】：即包含新留言文件的保留时间，旧留言文件的保留时间，及每次侦测的间隔时间从设定的时候开始算起。

【启动拨号文件维护】：即拨号文件的侦测，设定其侦测维护的间隔时间。

【启动传真文件维护】：传真文件维护设定有两个，传真文件保留时间为几个小时，及每次侦测间隔为几个小时。

【启动硬盘空间维护】：此为侦测系统里面硬盘空间的最大使用空间，为所有空间的百分之几，并可设定每次侦测的间隔时间为几小时。

3.3.8 设定〉电话线监控设定

选定系统使用的电话线，此系统会自动侦测电脑上面所接的卡，一共含有多少线数，然后显示于画面中，使用者可利用点选的方式，设定使用其中的某几线或全部使用。

【等待的铃响数】：系统等待接电话的铃响数。

3.3.9 设定〉其他设定〉外部程序沟通设定

使用者可以撰写程序以管理数据库，此程序称为外部程序，外部程序经过与系统定义的文字文件(Text file)作数据交换，即可达成利用语音系统管理数据库的应用；外部程序沟通设定是指示外部程序与系统沟通的文件目录，系统定义的文字文件有 EXEREQ(n).TXT、EXEACK(n).TXT、GOTOBOX(n).TXT、VOICE(n).TXT、VMSLINK(n).TXT、TIME(n).TXT、REQ(n).TXT等文件，如下图外部程序沟通路径设定在 c:\age32\tools 之下。

3.3.10 设定〉拨号文件功能设定

拨号文件(即 DIAL.TXT)为系统用以拨号的文字文件，以下是其两项设定选择:

文件目录选项:

【拨号文件在电脑语音系统目录】: DIAL.TXT 文件目录在电脑语音系统目录下。

【拨号文件在外部程序沟通目录】: DIAL.TXT 文件目录在【外部程序沟通设定】所设定之目录下。

侦测选项:

【停止侦查拨号文件】：不检查DIAL.TXT，即不主动打电话或送传真。

【开始侦查拨号文件侦测间隔时间：】：系统侦测DIAL.TXT的间隔时间，以毫秒计，如 2000 表是2秒。

3.3.11 工具〉工作日志〉设定〉外拨设定

针对工作日志的外拨设定

【拨号前置码】：外拨前置码，如接交换机，要设成0或9，要视交换机规格不同而有不同之设定。

【重拨次数】：重拨次数。

【重拨间隔】：两次重打间隔多久(分钟)。

3.3.12 其它设定〉一般设定

【使用文件与外部程序做沟通】：

经过执行程序元件时，与外部程序做沟通的方式有两种，一为使用文字文件(REQ(n).TXT、EXEREQ(n).TXT、EXEACK(n).TXT)与外部程序做沟通；另一为使用呼叫 DLL 方式(限使用Windows语言程序)，而非使用文字文件与外部程序做沟通。

打 表经过执行程序元件时，使用文字文件(REQ(n).TXT、EXEREQ(n).TXT、EXEACK(n).TXT)与外部程序做沟通。

【启用按键缓冲区】:

打勾表示启用按键缓冲区，在电话键盘上按入键超过该语音元件所能接受的键，将留给下一个语音元件使用，此功能用于需要快速键入的应用。

3.3.13 元件〉设定为接电话元件

将所选择的元件，预设成系统接电话元件。

在语音管理程序的电话设定，设定每条线接电话后之【前往元件】，可选【根照系统设定】或【自行设定】，所谓【根照系统设定】即为本节所设定的接电话元件。

若这条线设定为【自行设定】，这条线接电话之语音元件不受本节语音软件产生器【设定为接电话元件】之影响。

3.3.14 设定>数据库设定

此处设定可以使系统同时连接多个数据库，勾选所需要的选项； 使用者名称：访问数据库的USERID,密码：PASSWORD; 数据源名称：在控制面板〉odbc内设定; 连结名称可以任意设定,但不能重复,是AG32 指向的别名

3.3.15 设定>电子邮件设定

对于企业内部具有邮件服务器的，可以使用此邮件服务选项，并且配合邮件收发元件实现电子邮件的一般功能。特别指出，默认发送设置没有用户验证功能


各种语音信箱功能

<电脑语音广场> 第4章 各种元件功能

第4章 各种元件功能

本系统提供多种功能的元件，可在屏幕上架构语音元件间之连接关系并设定语音元件功能，以产生各种语音传真软件，包括图示:

1. 只播放语音元件: 只播放单一语音用

2. 按键输入元件 : 接受电话按键，依照按键跳到所设定的元件

3. 留言元件: 留言用，留言后可设定呼叫电话、呼叫器或大哥大

4. 转接元件： 转接分机

5. 送传真元件：送传真

6. 远端遥控元件：听取留言，更新个人信箱设定

7. 程序连结元件： 经由此元件通知外部程序，与系统作沟通

8. 语言切换元件： 经此元件切换成另一种播放语音

9. 文字播放元件：经此元件播放中文文字语音(语音文件在VOICE(n).TXT)

10. 打电话元件： 发送 DTMF 电话按键

11. 语音线连接元件：将两条电话线相接在一起用[需要特殊语音卡或配件]

12. 收传真元件 ：收传真

13. 数据库操作 ：可通过标准的SQL 语句访问数据库

14. 物件指定元件：可对变量，文件进行赋值

15. 物件比较元件：对变量、常数进行比较

16,17 [image] ,邮件收发： 需要邮件服务器的配合，进行邮件的接收

【语音管理员】：提供线上即时录音、播音，对天羚卡适用。

储存语音文件：可以利用此按键，录音后立即储存文件，再修改语音文件名即可录制下一个语音文件，依此类推可在同一个画面将所有的录音文件录制成。


元件基本设定

<电脑语音广场> 第4章 第一节 元件基本设定

4.1 元件基本设定 [每一个元件含一到四个子程序]

每一个元件共有下列几种基本设定功能，其中子 程序1为所有元件共同拥有：

程序一〉计时设定

每一个元件都可以启用计时功能，计时的方式有三种：

      1. 元件自行计时：进入元件之后，即在元件里面自行执行回路的工作，直到计时条件选项的时间到或挂断为止。

      2. 记录计时时间：代表进入元件时，立即将此时的时间记录到TIME(N).TXT里面。TIME(N).TXT內容各栏以「，」相隔开，例子如下：

        3. 1999/7/7 AM 10:18:47,1999/7/7 AM 10:28:48

        第一栏：为记录开始计时时间

        第二栏：为判别到计时结束时所记录的结束时间

      3. 判别计时结束：即是进入元件时，立即判断结束的时间是否已到，判断方式为系统以目前的时间与TIME(N).TXT之开始时间的时间差是否已超过设定之时间，此时间可以是固定时间或由INTERVAL(N).TXT提供。

        4. INTERVAL(N).TXT內容，仅含一组数字，例子如下:

        100 此数字代表间隔时间为100秒

      4. 判别计时时间到跳到元件：此栏位是判别到达结束时间后，下一个执行的语音元件号码，若不执行此功能，将栏位空白即可。

程序一〉计数设定

  • 适用于重复语音元件回路数次的功能。

    • .

      1. 取用一个新计数器：将之前计数的计数器储存，然后取用一个新的。【归还最近取用之计数器】：表示先归还上次使用的计数器，再取 用一 个新的计数器。起始值表示循环 次数的起始值，会继续执行此元件功能。

      2. 下一轮：表示每次经过此元件循环的次数，计数器会自动减一，然后依照计数值计数到０就跳到某一个元件，如果计数器仍大于０，则继续执行此元件功能。

      3. 归还最近取用之计数器：表示归还最近取用的计数器，结束这个循环回路。

      4. 归还所有计数器：表示归还所有的计数器的设定，结束所有的循环回路。

    程序一〉指定变数 [变量]

    指定变数：顾名思义就是取得并指定变化的数值

    应用程序往往需要知道来电的某时、某刻的信息，每一个元件结点都可以取得不同的变数

    这些变数都是AG32 应用程序返回的各类参数，使用者可以自主存取，并记录或写入数据库等

    一般就取〉进元件前就指定；

    进元件后指定也可以，元件可能执行一定的时间，例如按键输入元件，这样取得的参数就是离开此元件时的变数，供下一元件使用。

    挂断／特殊音设定

    按【特殊音侦测设定】按键，可设定侦测到挂断音(来电挂断)或特殊音时，如挂断电话、改变语音流程(到指定的元件去执行)或忽略不管，所谓特殊音，是指特殊的信号，如电话答录机之哗声、传真机之应答声(Answering Tone)或特殊之控制信号等。

    系统从进入元件开始，至离开元件(执行【招呼语】时)，到下一个元件继续执行前，若侦测到来电挂断的挂断音、电话答录机之哗声、传真机之应答声(Answering Tone)或特殊之控制信号时，会根据在元件【特殊音侦测设定】中的设定，改变语音流程，挂断音与特殊音，在语音侦测程序的【设定】、【来电挂断设定】设定。

    a.【挂断选项】:

    系统从进入元件开始，至离开元件(执行【招呼语】时)，到下一个元件继续执行前，若侦测到来电挂断的挂断音时，可采取之对策：

    • 直接挂断：若侦测到来电者挂断电话的话，则挂断电话。

    • 忽略：侦测到来电者挂断电话时，忽略不管。

    • 跳到语音元件：侦测到来电者挂断电话时，到那个元件去执行，可到一个执行元件去计算来电到挂断电话时的时间长短。

    b.【特殊音选项】

    特殊音与挂断音类似，您可设定第一组到第三组等三类的特殊音，系统从进入元件开始，至离开元件(执行【招呼语】与【应答功能】时)，到下一个元件继续执行前，若侦测到此组特殊音时，可采取之之功能设定：

    • 直接挂断：若侦测到特殊音的话，则挂断电话。

    • 忽略：侦测到特殊音时，忽略不管。

    • 跳到语音元件：侦测到特殊音时，到那个元件去执行。

    某些电话通知、传真行销的应用，打电话出去，须自动侦测接电话的是人、电话答录机或传真机，如果是人接电话，则播放语音，介绍产品或其它通告，如停话通知﹔如果是电话答录机接电话，则在播放语音的当中，听到电话答录机的哗一声后，自动重头播放语音，如介绍产品或停话通知，以便答录机录下完整的语音內容﹔如果是传真机接电话，则自动传送传真资料，如产品目录通知的传真资料，这些电话行销、传真行销的应用，须设定电话答录机的特殊音和传真机的特殊音。

    特殊音的设定，在语音侦测程序的【设定】、【来电挂断设定】，按【增加】按键，在【型态】选第一组(第二组或第三组)特殊音，填入数值，即可以增加一组所选要设定电话线的特殊音侦测设定。


只播放语音信箱

<电脑语音广场> 第4章 第二节 只播放语音元件

4.2 只播放语音元件 [任一个元件都包含本元件的程序一的所有功能]

此元件的功能只有播放语音，为最基本的语音元件，其播放的语音文件在【招呼语选项】中选择。

    • .

    若招呼语根据VMSLINK(n).TXT或变量设定，则其格式为：

    ＊天羚科技^C：\AG32\voice; A.WAV^ ....

    也可指定一个固定文件


资料输入信箱

<电脑语音广场> 第4章 第三节 按键输入元件

4.3 按键输入元件 [本元件是一个语音系统中功能强弱的集中体现,是连接各流程的结点]

按键输入元件将从电话按键的资料存成文字文件或变量，根据输入值，依照一个文字文件或对照表，跑到对应的元件，其功能为:

播放的招呼语语音文件选项，可以以下二者选一：

1. 招呼语根据DENTRY(n).TXT设定：语音文件名在DENTRY(n).TXT，可由你的外部程序经执行程 序元件产生DENTRY(n).TXT。也可由 物件指定元件 赋值; 这样可以动态定义需要播放的语音!

DENTRY(n).TXT內容各栏以「，」相隔开，例子如下：

*我的会员编号，C:\WINNT\MEDIA\CHORD.WAV，

*5个^C:\WAV;A1.WAV^，…….

第一栏表示第一句问话,第二栏表示第二句问话….依此类推使用语法：

“*XXXX…”：(文字字串格式) 字首是‘*’代表以下的字串会逐字播放,X可以是任何的数字，英文字母或者是中文GB-5码。

“XXXX…”：(文件格式) 字首不是‘*’代表以下的字串会被当做是语音的文件名称，所以XXX只可以是一个文件名称。

“*XX^YYY;ZZZZ^”：(字串+文件格式)

字首是‘*’而且字串中有成对的‘^’(可视为括弧)出现，则会被当做是字串加文件的格式

^ ：字串与文件的分隔字元。

‘；’：使用目录与文件名称的分隔字元。

YYY：两个‘^’之间，而且在；之前，则当做是文件名称的目录，若是空白，则代表使用安装系统的目录。

ZZZZ：文件名。

2. 固定招呼语(GREET(n).GRT) ： 语音文件为固定文件名GREET(n).GRT语音文件。

播放语音且接受按键; 此语音文件格式实际也是一个 wav 文件，[pcm 8k,8 bit,mono]

【播放语音个数】： 设定几个语音文件，可设1-5，例如设成5，则顺序为：

1: 播放第1个语音文件(GREET1.GRT)，接受第1次电话按键，最多按几个

键，依据【按键最大长度】、【语音: 1】。

2:播放GREET2.GRT，接受第2次电话按键，最多按几个 键，依据【按键

最大长度】 、【语音:2】。以此类推、、、

如【播放语音次数】设成1，则只播GREET1.GRT，接受第1次按键。

【错误重试次数】：重新电话输入次数，播放语音(招呼语)GREET(n).GRT时即可接受按键，一直到播完招呼语之后3秒內仍接受按键，若未按键则播放语音文件可自行录制于元件之下，文件名为Error1、Error2…..,Error5.WAV，若在元件目录之下，找不到这些文件则播放系统语音VC33.WAV。“你未输入按键”，接着重复播放GREET(n).GRT(重复次数为【错误重试次数】之设定值)，若重复后仍未按键，则执行在按键值设定中【未输入】设定元件，若未设定则根据步骤三之设定。若所按键输入错误，则播放VC64.WAV “您输入错误，请重新输入”

【按键最大长度】：各次电话按键最多可按几个键。

【是否要确认】：要不要确认电话所按键的內容，如果设成要确认，则接受电话按键后，播放 CONFIRM(n).GRT，再播放CONFIRM.GRT要求确认，若按1则表电话输入资料正确， 若按2则重新输入。

【等待按键时间】: 等待输入电话按键的时间。

【未达最大按键长度，前补０】:表示接收按键长度若为5，但使用者输入4码，则会在最前面补0，变为5码。

【编辑INFORM.TXT】：依据按键值到INFORM.TXT去寻找相对应的语音文件播放（此功能必须打）ˇ。

INFORM.TXT格式：

「电话按键1，电话按键2，...，对应的语音文件1，对应的语音文件2，….」

INFORM.TXT 格式也可以是：

「电话按键，语音文件名」

或 「电话按键，语音文件名，语音文件名，语音文件名，...」

或 「电话按键，语音文件名，文字字串，语音文件名」

<例子>

12345，D：\VOICE\V1.WAV (按12345，播放d：\voice\v1.wav语音)

<例子>

135，D：\VOICE\F1.WAV，D：\VOICE\F2.WAV，D：\VOICE\F3.WAV (按135，播放 D：\voice\f1.wav、D：\voice\f2.wav、D：\voice\f3.wav，3个语音逐次播放)

<例子>

135，D：\VOICE\F1.WAV，D：\VOICE\F2.WAV，D：\VOICE\F3.WAV

(按135，播放 D：\voice\ f1.wav语音后，播放 CONTINUE.GRT「继续听请按1，结束请按2」二次，若按1则继续播D：\VOICE\ F2.WAV， D：\VOICE\F3.WAV语音，若按2，则结束，不播 D：\VOICE\ F2.WAV， D：\VOICE\F3.WAV语音；若不按，则挂断电话)

按键选项

按完电话按键后会跑到那个元件：

【根据电话按键，跳到所按键的元件】:根据电话按键，跑到所按键的元件。

【根据表，跳到对应的元件】:根据GOTOBOX.TXT表，跳到对应的元件。

【根据按键值，跳到对应的元件】：根据按键对照表，跳到所对应号码的元件执行。

【是否为特殊键】：判断一个固定的快速键，对于此类能可立即执行，不需等待下一个按键值。

【启用结束按键，按键为】：代表按键结束，此按键不属于输入按键值。

【是否写入 VMSLINK(n).TXT写入第 n 栏】：将按键资料写入VMSLINK(n).TXT第 n栏，栏位从0开始计算。

例如:

输入资料写入之栏位=2

VMSLINK(n).TXT 內容原为：12，34，51，52，90

按键资料： 71，72

VMSLINK(n).TXT 內容变为：12，34，71，72，90


留言信箱

<电脑语音广场> 第4章 第四节 语音录制元件

4.4 语音录制元件 [留言]

此元件可为留言或录制语音文件之用，留言后并可存入数据库或设定呼叫电话、 转发email等

留言文件存文件方式：

【依据最近一次按键输入】:

根据最近一次的按键输入得到个人信箱代码，并将留言文件存入此个人信箱中。

【指定个人信箱】:

留言元件提供个人箱信箱代码，并将留言文件存入此个人信箱中。

【个人信箱由VMSLINK提供】:

由VMSLINK得到个人信箱代码，并将留言文件存入此个人信箱中。

【留言文件由VMSLINK提供】:

将留言文件存入固定的目录、文件名。例如：C:\AG32\ICM\A.WAV

【留言文件由变数提供】:

由变量得到留言文件名

留言完设定选项：以下三者多选：

      1. 留言：选择要不要留言。

      2. 留号： 要求留下电话号码。

      3. 重录，重听.. 等选项: 留言者可按1重录、按2重听或按0结束。

留言长度设定：

【留言长度根据系统设定】: 留言长度根据【系统设定】、【时间限制】中设定之。

【留言长度由信箱设定】: 留言长度可在此处设定，以秒计算。

【留言长度由VMSLINK(n).TXT提供】: 留言长度在VMSLINK(n).TXT中设定。

留言后，留言结果会存在 VMSLINK(n).TXT 。

VMSLINK(n).TXT內容为：

「留言状态，留言长度，语音信箱号码，文件路径及文件名」

第一栏

0: 表留言 OK，留言留到满为止或按*结束。

B: 表留言 OK，留言未留到满就挂断电话。

E: 留言有错误，沒有留言。


转接信箱

<电脑语音广场> 第4章 第五节 转接元件

4.5 转接元件

[配合PBX 实现电话转接，AG32 配合相应硬件板卡独立组成一个PBX 系统而无需外接交换机]

转接元件能将来电自动转接到指定的分机。在此，转接号码意义为个人元件号码，实际转接的 分机号码在个人信箱设定中设定。

交换机转接之号码：

【转接固定号码】：转接到固定的分机号码。

【转接号码由VMSLINK(n).TXT提供】：转接的分机号码在VMSLINK(n).TXT，可经由资料输入元件、或程序经执行程序元件产生 VMSLINK(n).TXT

交换机配线图:

交换机必须使用:

1.电子交换机(PABX， 按0或9接到外线）。

2.按键电话系统(Keyphone system，按不亮键接到外线）， 必须加装单机 音频卡，单机音频卡系由按键电话系统公司提供。

3.交换机配备CTI LINK 接口，使用软件控制实现转接分机

交换机优先响铃的分机接到语音卡，可将一分机接至人工总机，其他的分机接到各部门的电话机，有的交换机转接前，要先按一些码，则在所有转接元件的交换机【转接的转接固定号码】前，要先加 某些按键码，如交换机TELEX 1001，分机转接前要先按32，则在所有转接元件的【交换机转接的转接固定号码】前，要先加32，如转接号码20，则改成3220。

监控转接过程

若选不要【监控转接过程】，则转接分机后，视为接通。

按【监控选项】按键可设定:

【转接等待铃声数】：响几声算沒人接听。

【接通选项】: 如果接通电话后，让系统释放电话线，亦即来电者可与接听电话通话。另一种应用称为三方通话，即系统不释放电话线，系统因此可计算通话时间，但必须做以下之设定:

【拉回时间】:接通后所须按的FLASH的时间。

【拉回按键码】:有的交换机接通后须按的按键码。

【拉回须按两次】:有的交换机接通后须按两次FLASH。

【二次间之间隔时间】:有的交换机接通后须按电话两次FLASH，两次FLASH的间隔 时间。

【释放电话线】:接通后可设定要不要释放电话线，要达到三方通话功能必须不要打勾。

【如果接通，到元件】:此栏位代表接通后到某一个语音元件，若不提供此功能将此栏位空白即可。

【无人接听/忙线中选项】:

若转接沒有人接听或讲话中，则可选择【播放无人接听/忙线中讯息】，可选择播放讯息选项，以下四者多选：

1.继续等待: 播放「若要继续等待请按1」。

2.留言: 播放「若要留言请按2」。

3.转接其他分机，再输入跳到的语音元件号码: 例如播放「转接其他分机请按3」。

4.转接总机，再输入跳到的语音元件号码: 播放「需要总机服务请按0」。

5.收传真：播放「若要收传真请按4」，系统进入收传真功能，接收传真。

【留言时播放招呼语】

可选择留言时要不要播放招呼语。

【转接失败选项】

若不选择【播放无人接听/忙线中讯息】，则当无人接听或忙线时，由以下选项決定执行的元件。

经转接元件，若来电者未按任何键选择时，依照此元件在【应答功能设定】、【执行完应答功能后继续做】所设定的去执行。而无人接听/忙线结果储存在VMSLINK(n).TXT:

3: 无人接听

5: 忙线

4: 接通


送传真信箱

<电脑语音广场> 第4章 第六节 发传真元件

4.6 发送传真元件

选《传真发送元件》出现设定画面：

在【传真文件格式】选【內定传真文件】，并在【內定传真文件选项】、【文件名称】输入传真文件名，这里提供內定传真的四种格式文件（*.FAX、*.PCX、*.DCX、*.TIF）。

在【传真文件格式】选【文字文件】，并在【文字文件选项】、【文件名称】输入文字文件名，选择【文字文件】(.txt)时，本系统自动判断文字文件(.txt)是中文(GB码)文字文件或英文文字文件，经此送传真元件时，线上即时将中文(GB码)自动转换成传真格式传出。

在【传真文件格式】选【由VMSLINK提供个人信箱】，系统将根据VMSLINK提供个人信箱代码，到个人信箱中取得传真的文件，文件名称由系统自定。

在【传真文件格式】选【传真文件由VMSLINK提供】，系统将会由此得到传真文件的文件名及路径，直接送传真。

格式：[类别，传真文件，类别，传真文件，。。。] [最长 1024 字节]

第一栏：类别 ：

0： 代表第二栏传真文件为文本文件[*。TXT]

1： 代表第二栏传真文件为传真格式文件[*.tif,*.fax,dcx]

在【传真文件格式】选【传真文件由指定信箱提供】，并在传真文件指定信箱的栏位中填入个人信箱代码，系统将根据此个人信箱代码，去个人信箱中取得传真的文件，文件名称由系统自定。

【选择传真文件，前往元件号码】

于多重传真情況，选择此功能，当索取者选完传真资料时，系统会播放「立即传真请按1，欲索取更多资料请按2」之语音文件。若按1，则开始传真，当传真完成后，其结果将会写入VMSLINK(n).TXT中(0: 代表传真成功，E: 代表传真失败)；若按2索取更多资料时，系统会依据【前往元件号码】，跳至该元件执行；若沒有按键，会将F写入VMSLINK(n).TXT中。当传真功能结束后，不论传真完成或失败，系统均会根据【步骤三】的设定执行(按2除外)。

【播放提示语音】

经过送传真元件，送传真时，可选要不要播放以下的语音文件:

1.「请按下您传真机的开始键，以便开始接收您想获得的传真资料，谢谢」。

2.「请稍候，传真资料准备中」。

3.「若您是使用传真机请按1，以便开始接收您的传真资料， 若您是使用一般话机请按2，并输入您的传真机号码」(传真自动回复方式选留号待传式时)。

4. 请输入您的传真机号码以#字号结束，以便由系统发送传真给您。

根据「回复设定」可设定使用上列四句招呼语设定方式如下：

a.线上即时方式、留号待传方式，则会使用上列1~4句。

b.线上即时方式，则会使用上列1,2句。

c.留号待传方式，则会使用上列第4句。

【回复设定】

传真自动回复方式可【根据系统设定】或【根据信箱设定】。

【根据系统设定】:

由【系统设定】、【传真设定】、【传真自动回复方式】中设定之。

【根据信箱设定】

1. 线上即时方式(One Call Fax Retrieval)：

设定成索取传真资料必须从传真机拨电话进来。

2. 留号待传方式(Two Call Fax Retrieval)：

设成索取传真资料，可由一般电话机拨电话进来，留下传真号码，

系统再回拨此号码送传真资料。

注：传真头说明：

1：发送传真后，收件方传真头上有一行from... to .... 内容，可以在软件产生器〉设定〉传真设定内设定 传真设定

2：也可以由head(n).txt 提供，格式为：

telelink ; [form 字符串]

010 62186575 ; [to 字符串]

3:FaxHand.txt : [在外部程序沟通目录]，内含一个文件名，可以是：d:\temp\head.txt

或d:\temp\head.tif

4:传真封面页,由 软件产生器〉设定〉传真设定内设定 传真设定


远端遥控功能

<电脑语音广场> 第4章 第七节 远端遥控元件

4.7 远端遥控元件 [个人语音信箱设定]

元件提供听取留言，更新设定，与远端遥控有相同的功能。

远端遥控设定:

【由来电者输入个人信箱号码和密码】：由电话中输入信箱号码和密码。

【信箱号码由 VMSLINK(n).TXT 提供， 来电者输入密码】：

信箱号码在VMSLINK(n).TXT，由电话中输入密码。（此号码为信箱号码或个人信箱号码

VMSLINK(n).TXT，可经由按键输入元件，或外部程序经程序连接元件产生。


执行程序信箱

<电脑语音广场> 第4章 第八节 程序连接元件

4.8 程序连接元件 [AG32 的开放性体现，用户程序可通过此程序来与AG32 交互]

程序连接元件提供在电话中可与用户程序(Delphi,C、VB、FoxPro、Basic、C++Builder 等)交换数据，以即时提供语音资讯、修改数据库或改变电话中路径，并可在网络上执行的程序沟通。具体见 AG32 开放性连接

经过此元件，AG32 将通过许多自约定的文本协议来与用户程序交换数据或命令

下面 n 代表电话线号，如 EXEREQ3.TXT，代表第3条电话线发出请求。所有.TXT 文件，在语音软件产生器的【系统设定】、【外部程序沟通设定】设定的文件目录之下。

例如:

1.打电话进来经过按键输入元件，输入会员号码与密码后，资料存在VMSLINK(n).TXT。

2.当跑到这个程序连接元件时，会产生二个文件REQ(n).TXT及EXEREQ(n).TXT，使用者执行程序必须一直检查 REQ(n).TXT文件是否存在。使用者程序，只要根据这套系统所产生的文字文件(VMSLINK(n).TXT、EXEREQ(n).TXT)，至数据库存取后，再转换输出成另外一些文字文件即可。

3.使用者执行程序执行后，产生以下文件 ：GOTOBOX(n).TXT、 EXEACK(n).TXT、VOICE(n).TXT*、 VMSLINK(n).TXT*及 DIAL.TXT*（*: 为选项，不一定有）。

「GOTOBOX(n).TXT」: 在执行此执行程序元件之后，跑到那一个元件号码去执行。

「EXEACK(n).TXT」:使用者程序通知本系统已经执行完毕。系统产生文件

REQ(n).TXT、EXEREQ(n).TXT 后，会一直检查 EXEACK(n).TXT 文件是否产生，若发现，则 代表用户程序已经返回，系统将根据用户程序写入的GOTOBOX(n).TXT 内容走向相应的代码元件，并建议一定删除此文件[不然下次就不好办了]。

「VOICE(n).TXT」:用于播放语音元件，以播放语音给来电者听，或播放中文(GB码)语音文件，中文(GB码)自动转换成语音念出。

「VMSLINK(n).TXT」:使用者执行程序后，可以将结果输出 VMSLINK(n).TXT给别的语音元件使用。

执行程序元件相关的文字文件(.TXT)

「REQ(n).TXT」为一空文件

当跑到这个执行程序元件时，会产生二个文件REQ(n).TXT及 EXEREQ(n).TXT。使用者执行程序必须一直检查REQ(n).TXT文件是否存在。

「EXEREQ(n).TXT」为实际存沟通资料的文件

EXEREQ(n).TXT內容如下：

3，C：\AG32\Tools，19970701

3： 代表「给外部程序之功能代码」(执行代码)，在(【外部程序界面设定】中的【给外部程序之功能代码】中自行指定，用来辨别是那一个执行程序元件来要求执行使用者程序。

C：\AG32\Tools： 目前语音流程所执行的目录，可经由语言切换元件来改变。

19970701： 要求执行使用者程序的日期.

「VMSLINK(n).TXT」: VMSLINK(n).TXT是一个资料暂存区，可作输入或输出。

VMSLINK(n).TXT作输入用

1.任何元件的招呼语，若播放招呼语设为【文件名称由VMSLINK(n).TXT】时，招呼语语音文件名在 VMSLINK(n).TXT，可由 DIAL.TXT的第19栏或你的程序经执行程序元件产生 VMSLINK(n).TXT.。

2.语音录制元件的留言语音文件名，若设为【留言文件由VMSLINK(n).TXT提供】时，留言储存到在 VMSLINK(n).TXT语音文件名，可由你的程序经执行程序元件产生 VMSLINK(n).TXT。

3.转接元件的转接号码，若设【转接号码由VMSLINK(n).TXT】时，转接的分机号码在 VMSLINK(n).TXT，可经由资料输入元件、语音讯息元件或你的程序经执行程序元件产生 VMSLINK(n).TXT。

4.听取留言元件，信箱号码若选择【信箱号码由 VMSLINK(n).TXT 提供】，则信箱号码在VMSLINK(n).TXT。

5.播放语音元件，播放完成后到的语音元件，【如果播放完成，到语音元件】选择【元件号码由VMSLINK(n).TXT提供】，则播放完成后，到此文件提供的元件。

6.执行程序元件的输入，给使用者执行程序使用，可由资料输入元件产生的VMSLINK(n).TXT得到。

7.打电话元件的电话号码，若选择【电话号码由VMSLINK(n).TXT提供】，则由此文件提供电话号码。

8.语音线连接元件要连接或不连接在一起两条电话线的线号，若选择【语音连接通道由VMSLINK(n).TXT提供】，则经过此元件时，此文件提供要连接或不连接在一起两条电话线的线号，适合与执行程序元件配合使用。

9.送传真元件的传真文件文件名 ，若设为【传真文件由VMSLINK.TXT提供】时，传真文件可由你的程序经执行程序元件产生 VMSLINK(n).TXT。

VMSLINK(n).TXT作输出用

    1. 由 DIAL.TXT第19栏(「xxxxx」)产生。

    2. 由资料输入元件，输入资料时产生。

    3. 留言元件的留言结果。

    4. 转接元件的转接结果，若不选择【播放无人接听/忙线中讯息】，则无人接听/忙线结果储存在 VMSLINK(n).TXT.。

    5. 执行程序元件的输出，使用者执行程序后，您也可以将结果输出到 VMSLINK(n).TXT，给播放语音元件、留言元件、转接元件、资料输入元件、给另一个执行程序元件使用。

「GOTOBOX(n).TXT」

在执行此执行程序元件之后，跑到那一个元件号码去执行，如：GOTOBOX(n).TXT內容：300，表示跑到元件300去执行。

「EXEACK(n).TXT」

使用者程序通知本系统已经执行完毕。系统产生文件 EXEREQ(n).TXT后，会一直检查 EXEACK(n).TXT 文件是否存在，若发现存在，则自动删除此文件。

[VOICE(n).TXT」

用于播放语音元件，您可规划使用者执行程序产生VOICE(n).TXT之后， 跑到一个播放语音元件以播放语音给来电者听。或播放中文(GB码)语音文件，中文(GB码)自动转换成语音念出。

设定

【给外部程序之功能代码】：

自行指定，用来辨别是那一个执行程序元件，例如【给外部程序之功能代码】=35，则 EXEREQ(n).TXT 內容如下：

35，xxxxxxx，dddddddd

xxxxxxx: 系统目前语音流程所执行的目录，经语言切换元件切换到不同系统语音目录。

dddddddd: 跑到这个执行程序元件的日期。

【等待外部程序之时间设定】:

等待时间由INTERVAL(n).TXT提供或在此直接设定。

【侦测外部程序间隔时间】: 系统侦测外部程序是否产生EXEACK(n).TXT间隔时间。

【等待外部程序时播放语音文件】：

若此栏有语音文件，则当跑到这个执行程序元件，使用者执行程序 没有返回时，会循环播放该语音文件给来电者听，直到发现 EXEACK(n).TXT 文件存在为止。

【外部程序回应后直接跳到其他元件】:

系统发现 EXEACK(n).TXT 文件存在，即外部程序有了回应，则跳到外部程序指定的元件；若不选此项，则在系统发现 EXEACK(n).TXT时，正在播放的语音并不立即停止，会等待此语音播放完毕，才结束执行程序元件的作业。

【等待外部程序失败时跳到语音元件】：

本系统检查 EXEACK(n).TXT 文件是否存在的时间，超过这个等待秒数仍未发现 EXEACK(n).TXT 文件时，会跑到失败元件所设定的元件去执行。


语言切换信箱

<电脑语音广场> 第4章 第九节 语言切换元件

4.9 语言切换元件

语言切换元件提供多种语言功能，经此元件后，切换到不同语言，如切换到英语、粤语或普通话等。

    •

    【自定语音目录】:

    经此元件后，切换这条电话线所有语音文件到另一个目录，而其它电话线不受影响，例如元件900为语言切换元件，其自定语音 流程目录C：\AG32eng\flow (原在 C：\AG32\flow)。则元件900的语音文件切换到C:\AG32eng\flow\900.box\greet.grt

    (原在 C：\AG32 \flow\900.box\greet.grt)，系统语音文件切换到 C：\AG32eng \WAV (原在 C：\AG32\WAV)。使用者必须自行在 C：\AG32eng 下建立所有语音文件目录，和录制所有语音文件。

    这条电话线挂断后，将自动切换回到原来预设的语音文件目录： c：\AG32\flow。

    注意: 切换语音系统文件目录必须在 流程上一级根目录下，例如D:\AG32eng\wav。

    【系统语音目录】:

    切换回到原来预设的系统语音文件目录 \AG32\flow。

    【到语音元件】:

    切换语音文件目录后，跑到那一个元件去执行。

    。上一节 下一节 上一章 下一章 回总目录


文字播放元件

<电脑语音广场> 第4章 第十节 文字播放元件

4.10 文字播放元件 [TTS ,TEXT TO SPEECH;AG32 内置中文文字读音软件包]

使用播放语音元件，可播放中文(GB码或其他码)语音文件，经此语音元件中文自动转换成语音念出。[绝大部分的中文二级字库都能读出，AG32 还提供了造字功能，破音处理功能]

    • 中文(GB码)文件可由固定文件或VOICE(n).TXT提供

    • 如选择语音来源由变量提供：可以播放一个固定的语音文件，也可在字符串前加 * 采用 TTS 方式

    • 采用微软TTS，如文本每一行第一个字符为 *，则按照 TTS 方式播放，没有 *，则采用 SAPI 播放

    【由固定文件提供】: 可按【选择文件】按键选择一个固定文件，如：C:\AG32\V.TXT，则固定由V.TXT文件提供中文码。

    【文件由VOICE(n).TXT提供】： 则固定由VOICE(n).TXT文件提供中文码。

    如果播放完成，到语音元件

    【元件号码由VMSLINK(n).TXT提供】： 如 VMSLINK(n).TXT內容为300，表示到元件300执行。

    【跳到固定元件】： 播放语音成功之后，跑到该元件执行。

    【如果播放失败，跳到语音元件】： 播放语音失败之后，跑到该元件执行。

    中文转语音可以：

    1.念出一个中文语音文件。

    2.播放数字或英文字母。

    3.中文码和语音文件连在一起播放。

    <例子1>（读取中文转语音播放）

    1997年受景气复苏步伐不一，利率走势分歧，以及政治不同等因素影响，今年第四季欧洲股市，也将呈不同面貌。

    <例子2>（读取中文转语音播放）

    98345AS34 (播放数字，英文字母：98345AS34).

    <例子3>（读取中文转语音播放）

    上海A股指数以三千五百七十七点报收，上升一百点。方正十六元五毛，同方八十九元。

    <例子4>

    「*中文码^语音文件目录；语音文件名；语音文件名^」

      1. 1.*王大杰^c：\AG32；a3.wav；a4.wav^再見, (则播放王大杰和 c：\AG32\a3.wav和c:\AG32\a4.wav 语音文件和“再見”).

      2. C:\AG32\A.WAV，C:\AG32\B.WAV

      3. 3.*王大杰&1997/1/17&3:41PM尚有余额$123元, (则播放王大杰1997年1月17日下午3点4时分尚有余额1百2拾3园)

    注意:

    1.若“语音文件目录”栏空白表目录为系统语音目录，预设为 \AG32\WAV.

    2.VOICE(n).TXT，VMSLINK(n).TXT文件，在语音软件产生器、【系统设定】、【外部程序沟通设定」设定的文件目录下(如F：\ABC，表示F：\ABC\VOICE(n).TXT，F：\ABC\VMSLINK(n).TXT)，n代表电话线号，如 VOICE3.TXT，代表第3条电话线。


电话拨号元件

<电脑语音广场> 第4章 第十一节 电话拨号元件

4.11 电话拨号元件 [此元件用来拨号，即发送DTMF 码或者拨号转接座席，而不是通常意义的打电话]

在某些特殊的应用，利用打电话元件送出按键音（DTMF） 等信号音。

电话设定

【拨号设定】: 选择电话号码由固定电话号码或由VMSLINK(n).TXT提供。

【拨号监控】：拨号时要不要判断是否接通。

【等待铃声数目】：若选要【拨号监控】，则输入要等待铃声数以判断是接通，若超过【等待铃声数目】仍未拿起电话，则判断成无人接听。如果拨号完成，到语音元件拨号完成之后，跑到那一个元件去执行。

【元件号码由GOTOBOX(n).TXT提供】: 元件号码由GOTOBOX(n).TXT提供。

【有接通跳到元件号码】: 如100，表示拨号完成之后，若接通，则跑到元件100执行。

【沒有接通跳到元件号码】: 如200，表示拨号完成之后，若沒接通，则跑到元件200执行。

拨座席卡要注意是否已经安装座席卡，座席卡的号码从100，101，以此类推[也可经PBX.ini 设定 ]；

选择拨座席卡后要特别注意，接通后必须进入”通道连接元件“去等待通话完成；否则就是失败！发生异常。拨座席卡之前要确认在当前流程目录下，是否有 hold.wav 或100.wav,101.wav.. 这些文件是在拨打座席卡的时候等待的音乐。客户可自主录制[pcm,8k,8bit,mono];时间长度在20 秒左右即可。

此元件也可以配合交换机发送特别控制码，如可以是：&,201; &,代表flash 动作以后再拨201 分机号码。如dialogic等语音卡，可以设定此flash 代号。常用的是 &,或者 ! .就可以实现电话转接元件的类似功能

对特定的部分语音卡，还可实现在线直接拨打另外一条外线并在拨通后连通。电话号码必须是以*开始，如是以#开始的号码，如 #10，则将通过IP通道拨打设定好的 10 对应的对端 IP 电话或网关[在 pbx.ini 内设定]。


通道连接元件[多方会议元件]

<电脑语音广场> 第4章 第十二节 通道连接元件[多方会议元件]

上一节 下一节 上一章 下一章 回总目录

4.12 通道连接元件[多方会议][仅限于某些卡型]

经过此元件，加入指定的连接通道[一般是外线与内线]，所有加到相同连接通道的语音线，便连接起来，一般可允许多 达4条线在同一[会议]通道[通过特殊设定]。

此通道连接元件有两个用途：

1：由电话拨号元件拨打座席卡接通以后进入，按图默认配置即可，只需更改功能完成后的走向

2：选择了[外线之间连通]，由外线直接进入等待另外的外线进入，直到条件满足，此时需要指定通道号，可以指定，也可以由外部程序临时写入到 vmslink(n).txt ,实现临时的多方会议；要注意，如果外线通道进入的连结方式只是建立连结，完成后必须要再次进入类似的通道连接元件进行取消连接的动作。

连接通道有两种设定

1.语音线连结通道由VMSLINK(N).TXT提供。

2.语音线连结通道由固定的语音连结通道。【离开通道选项】：代表语音线连结到另外一条通道，何时要离开通道，该通道的选项有三：

(1)侦测到挂断

(2)侦测到按键

(3)侦测到时间到：是根据时间依据，依据有两种：

1.根据DISCONNECT(N).TXT

2.根据固定的时间由使用者自行设定。

到语音元件连结或分开完成后跑到下一个元件继续执行。


收传真信箱

<电脑语音广场> 第4章 第十三节 传真接收元件

4.13 传真接收元件

【设定接受传真文件】：

      1. 使用固定文件：将所收的传真文件储存到一个固定的文件，这将会复盖上一次所储存的传真。

      2. 使用VMSLINK(N).TXT所指定的文件：此功能如同上述使用固定的文件，只是固定的文件由VMSLINK(N).TXT提供。

      3. 使用指定接受信箱：使后面的栏位设定为个人信箱号码，则接受传真之后，此传真文件将指定给个人信箱指定接收。

      4. 使用VMSLINK(N).TXT所指定的个人信箱：此功能如同上述使用指定接收信箱，只是个人信箱号码由VMSLINK(N).TXT动态来提供。

【到语音元件】

如果完成，到语音元件：表示接收完传真文件之后，会跳到某一个指定元件。

如果失败，到语音元件：只接收完传真文件若失败，会跳到某一个语音元件。

【选项】

是否即时打印：接收传真成功之后，若此选项打 则将所接收的传真文件即时打印到系统预设之打印机。

产生FAXID(N).TXT文件：将所接收的传真文件內容，包含接收的时间、传真机号码等等的资讯，存储在FAXID(N).TXT里面。

例如：

2003/6/11 09:08:28 ： 86 10 62186575

2003/6/13 09:03:21 ： 86 10 62131778


4

<电脑语音广场> 第4章 第十四节 个人信箱

4.14 个人信箱 [用作企业语音信箱用途] [软件产生器 〉使用者管理]

    •

    【基本设定】

    信箱代码：此为个人信箱之号码。

    信箱密码：此提供个人信箱使用者，进出远端遥控所使用的密码。

    信箱使用者：此表示个人信箱的拥有者名称。

    转接分机号码：此代表个人信箱所指的转接分机。

    • 【功能设定】：功能设定可设定转接分机或直接进入留言信箱，提供使用者不在分机线上时，可提供直接留言。

    【招呼语设定】：可启用转接招呼语或启用留言招呼语。

    【提供系统传真文件】：在送传真信箱的时候，可以根据个人信箱提供的传真文件，文件由这里提供。

    • 个人信箱提供系统之传真文件，此为在送传真时系统由个人信箱所收到的传真文件。

    【讯息通知种类设定】：分为两种，包括留言及传真。

    【讯息通知设定】：方式有四种 B.B.CALL通知、打內线电话通知、打外线电话通知、留言点灯通知等等并提供在画面上设定B.B.CALL号码显示或打內外线分机的号码显示。

    注意：要使用群呼代码，必须先选择一组群呼代码设定，此时才可以编辑群呼设定的內容。

    【留言传送设定】：可使用群呼传送，并设定现在使用的群呼代码为何。

    【群呼代码】：可提供多组群呼代码使用，提供个人信箱留言传送或群呼之用。

    【群呼设定】：此为群呼代码之內容，內容为个人信箱号码，可在此编辑群呼的內容设定。

    【传真传送设定】：也可使用群呼传送，并可设定直接传送的电话号码，而群呼传送并不使用群呼代码，而只能设一组群组。

    【传真传送电话设定】：若选择【直接传送传真】，须输入传真机号码，则当个人信箱接收到传真后，会立即将传真文件直接传送传真，到所输入的传真机号码。

    【群呼设定】：此內容为个人信箱号码，可在此编辑群呼的內容设定，当收到传真时，若设定群呼传送，则会将此传真文件转送到每一个个人信箱里面。

    • 新旧留言可在主画面中查看个人的新旧留言状态，并可立即听取留言及删除留言。

    • 传真文件：个人信箱提供线上即时看传真，也可删除传真文件。


AG32 快速数据库语音查询例程

<电脑语音广场> 第4章 第十五节 数据库操作[含物件指定元件等]

上一节 下一节 上一章 下一章 回总目录

AG32 通用电话语音系统软件,本软件主程序含有17个多功能元件模块[P1~P17]

一个简单的查询系统设定由四个模块元件组成，元件都有一个代码表示，并且含有几个子程序：

1：按键输入元件[播放语音，并且接收DTMF电话按键，把按键值放入一个变量或写入连结文件],元件排序:P 4

2：数据库操作:访问数据库 [使用 通用的SQL 语句] 元件排序:P13

3：物件指定赋值:取数据库栏位字段的数值，及对变量，文件赋值 元件排序:P14

4：播放语音 [包括文本转语音] 元件排序:P 5

1：按键输入元件P4 功能为： 您可把按键值或常数指定给变数[变量]，留作下一元件模块使用。例如下一个元件为P13《程序二》 设定：选定{按键值指定给变数} 第一次按键指定给V1，以后使用此变数时通常采用 %%V1%% 来表示；此变数不会消失，直到重行被赋值或本条线路挂机； 下页进入P4 的《程序3》

P4 的《程序3》

一般选取《依据按键值，执行对应的元件》您可以定义一些一位的特殊按键，以便使用户进行其他项。<程序2>已经由用户输入了按键，此处定义按键完成后到哪个元件去执行。下图显示：其他 >>13000 元件和未输入等几个选项；表示： 用户只要输入了非0和*按键值，都会进入13000 元件 ； 例如13000 元件为查询数据库；

[挂断音/特殊音设定对所有元件定义都一样。]

2: 数据库操作 元件

须首先在 [设定S]》资料库设定内设定　数据源名称，访问者及密码。 数据源设定在《控制面版》32 ODBC 中设定。首先保证此数据源联结正常，否则将不能正常访问数据。

选取《查询》：联结数据源名称，及查询的SQL语句。此处也可执行任何标准的SQL 语句，包括 SELECT、DELETE,UPDATE 等; 执行成功与否根据《程序三》的元件走向进入其他元件节点。

以上执行SQL 语句后，所查询到的纪录指向到了 table1 [ag32 内置的虚拟表]

也可以在执行查询过后，进行下一个节点作 动作〉移动

功能选项 [这些功能可在不同元件代号但是在同样功能元件P13内实现]
¤ 连结
可选择建立新的连结或取消已建立的连结, 数据库连结必须先在主画面选单设定下之数据库设定中做设定。
¤ 动作
可将已建立好查询结果之资料表做纪录的移动。
¤ 查询

连结 : 选择已建立之连结与后端数据库服务器做沟通。指定给资料表 : 将查询出之资料集设定给资料表, 共有 20 个资料表可供设定。 命令 : 输入 SQL 命令与后端数据库服务器做资料的处理。
¤ 记录总笔数
此选项打√时, 会将select 查询后资料集中之资料总笔数记录下来, 以供变量设定指定。
¤ 是否有传回结果集
若 SQL 命令会传回后端数据库结果资料集，例如select，此选项必须打√时

3: [物件指定元件] 本元件 的《程序二》 取数据库值 和对变量 或文件赋值

上一步数据库操作已经定位了数据库的记录，把所查询到的纪录指向了 一个临时表内，例如table1 [本系统每线可提供30个临时数据表，供用户使用]

本元件即希望取出某一字段/栏位的数据，并赋值

指定设定：型态》2 栏位：〉指定给 1 变量 v1~v30

选择资料表 TABLE1，栏位名称为PRICE，指定给V2, 意思是把TABLE1 的PRICE 字段内容取出，且指定赋值给变量参数 V2, 然后按添加箭头，在下面的表内显示。 您也可以按修改按钮，修改；

也可以如下面赋值到一个文件，例如：voice1.txt[1,代表第一线路]，假设下一个元件是文字播放元件，需要一个voice(n).txt 播放 c:\voice\1.wav 和刚才取得的变量v2 则：

指定设定：型态》5.文字〉指定给：31.档案：2 voice(n).txt

需要点击：编辑文字档 会出现一个空白框，输入：

*^c:\voice; 1.wav^ %%v2%%

[完成后点框上的指定健并点添加按钮如下图]

//此处%% %% 代表一个字符串统配符，就像一个括号

//* 代表需要混合播音，语音文件与文字，详情参考4-10 4-16

4: 文字/语音文件放音: 此模块可以实现放音的功能， 无论是文本文字信息，语音文件，日期，金额，数字或是他们的组合 都可以按用户的要求顺序播放。 用户也可以加载其他 TTS 引擎，配合此元件使用，得到需要的效果。

以上四个元件的举例是一个简单又实用的应用，用户可以安排多重按键输入元件模块，实现多级菜单的语音查询。少则 几个元件，多至上千个模块组合，整合 语音/传真/EMAIL 应用，完全可以方便的生成用户的主要业务流程。


AG32 快速数据库语音查询例程

<电脑语音广场> 第4章 第十六节 物件指定元件

程序一 与所有其他元件相同

[物件指定元件] 本元件 的《程序二》 取数据库字段值 和 、或对变量 或文件赋值

1:利用此元件可以对变量,字符串进行赋值

2: 利用此元件，可以对系统内的常用文件赋值

例如：电话打入，进入按键输入元件首先要放音，但放那个音呢？ 可能是文字，可能是固定文件greet1.grt[在本元件目录下存放]，也可能是Dentry(n).txt 或从数据库取得变量再指定,也可能是自定义一个特别是这个节点的语音文件，例如d:\ag32\tools\1.wav.

如下面一个元件是按键输入元件，您可以选择按键输入元件〉程序二〉使用dentry(n).txt 来提供语音。本物件指定元件就可以预先起到此作用。

指定设定：型态》5.文字〉指定给：31.档案：3 Dentry(n).txt

如下面是文字播放元件，则可以把相类似的需要播放的内容赋值到：voice(n).txt,供下一元件使用，以此类推。

首先 取出数据库查询到数据的某一字段/栏位的数据，并赋值

指定设定：型态》2 栏位：〉指定给 1 变量 v1~v30

选择资料表 TABLE1，栏位名称为PRICE，指定给V2, 意思是把TABLE1 的PRICE 字段内容取出，且指定赋值给变量参数 V2, 然后按添加箭头[新增键]，在下面的表内显示。 您也可以按[修改键]按钮，修改；

也可以如下面赋值到一个文件，例如：voice(n).txt[n,代表第n线路]，假设下一个元件是文字播放元件，需要一个voice(n).txt 播放 c:\voice\1.wav 和刚才取得的变量v2

指定设定：型态》5.文字〉指定给：31.档案：2 voice(n).txt

需要点击：编辑文字档 会出现一个空白框，输入：

*^c:\voice; 1.wav^ %%v2%% [特别符号@ 代表换行]

[完成后点框上的指定健并点添加按钮如下图]

//此处%% %% 代表一个字符串统配符，就像一个括号

//* 代表需要混合播音，语音文件与文字，详情参考4-10

¤ 指定设定
A 型态 : 欲指定的型态, 一共有六种型态可供选择
1. 总笔数 2. 栏位 3. 常数 4. 变数 5. 文字 6. 档案
B 指定给 : 可将选择好的型态指定给 30 个变数(Var 1 ~ 30)、档案或 ‘变数’, 其中 :
1. ‘31. 档案‘ 仅能由型态为 ‘5. 文字’ 指定,文字可由 “编辑文字档[M]”按键进入编辑, 文字可为任何字元,也可包含已设定 好的变数(Var 1 ~ 30), 例：
*^;YouHave.wav^$%%V5%%^;NewMsg.wav^$%%V20%%^ [具体规格请参考文字播放元件之设定]
加入变数 5 內容v5 后加入变数 20內容 v20
2. ‘32. 变数‘ 仅能由型态为 ‘6. 档案’ 指定, 档案由 '档案设定’ 中指定, 可以是固定档案也可以是一个自定义档案，档案中之內容格式为: 『%%V(1~30)<-內容%%』
例. %%V5<-1234%% %%V20<-ABCD%%; 将1234指定给变量 5 将ABCD指定给变量 20
C: 指定后型态 : 选择 ‘指定给’ (Var 1 ~ 30及变量) 的型态字串或长整数, 若 ‘指定给’ 为档案则不可设定 ‘指定后型态’

¤ 资料表设定 [数据库 TABLE 表]
1. 型态选择 ‘1. 总笔数’, 必须设定资料表
2. 型态选择 ‘2. 栏位’, 必须设定资料表及栏位名称
¤ 常数设定
型态选择 ‘3. 常数’, 必须设定常数值。此时 常数设定框置能，可以输入常数
¤ 变数设定
型态选择 ‘4. 变数’, 必须选择变数(Var1 ~ 30) 。此时 变数设定框置能，可以输入指定一个变数〉变数
¤ 档案设定 ：0：内置固定档案 1：自定义文件名称
型态选择 ‘6. 档案’ 及指定给选择 ‘31. 档案’, 必须设定档案。
新增键 : 指定设定完成后必须按此键做确认指定的动作, 指定设定列表会新增一笔指定设定之內容。
编辑键 : 若需编辑已确认的指定,需在指定设定列表中选择指定设定,做修改的动作, 修改后再点新增键做确认。
删除键 : 若需删除已确认的指定,需在指定设定列表中选择指定设定,删除已确认之设定。

程序三 成功和失败走向，如赋值不成功，原因可能是数据库字段不能取出，或赋值的目录文件不存在等


AG32 快速数据库语音查询例程

<电脑语音广场> 第4章 第十七节 物件比较元件

程序一 与所有其他元件相同

[物件比较元件] 本元件 的《程序二》 对变量 或常数进行大小比较

比较设定
¤ 变量
选择需比较的变量(Var1 ~ 30)。
¤ 与常数 或 变量做比较
若与常数做比较， 需输入比较数值及型态。
若与变量作比较，需选择变量(Var1 ~30)。
¤ 设定条件
比较条件有 ‘>’、‘<’ 及 ‘=’, 其中条件成立, 则跳至所指定之元件。
¤ 执行完功能后 若比较失败, 则跳至所指定的元件。


产生器的其他功能

<电脑语音广场> 第5章 第一节 产生器的其他功能

第5章

产生器的其他功能

5.1 文本文件 DIAL.TXT ［使语音系统实现拨号，制作拨号任务］

DIAL.TXT为一个文本文件，可以使系统拨出电话，只要用任何软件在DIAL.TXT上建一笔资料即可，其功能有：

1：打电话，打完电话后跳到指定的元件。

2：传送传真。

DIAL.TXT的第九栏表示功能代号，2为定时打电话，13表示定时送传真。

注意：在建立Dial.TXT时必須先检查Dial.TXT是否存在，不存在时才可建立此文件，若系统已处理完毕，系统会将Dial.TXT删除掉，等待下一次新的Dial.TXT产生。

DIAL.TXT 內容中，各栏中间以 逗号「,」相隔，以下为一行的例子，DIAL.TXT內容为：

0，0，19970701，00:00:00，19970701，00:00:00，3，1，2，0-7101213，701，456，19970805，18:14:00，19970807，19:14:00，1，5，"1234567890"

第一栏(0):表示未执行

第二栏: 指定那一条电话线(线号)打电话，0代表由电脑自动找一条空号打。

第三~六栏: 预留给系统用。

第七栏(3): 表示若打不通最多打三次。

第八栏(1): 表示两次打电话之间隔(分种)。

第九栏(2): 表示定时打电话功能。

第十栏: 表示要打的电话号码(0-62186575)。:「-」表示打电话中要停几秒

  • 在【系统设定】、【电话设定】、【一个逗号暂停的时间】设定)。

  • 以下为呼叫B-B-CALL的例子:「0-060123456#9106789#」0表示由交换机分机拨外线，060123456为B-B-CALL号码，9106789为显示在B-B-CALL上的号码。

    •

    第十一栏: 表示打完电话后，若接通则跳到那个(701)元件执行，「-1」表示打完电话

    后，若接通则挂断电话。

    第十一栏: 另一种格式为「 XXX-YYY」，表示打完电话后，若接通时，接电话的是人则跳到XXX元件(100)执行；接电话的传真机则跳到YYY元件(200)执行。

    第十二栏: 表示打完电话后，若不通则跳到那个(456)元件执行，「-1」表示打完电话

    后，若不通则挂断电话。

    第十三栏: 表示定时之开始日期(1997年8月5日)。

    第十四栏: 表示定时之开始时间(18:14:00)。

    第十五栏: 定时之结束日期(1997年8月7日)。

    第十六栏: 定时之结束时间(19:14:00)。

    第十七栏: 1表示打电话时要监督拨号过程，判断拨号音、接通、忙线或无人回答。0表

    示打电话时不要监督拨号过程，打完电话后视为已打通。

    第十八栏: 表示铃响数，5表示等5声铃响。

    第十九栏: 打电话后，将此"1234567890"內容送到VMSLINK(n).TXT之第二栏，供使用者程序或元件用，此栏不一定要。

    送传真

    以下为 DIAL.TXT 一列的例子:

    0，0，19970701，00:00:00，19970701，00:00:00，3，1，13，0，C:\MULTI\FAX1.TXT，7101615，-1，-1，19970805，18:14:00， 19970807，19:14:00

    。

    前八栏与打电话或呼叫B-B-CALL之定义相同。

    第九栏(13): 表示定时送传真功能。

    第十栏: 0表示送传真文件(第十一栏)为文本文件(.txt)，1表示送传真文件为传真文

    件。选择文本文件时，本系统自动判断文本文件(.txt)是中文(GB码)或英文文件，线上即时将中文(GB码)自动转换成传真格式传出。

    第十一栏: 表示送传真文件(C:\MULTI\FAX1.TXT)。

    第十二栏: 表示要打的传真号码(62131778)。

    第十三栏: 表示打完电话后，若接通则跳到那个元件执行，「-1」表示打完电话后，若接通则挂断电话。

    第十四栏: 表示打完电话后，若不通则跳到那个元件执行，「-1」表示打完电话后，若不通则挂断电话。

    第十五栏: 表示定时之开始日期(1997年8月5日)。

    第十六栏: 表示定时之开始时间(18:14:00)。

    第十七栏: 定时之结束日期(1997年8月7日)。

    第十八栏: 定时之结束时间(19:14:00)。

    第十九栏: 拨号完成后，此栏位会连同结果写至VMSLINK(n).TXT

    DIAL.TXT的执行结果

        1. DIAL.TXT执行后，此执行结果会送到 VMSLINK(n).TXT 之

          2. 第一栏，供使用者程序或元件用:

          0: 未执行

          1: DIAL.TXT格式错误

          2: 无法打电话

          3: 无人接听

          4: 执行OK

          5: 电话忙线

          6: 系统内存错误

          7: 传真时发生错误

        2. 使用语音管理程序中，执行【转出拨号文件结果】，结果将存在Result.TXT中，栏位格式与Dial.TXT栏位格式相同，每次执行此功能将重新产生一次Result.TXT供外部程序批次处理结果。

    系统检查 DIAL.TXT的时间间隔

    在【系统设定】的【拨号文件功能设定】中:

    • 【文件目录选项】:

    DIAL.TXT 文件目录在：

    1.DIAL.TXT 文件目录在电脑语音系统目录下。

    2.拨号文件在外部程序构通目录: DIAL.TXT 文件目录在【外部程序构通设定】所设定之目录下。

    【侦测选项】

    1.停止侦查拨号文件：不检查DIAL.TXT，即不利用DIAL.TXT主动打电话或送传真。

    2.开始侦查拨号文件: 开始侦查DIAL.TXT。侦测间隔时间：多少毫秒(ms) 检查一次DIAL.TXT，如：2000(ms)，表示2秒。

    更新DIAL.TXT

    由于本系统会一直更新并删除DIAL.TXT，当您要更改 DIAL.TXT 时，在建立DIAL.TXT的时候，建义关闭语音管理程序，因为对系统而言DIAL.TXT为一个外拨暂存文件，它会在系统每次侦测的时间到时被系统所删除。建义在建立DIAL.TXT时，先建立一个拨号的暂存文件再复制成DIAL.TXT。

    在 dial.txt 内不限制记录行数[要依据用户程序需要而定，一般每次几百个记录即可]


中文文字转语音

<电脑语音广场> 第5章 第二节 中文文字转语音

5.2 中文文字转语音

电脑语音广场软件，包含中文(GB码)自动转换成语音念出(中文TEXT-TO-SPEECH)的功能，适合软件公司发展:

1.念出固定的语音资料，如:学校成绩单语音查询系统等的电话语音应用。

2.念出线上即时变动的语音资料，如:银行存款余额，股票成交等的电话语音应用。

详细功能如下:

念出固定的语音资料:

使用语音资料输入元件的中文TEXT-TO-SPEECH功能，根据来电者在电话上所按的数字，依照 INFORM.TXT 对照表，播放各种语音资讯或线上立即送出一个传真文件给来电者。

INFORM.TXT格式：

「电话按鍵，*中文码，*中文码，...」

<例子>

12345678，*林志颖，*语文 85分，*数学56分，*英文48分，*自然100分

(按键12345678，则播放: 林志颖，语文 85分，数学56分，英文48分，自然100分。)

念出变动的中文语音资料:

可以使用任何语言(如DBASE、C、BASIC等)，经过执行程序元件产生VOICE(n).TXT、VMSLINK(n).TXT 等文字文件，即:

执行程序元件--> 播放语音元件(播放VOICE(n).TXT的中文码)

执行程序元件--> 任何的元件(若【播放招呼语】选【文件名称由 VMSLINK(n).TXT】)

有以下数种方法:

1.使用播放语音元件，经此元件后，播放VOICE(n).TXT的中文(GB码)与语音文件，中文(GB码)自动转换成语音念出。

<中文(GB码)文件例子>

VOICE(n).TXT內容为:

*自然100分 (播放自然100分)

*5^c：\multi;a3.wav^ (播放数字5和 c：\multi\a3.wav)

2.使用任何的元件，若【播放招呼语】选【文件名称由 VMSLINK(n).TXT】时，经此元件后，播放中文(GB码)与语音文件，中文(GB码)自动转换成语音念出。

<中文(GB码)文件例子>

VMSLINK(n).TXT內容为:

*自然100分 (播放自然100分)

*5^c：\multi;a3.wav^ (播放数字5和 c：\multi\a3.wav)

3.使用播放语音元件，选择中文转语音播放选项打ˇ


中文 TEXT-TO-FAX功能

<电脑语音广场> 第5章 第三节 中文 TEXT-TO-FAX功能

5.3 中文 TEXT-TO-FAX功能

电脑语音广场软件，包含中文(GB码)自动转换成传真格式(中文TEXT-TO-FAX)的功能，适合软件公司发展线上即时变动资料的传真回覆(如:银行存款余额、股票成交的传真回复查询等)和传真行销等电话传真应用，您可以使用任何语言(如DBASE，C，BASIC等)，经过执行程序元件来产生中文(GB码)文字文件，即:

执行程序元件-->DIAL.TXT(传真的中文GB码文件)

执行程序元件-->送传真元件(传真的中文GB码文件)

1.主动让系统传送传真的中文TEXT-TO-FAX功能:

只要用任何文书处理软件，如DOS的EDIT、PEII，WINDOWS的记事本或小作家，在DIAL.TXT上建一笔资料，即可打电话，打完电话后跳到指定的元件，请参考DIAL.TXT。

DIAL.TXT 內容：(以下为一列，以「0，0，」为起头)

0，0，19970101，00:00:00，19970101，00:00:00，3，1，13，0，C:\ag32\FAX1.TXT，7101615，-1，-1，19970825，08:11:28， 19970825，09:11:28

第十栏: 0 表示送传真文件(第十一栏)为文字文件(.txt)

1 表示送传真文件为传真文件

2.送传真元件的中文TEXT-TO-FAX功能: 请参考送传真元件

送传真元件，按【设定应答功能】出现设定画面，让您选择被送传真的资料时，在【传真文件格式】选【文字文件】，并在【文字文件选项】【文件名称】输入TEXT文件名。


侦测是人、答录机或传真机接电话

<电脑语音广场> 第5章 第四节 侦测是人或传真机等接电话

5.4 侦测是人、答录机或传真机接电话

[天羚语音卡可通过语音侦测程序测定信号，其他语音卡请参考不同语音卡的侦测工具]

在一些电话行销或传真行销的应用中，打电话出去，必须自动侦测接电话的是人、电话答录机或传真机，如果是人接电话，则播放语音，介绍产品或其它通告(如停话通知)；如果是电话答录机接电话，则在播放语音的当中，听到电话答录机的哔一声后，自动重头播放语音，如介绍产品，以便答录机录下完整的语音內容；如果是传真机接电话，则自动传送传真资料，如产品目录的传真资料。这种自动侦测接电话的是人、电话答录机之哔声或传真机之应答声(Answering Tone)。可利用下面两种方法:

1.使用【特殊音侦测设定】的设定

2.使用DIAL.TXT

使用【特殊音侦测设定】的设定

在各语音元件的【特殊/挂断音设定】中设定特殊音，如:电话答录机之哔声、传真机之应答声或特殊之控制信号。本系统侦测到特殊音时，会根据在各元件的设定，改变语音流程，基本上，第一組特殊音是用来定义电话答录机之哔声，各厂牌电话答录机的哔声特殊音，可能不同，您可设定占有率最高的几种厂牌之哔声特殊音(如三个厂牌，在语音侦测程序设定三个第一組特殊音)；而第二組特殊音是用来定义传真机的应答声，传真机的应答声特殊音，各厂牌相同，只须设定一个。

<设定>

在语音侦测程序中用鼠标选所要设定的电话线后，选【设定】、【来电挂断设定】，按【增加】按键，在【型态】选预设的第一組(和第二組特殊音)，按【确定】即可，在【全设定】打勾设定所有电话线。

设定其它的特殊音或其他厂牌电话答录机的哔声特殊音前，须先用【工具】、【讯号录音员】测试及分析特殊音特性的频率，有声长度、无声长度和侦测时间后，用鼠标选所要设定的电话线后，选【设定】、【来电挂断设定】，按【增加】按键，在【型态】选第一組(或第二组，或第三组)特殊音，填入数值，即可以增加一組所选要设定电话线的特殊音侦测设定。

使用DIAL.TXT

使用DIAL.TXT，也可以自动侦测接电话的是人或传真机。

DIAL.TXT 內容：(以下为两列的例子，以0，0，为起头)

0，0，19970101，00:00:00，19970101，00:00:00，3，1，2，7101213，100-200，456， 19970805，18:14:00，19970807，19:14:00，1，5，"12345，67890"

第十一栏:「XXX-YYY」

表示打完电话后，若接通时:

接电话的是人则跳到XXX元件(100)执行.

接电话的传真机则跳到YYY元件(200)执行.

1．YYY元件(200)为送传真元件: 在语音软件产生器，此元件的功能设定为【送传真元件】，设定如下:【播放招呼语】： 不选【播放招呼语】，到此元件不要播放一个语音文件。【执行完应答功能后继续做】： 执行完应答功能后，到那一个元件继续执行，选【挂断】，执行完应答功能后挂断。

2．在语音软件产生器，【系统设定】的【传真设定】之【传真自动回复方式】，须设定为:【线上即时式】(One Call Fax Retrieval)。

3．务必设定打电话出去特性：判断打电话出去时是否有无人接听，或忙线中，请在【语音侦测程序】中测试和设定，请参考语音侦测程序。

4．在语音侦测程序，选【设定】、【拨号过程监控设定】，按【增加】按键，增加【传真机之应答声】一项，并设定【传真机之应答声】的特性: 频率=2100，有声长度=1000毫秒后，按【进阶】，在【回应声的侦测设定】选【后缘触发】，并填入适当的【回应声的最大间隔】，如1000毫秒，在【全设定】打勾设定所有电话线，按【确定】。

5．测试所设定的特性是否正确选语音侦测程序的【工具】、【讯号测试员】，出现以下画面，选【测试接通状态】，先填入传真机电话号码(由本系统所接的电话号码，打电话到另一个传真机的电话)，按【开始测试】。测试结果若显示「接电者为传真机」，即为正常。


三方通话功能

<电脑语音广场> 第5章 第五节 三方通话功能

5.5 三方通话功能

利用电信局、交换机或连接元件的三方通话功能，可将来电转到另一个电话并计算通话时间。

1.利用电信局的三方通话功能

来电-->本语音系统接电话-->本语音系统按电话FLASH，利用同一条电话线打电话出去，接通后-->按电话FLASH造成三方通话(来电者、本语音系统和打电话出去接电话者)-->本语音系统计算通话时间直到来电者或接电话者挂断电话。

<设定>

所须的元件:

-->转接元件(例如元件8001)

-->执行程序元件(元件8003)

转接元件(元件8001)

详见转接元件，交换机转接之号码，以下二者选一：

【转接固定号码】：转接到固定的分机号码。

【转接号码由VMSLINK(n).TXT提供】：转接的号码在VMSLINK(n).TXT，可经由资料输入元件、或你的程序经执行程序元件产生 VMSLINK(n).TXT。

利用电信局的三方通话功能

三方通话时须不【释放电话线】，并设定打电话出去接通后，要达到三方通话功能，所须的按电话FLASH的时间(即拉回时间)。

利用交换机的三方通话功能

来电-->交换机-->本语音系统接电话(本语音系统接到交换机優先响的分机)-->本语音系统执行电话FLASH，利用同一条电话线打电话出去到另一分机，接通后-->按电话FLASH，造成三方通话(来电者、本语音系统和打电话出去接电话者)-->本语音系统计算通话时间直到来电者或接电话者挂断电话。

有的交换机之三方通话(会义)须按数个键(即拉回按键码)，有的交换机须按电话FLASH两次(在拉回须二次打x)，并须设定FLASH两次的间隔时间(即两次之间隔时间)；有的交换机之三方通话(会义)须设定拉回按键码，如： 西门子交换机的拉回按键码=3 或 8。

若不选择【播放无人接听/忙线中讯息】，则打电话出去无人接听时，跳到以下的语音元件号码()执行；忙线时跳到以下的语音元件号码()执行。

计时设定

打电话出去接通后，则跳到任一元件执行，详见计时设定。要做计时功能时，则选择【启动计时】(打勾)，

【等待条件】: 选择一直等到【时间到】(600秒)和【挂断电话】(来电者和打电话出去接电话者，都挂断电话时)。

计时结果存于TIME(n).TXT文件，单位为毫秒ms。

等到【时间到】(600秒)或【挂断电话】时，跳到执行程序元件(元件8003)执行，以计算累计时间或费用。

注意：务必设定打电话出去和来电挂断特性。

利用 通道连接元件的三方通话功能

通道连接元件[P11]可以配合外部程序达到三方通话的功能:

A来电-->本语音系统接电话-->执行程序元件-->连接元件-->

B来电-->本语音系统接电话-->执行程序元件-->连接元件-->

(或打电话出去-->执行程序元件-->连接元件-->)

A与B线连接起来，造成三方通话(来电者、本语音系统和打电话出去接电话者)-->本语音系统计算通话时间直到来电者或接电话者挂断电话-->连接元件(不连接)。

可选择进入连接的语音连接通道，是由VMSLINK(n).TXT或固定的语音连接通道提供。

【语音线设定由VMSLINK(n).TXT提供】:

经过此元件时，VMSLINK(n).TXT提供语音连接通道，适合与执行程序元件配合使用，VMSLINK(n).TXT可由您的程序，经过执行程序元件时提供。

VMSLINK(n).TXT內容：

1，线号A，线号B

配合【连接通道】设定：

      1. 只做连接：表示将线号A和线号B的两条电话线加到同一个语音连接通道。

      2. 只做不连接：表示将线号A和线号B由某一个语音连接通道中移除。

      3. 连接后判別条件：表示将线号A和线号B于连接后，等待判別条件成立。


听取留言、远端摇控

<电脑语音广场> 第5章 第六节 听取留言、远端摇控

5.6 听取留言、远端摇控

本系统可透过任一个电话，由远端打电话进来以听取留言、更改所播放的语音和改变信箱的设定，其方式为经过听取留言/更新设定信箱，再输入信箱号码和密码。

远端遥控，在系统设定、【来电设定】的【启动远端遥控功能】中设定(打勾:可远端遥控)，进入听取留言、远端遥控流程，侦测到挂断音(来电挂断)时，将挂断电话；侦测到特殊音时，将忽略不管。

远端遥控中只有在接电话元件可按5修改远端应答功能，见使用手册:

其余按键之远端遥控流程见使用手册:


系统语音

<电脑语音广场> 第5章 第六节 系统语音

5.7 系统语音

所有系统语音文件在应用程序之 WAV 目录之下:

VC0.WAV 再见

VC1.WAV 已是最后一笔留言

VC2.WAV 只启动留言讯息通知按1、只启动传真讯息通知按2、取消所有讯息通知按3、启动所有讯息通知按4、结束按0

VC3.WAV 未输入

VC4.WAV 未输入分机号码请重新输入

VC5.WAV 正确请按1、重新输入请按2

VC6.WAV 有您的留言请输入密码、结束时请按＃字号

VC7.WAV 有您的留号如下

VC8.WAV 此群组代码并不存在

VC9.WAV 群组代码并不存在请重新查明后再删除

VC10.WAV 利用呼叫器请按1、打內线电话请按2、打外线电话请按3、点留言灯请按4、结束请按0

VC11.WAV 并且有您的留号如下

VC12.WAV 抱歉您输入错误

VC13.WAV 信箱尚未录制问候语

VC14.WAV 信箱原先的问候语为

VC15.WAV 按1重听、按2下一笔、按3删除、按4保留、按9转送给其他信箱、按0结束

VC16.WAV 按1重听、按2下一笔、按3删除、按9转送给其他信箱、按0结束

VC17.WAV 若您是使用传真机请按1，以便开始接收您的传真资料、若您市使用一般话机请按2，并输入您的传真机号码

VC18.WAV 若要重听请按1、重录请按2、取消请按3、确定请按0

VC19.WAV 若要重听请按1、重新输请按2、取消请按3、确定请按0

VC20.WAV 若要重听问候语请按1、录制新的问候语请按2、结束请按0

VC21.WAV 若要启用远端遥控请按1、取消远端遥控请按2、结束请按0

VC22.WAV 若要变更请按1、结束请按0

VC23.WAV 要变更设定请按1或按0结束

VC24.WAV 刚才有您的传真

VC25.WAV 留言转送完毕

VC26.WAV 讯息通知类別设定按1、讯息通知方式设定按2、结束按0

VC27.WAV 密码已变更

VC28.WAV 密码错误无法变更

VC29.WAV 您已沒有留言

VC30.WAV 您已设定启用留言问候语

VC31.WAV 您已设定启用转接问候语

VC32.WAV 您未输入信箱号码

VC33.WAV 您未输入按键

VC34.WAV 您未输入个人信箱号码

VC35.WAV 您未输入密码

VC36.WAV 您未输入群组代码

VC37.WAV 您沒有留号

VC38.WAV 您沒有新的留言

VC39.WAV 您沒有旧的留言

VC40.WAV 您尚未设定启用留言问候语

VC41.WAV 您尚未设定启用转接问候语

VC42.WAV 您的留言是

VC43.WAV 您的留号是

VC44.WAV 您按键输入错误

VC45.WAV 您按键错误次数已满

VC46.WAV 您按键错误次数已满结束传真功能

VC47.WAV 您现在有

VC48.WAV 您现在的设定为直接留言

VC49.WAV 您现在的设定为转接分机

VC50.WAV 您曾录制的问候语为

VC51.WAV 您输入的信箱代码为

VC52.WAV 您输入的信箱号码不存在

VC53.WAV 您输入的信箱号码为

VC54.WAV 您输入的密码错误

VC55.WAV 您输入的群组代码为

VC56.WAV 您输入的号码为

VC57.WAV 您输入的显示号码为

VC58.WAV 您输入信箱号码错误

VC59.WAV 您输入按键错误

VC60.WAV 您输入按键错误次数超过

VC61.WAV 您输入个人信箱号码不存在

VC62.WAV 您输入个人信箱错误

VC63.WAV 您输入错误

VC64.WAV 您输入错误请重新输入

VC65.WAV 现在分机忙线中

VC66.WAV 现在分机无人接听

VC67.WAV 现在的铃响数为

VC68.WAV 现在开始录制问候语请于听到哔一声后开始留言结束时请按＃字号

VC69.WAV 设定已变更

VC70.WAV 设定转接问候语请按1、设定留言问候语请按2、结束请按0

VC71.WAV 这是留言传送功能个人信箱

VC72.WAV 这是传真通知传送功能个人信箱

VC73.WAV 无此分机号码请重新输入

VC74.WAV 笔保存的留言

VC75.WAV 笔新的留言

VC76.WAV 传真文件准备中请稍侯

VC77.WAV 新的问候语为

VC78.WAV 新增群组设定请按1、删除群组设定请按2、查询群组设定请按3、结束请按0

VC79.WAV 新增请按1、修改请按2、删除请按3、结束请按0

VC80.WAV 群组之信箱为

VC81.WAV 响铃数已变更

VC82.WAV 响铃数设定请按1、远端控制请按2、结束请按0

VC83.WAV 确定请按1、取消请按2

VC84.WAV 请以2位数输入日期

VC85.WAV 请以2位数输入月份

VC86.WAV 请以2位数输入几分

VC87.WAV 请以2位数输入几点

VC88.WAV 请再输入一次新的密码以＃字号结束

VC89.WAV 请于哔一声后开始留言按＃字号结束

VC90.WAV 请于哔一声后开始留号按＃字号结束

VC91.WAV 请于哔一声后开始录制新的问候语按＃字号结束

VC92.WAV 请按下您的传真机开始键以便开始接收您想获得的传真文件

VC93.WAV 请输入內线分机号码以＃字号结束

VC94.WAV 请输入外线电话号码以＃字号结束

VC95.WAV 请输入呼叫器的显示码

VC96.WAV 请输入呼叫器号码以＃字号结束

VC97.WAV 请输入要删除的群组代码以＃字号结束

VC98.WAV 请输入要查询的群组代码以＃字号结束

VC99.WAV 请输入个人信箱号码按＃字号结束

VC100.WAV 请输入密码以＃字号结束

VC101.WAV 请输入您的传真机号码以#字号结束，以便由系统发送传真给您

VC102.WAV 请输入新的信箱代码以米字号做间隔以＃字号结束

VC103.WAV 请输入新的密码以＃字号结束

VC104.WAV 请输入新的群组代码以＃字号结束

VC105.WAV 请输入新的铃响数以＃字号结束

VC106.WAV 请输入语音信箱号码按#字号结束

VC107.WAV 请输入数字键

VC108.WAV 输入群组代码按１输入个人信箱按2选择全部按3结束按0

VC109.WAV 继续查询请按1结束请按0

VC110.WAV 响

VC111.WAV 变密码请按1变更转接设定请按2问候语设定请按3讯息传送设定请按4群呼组別设定请按5,结束按0

VC112.WAV 变更启用设定请按1录制问候语靖按2结束请按0

VC113.WAV 按1听取新的留言

VC114.WAV 按2听取旧的留言

VC115.WAV 按3更改问候语

VC116.WAV 按4留言群呼

VC117.WAV 按5修改远端应答设定

VC118.WAV 按6个人信箱设定

VC119.WAV 按0其他信箱

VC120.WAV 按#字号挂断

VC121.WAV 您输入的传真机号码为

VC122.WAV 继续等待请按

VC123.WAV 若要留言，请按

VC124.WAV 转按其他分机请按

VC125.WAV 转接总机请按

VC126.WAV 要收传真请按

VC127.WAV 传真机目前忙线中，若您要等待请按＃字号，

否则系统将会挂掉或是请您稍后再拨，谢谢。

VC128.WAV 留言失败

VD01.WAV 现在启动群呼设定功能

VC02.WAV 请选择立即传送按1，定时传送按2，结束按0

VD22.WAV 请确定群组代号，再使用此功能

VD23.WAV 您所输入的群组代号为

VD06.WAV 抱歉您的时间输入错误

VD07.WAV 您输入的时间为

VD08.WAV 确认无误请按1，重新输入请按2

VD19.WAV 群呼按1，重新输入按2，结束按0

VD20.WAV 请输入群组代号，结束时按＃字号

VD21.WAV 此群组代号不存在

VD40.WAV 重听次数已满

VD41.WAV 重录次数已满

~HOLD.VOC （音乐文件）


使用语音、传真范例

<电脑语音广场> 第6章 第一节 使用语音、传真范例

第6章

使用语音、传真范例

6.1 应用范例:

电脑语音广场软件包含各类语音、传真应用范例，这些应用范例全部由语音软件生成器架构生成，基本的流程架构可供使用者参考。在实际的应用中，您必须考虑各种使用情況，修改语音软件生成器架构及设定，必要时再配合外部程序，即可架构出各种多线电话语音传真应用，每一個应用范例都有其测试编号(即起始元件号码)，使用者可根据测试编号模拟它的语音或传真功能，也可以利用语音软件生成器修改架构，以生成不同的流程，符合实务的需要。

天羚公司为您收集了许多应用，在光盘的\50ap 目录下，在每个子目录下，都存在类似flow的应答流程例子，您可使用《电话语音载入程序》直接载入到一个您喜欢的目录，然后使用《语音软件生成器》〉文件〉更改电话流程：打开您刚才导入的目录； 您就可以看到流程的例子。您也可以直接复制一个流程到您喜欢的目录，但此时的文件夹是只读的，请更改属性，方可利用《语音软件生成器》修改流程。

退出其他程序，执行主运行程序《电话语音管理程序》，电话打入就可听到应答了。如接听又挂断了，代表《电话语音管理程序》包含的<电话设定>内设定的元件不存在或错误。其他可能有一些语音文件不存在，例如例程需要一些语音在d:\voice 没有复制或录制；可打开《电话监视程序》〉打开一个通道〉观察在播放哪个语音文件，如不存在，则录制。


线上模拟测试

<电脑语音广场> 第6章 第二节 线上模拟测试

6.2 线上模拟测试 [对天羚卡有效]

<步骤1>

关闭语音软件生成器，並执行电脑语音系统之电话语音管理程式，执行【电话语音管理程序】，如下画面：

    • <步骤1> 执行【线上模拟】出现以下画面：

    • 若执行电话监视程序，則可看到详细线上情況，在屏幕上面可以看到如下画面：

    • <步骤 3> 在模拟程序按测试编号

    执行【电话语音管理程序】中的线上模拟， 听到「输入测试编号」时，在电话机上按测试编号，即可测试各类的语音、传真应用范例。

    注意:

      1. 本系统出货预设接电话元件为1000，若在作线上模拟测试时，没听到「输入测试编号」时，请执行语音软件生成器，用鼠标在左边显示的元件(语音元件一览表)选元件1000，然後在【系统设定】中选【设定为接电话元件】，关闭语音软件生成器，並执行语音管理程序中的【线上模拟】。

      2. 电话行销或传真行销等主动打电话或送传真的动作，请执行电话调查系统。


执行一种应用范例

<电脑语音广场> 第6章 第三节 执行一种应用范例

6.3 执行一种应用范例

如果您只要执行一种流程，例如自动总机，您只要执行【语音软件生成器】，用鼠标在左边显示的元件(语音元件一览表)选元件1000，在【系统设定】中，选【设定为接电话元件】，再关闭【语音软件生成器】，並执行【电话语音管理程序】中的【线上模拟】。


电话语音查询系统

<电脑语音广场> 第7章 电话语音简单查询系统

第七章 [如本系统提供的软件光盘内有\50ap,目录；用户使用可以载入程序载入50ap\简单语音查询\flow 流程，参考以下的说明，或请参考50ap.chm 帮助文件]

用户也可直接载入或copy 一个例子，例如工资查询系统，设置好参数以后；实际体会一下。

电话语音查询系统

电脑语音广场，架构各语音元件的树状状系图，不一定要写程序，即可产生一套电话语音查询系统之应用。电脑语音广场，根据来电者在电话上所按的数字，依照对照表，播放各种语音信息或送传真给来电者。来电者在电话上所按的数字存成文字文件，根据输入值，依照一个文字文件表，跑到对应的语音查询元件。电话语音查询系统的运用例子有：

学校招生咨询 企业工资查询系统 政务办事查询 个人账户查询等

语音信息查询服务 银行存款电话语音查询 张老师讲故事 汽车拖吊电话语音查询

张老师讲笑话 汽车遗失电话语音查询 股市电话分析 汽车修护状况电话语音查询

股市电话语音成交回报 电影内容语音查询 联考放榜电话语音查询 电话英语教学

电话算命 电视节目内容语音查询 。。。。。

以电话英语教学为例，只须要使用按键输入元件就可以架构完成。

按键输入元件: 接受电话号码的按键输入。接受电话英语教学第一、第二个问题的按键回答输入。

请执行【语音软件生成器】，用鼠标在左边显示的元件(语音元件一览表)选元件4350(即电话英语教学的起始元件号码)，再在【系统设定】中选【设定为接电话元件】后，自动显示树状结构图，并执行语音管理程序中的【线上模拟】，即可模拟电话英语教学功能。

<树状图和所用元件表>

此例子的流程为:

按键输入元件4350(接受电话号码的按键输入)-->按键输入元件4300(接受电话英语教学第一个问題的按键回答输入)-->按键输入元件4310(接受电话英语教学第二个问題的按键回答输入)

1. 按键输入元件4350，播放语音例如C:\AG32\Tools\4350.BOX\GREET1.GRT(「请输入您的电话号码后，开始作电话测验」，播放语音次数=1)中，接受电话号码的按键输入(按一个键，按键最大长度语音1=1)。

2. 按键输入元件4300，播放语音例如C:\AG32\Tools\4300.BOX\GREET1.GRT(播放语音次数=1)中，接受电话英语教学第一个问題的按键回答输入(按一个键，按键最大长度语音1=1)。

3. 按键输入元件4310播放语音例如C:\AG32\Tools\4310.BOX\GREET1.GRT(播放语音次数=1)中，接受电话英语教学第二个问題的按键回答输入(按一个键，按键最大长度语音1=1)。可利用外部程序检查VMSLINK(n).TXT，分析VMSLINK(n).TXT內容如62186575，2，3。


一般的语音查询应用

<电脑语音广场> 第7章 第一节 一般的语音查询应用

7.1 一般的语音查询应用

查询的信息变动较少的语音信息查询的运用，不须要写程序，使用按键输入元件，设定根据INFORM.TXT内容播放语音，根据来电者在电话上所按的数字，依照INFORM.TXT各种语音信息播放，准备INFORM.TXT语音信息对照表即可。例如：语音信息查询服务、张老师讲故事、张老师讲笑话、股市电话分析、联考放榜电话语音查询、电话算命、汽车拖吊电话语音查询、汽车遗失电话语音查询、汽车修护状況电话语音查询、电影内容语音查询和电视节目内容语音查询等等。

本节使用按键输入元件(提供语音信息查询的语音信息)与设定循环回路(提供信息可查询的次数)箱，架构电话语音查询系统，以下以语音信息查询服务为例子，说明如下:

执行【语音软件生成器】，用鼠标在左边显示的元件(语音元件一览表)选元件1100(即语音信息查询服务的起始元件号码)，再在【系统设定】中选【设定为接电话元件】后，自动显示树状结构图，关闭语音软件生成器，并执行【语音管理程序】中的【线上模拟】，即可模拟语音信息查询功能。

<树状图和所用元件表>

<各元件功能>

元件 1100、1104：循环回路，提供语音信息查询的次数。每一个循环回路，含循环回路的起始、继续和结束等三个元件。

元件1102: 提供语音信息查询的语音信息。

1.循环回路的起始: 元件 1100用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件1100后，按鼠标二下，核取是否计数，按【设定】按键，即可看到设定:

    • 设定为起始循环回路，设定为【取用一个新计数器】，【起始值】=1， 经此循环回路元件后，跑到步骤三元件号码1102执行。

    2.循环回路的继续: 元件 1104

    用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件1104后，按鼠标二下，进入功能设定做功能设定，核取【是否计数】，按【设定】按键，即可看到应答功能设定:

    •

    设定为【下一轮】，每次经此元件后，循环次数减一，若循环次数=0，经此循环回路元件后，跑到元件号码90去执行： 若循环次数 >0， 经此循环回路元件后， 跑到步骤三元件号码1102去执行。

    3.元件 1102: 按键输入元件

    元件 1102 提供语音信息查询的语音信息，来电者在电话输入查询代号，根据 C:\AG32\Tools\1102.BOX\INFORM.TXT ，播放语音信息，可用任何文书处理软件或使用程序语言准备INFORM.TXT。以下为C:\AG32\TOOLS\1102.BOX\INFORM.TXT的例子:可至功能设定中核取根据INFORM.TXT内容播放语音，编辑INFORM.TXT

    1234，$1234.WAV

    1235，$1235.WAV

    1236，$1236.WAV

    1237，$1237.WAV

    1238，$1238.WAV

    1239，$1239.WAV

    1240，$1240.WAV

    1241，$1241.WAV

    1242，$1242.WAV

    1243，$1243.WAV

    元件1102播放语音\1102.BOX\VOC\GREET1.GRT中，接受信息查询代号(四位数字:按键最大長度语音1=4)，如按信息查询代号1240，根据 \1102.BOX\INFORM.TXT ，则播放语音信息 \1102.BOX\1240.WAV 语音文件，输入将被存在VMSLINK( n).TXT文件，最后到元件 1104 循环回路元件去执行。

    其它电话语音查询系统的应用例子，循环回路的元件号码和语音信息元件号码如下表:

    电话语音查询的应用例子

    循环回路元件号码

    起始 继续

    按键输入

    元件号码

    语音信息查询服务

    1100

    1104

    1102

    张老师讲故事

    1200

    1204

    1202

    张老师讲笑话

    1300

    1304

    1302

    股市电话分析

    405

    445

    联考放榜电话语音查询

    1600

    1604

    1602

    电话算命

    1700

    1704

    1702

    汽车拖吊电话语音查询

    1110

    1114

    1112

    汽车遗失失电话语音查询

    1120

    1124

    1122

    汽车修护状況电话语音查询

    1130

    1134

    1132

    电影内容语音查询

    1140

    1144

    1142

    电视节目内容语音查询

    1160

    1164

    1162

    7.1.1 电信业务语音查询系统

    本节使用按键输入元件，模拟一个电信业务的电话语音查询系统，并设定循环回路计数，查询多种语音信息或重听。

    <步骤 1> 建立新的按键输入元件

    执行【语音软件生成器】，选【语音元件】的【新增元件】，如下：

    输入【元件号码】和【元件叙述】及做功能设定，不选【播放招呼语】，在应答功能 ，指定此元件功能，在【元件功能】右边按 [image] 选【按键输入元件】:

    在【功能设定】下:

    • 【播放语音个数】=1 :设定一个语音文件，接受一栏按键。

    【按键最大長度 语音1】=3:最多按3个键。

    【错误重试次数】=1 重新电话输入为一次。

    听取根据Inform(n).TXT内容播放语音

    在【按键设定】下选择【根据按键值】，在按键值选择【其他】【跳至元件】输入8010按 [image] (新增):　按完电话按键后会跑到元件8010。

    同上选项按键值选择【输入错误】及【未输入按键】，跳至元件输入8090,若不按键(含重试一次后)时，会跑到此元件8090。

    在语音软件生成器，按 [image] 准备语音资料

    按【录音】按钮，以录制「您好，这是电信业务的电话语音查询系统，请按查询代号，例如按123可查询如何申请电话」的语音文件，录完按【停止】后，储存成\AG32\Tools\8000.box\greet1.grt的语音文件，按【储存文件】、【确定】按钮。

    在【跳到语音元件：】填入元件8300。

    建立元件8050:

    选【语音元件】的【增加元件】以增加元件8050，在招呼语选项中核取【是否播放招呼语】，按【选择文件案】按钮，按【录音】按钮，以录制「再見」，按【停止】、【确定】按钮。

    在【元件功能】右边按 [image] 选【只播放语音元件】。

    <步骤 8>

    关闭语音软件生成器，并执行语音管理程序中的【线上模拟】，即可模拟整套功能。7.1.2 成绩单语音查询系统

    本节使用语音信息元件和中文转语音功能，模拟一个学校成绩单语音查询系统。请参考电信业务语音查询系统，大部份相同，仅小幅度修改如下:

    <如果您已有一个成绩单的数据库，你可使用外部程序，来准备这一个TEXT文件(INFORM.TXT)，或使用Windows附属应用程序 中的记事本，并输入如下，另存新文件储成 C:\AG32\Tools\8000.BOX\INFORM.TXT 文件：

    <方法一>

    使用中文转语音( TEXT-TO-SPEECH)

    INFORM.TXT格式：

    「电话按键，*中文GB码，*中文GB码，...」:

    中文 TEXT-TO-SPEECH，中文(GB码)自动转换成语音念出。

    <例子>

    12345678，*林志颖，*语文85分，*数学56分，*英文48分，*自然100分

    按12345678，则播放:

    林志颖，语文85分，数学56分，英文48分，自然100分。

    <方法二>

    INFORM.TXT内容：

    「电话按键(学号)，语音文件名(学号)，*xxxxxxxx，语音文件名(语文)，*AA(语文分数)^语音文件名(分)^，语音文件名(数学)，*BB(数学分数)^语音文件名(分)^，语音文件名(英文)，*CC(英文分数)^语音文件名(分)^，语音文件名(自然)，*DD(自然分数)^语音文件名(分)^」

    播放语音文件在\AG32\目录下。

    如上，在电话按键12345678(学号)时，播放语音文件:

    「学号(n.wav)12345678，语文(c1.wav)85分(a.wav)，数学 (c2.wav)56分(a.wav)，英文(c3.wav)48分(a.wav)，自然

    (c4.wav)100分(a.wav)。」

    在电话按键12345680(学号)时，播放语音文件:

    「学号(n.wav)12345680，语文(c1.wav)65分(a.wav)，数学(c2.wav)98分(a.wav)，英文(c3.wav)78分(a.wav)，自然(c4.wav)65分(a.wav)。」

    在语音软件生成器，按 [image] 准备语音资料。

    按【录音】按钮，以录制:

    「学号」(储存成\multi\n.wav的语音文件)

    「语文」(储存成\multi\c1.wav的语音文件)

    「分」(储存成\multi\a.wav的语音文件)

    「数学」(储存成\multi\c2.wav的语音文件)

    「英文」(储存成\multi\c3.wav的语音文件)

    「自然」(储存成\multi\c4.wav的语音文件)

    <步骤 3>

    状闭【语音软件生成器】，并执行【语音管理程序】中的【线上模拟】，即可模拟整套功能。


一般的语音查询应用

<电脑语音广场> 第7章 第二节 计费的语音查询应用

7.2 计费的语音查询应用

计费方式的语音信息查询的应用，如股市电话分析等，必须配合执行使用者自己写的程序以检查有无此会员，缴会费情形等，本节用以下的元件，架构一个会员制的股市电话分析系统:

循环回路元件: 提供输入会员号码/密码的次数和重听次数

按键输入元件: 提供来电者在电话上输入会员号码/密码

执行程序元件: 检查有无此会员，欠缴会费

播放语音元件: 提供语音信息查询的语音信息

接受按键元件: 提供重听的选择

其执行流程如下:

1. 使用按键输入元件，将来电者在电话上所按的数字，储存在 VMSLINK(n).TXT中，再到执行程序元件。

2. 使用执行程序元件，依照来电者在电话上所按的数字(即VMSLINK(n).TXT)，执行自己的程序，检查有无此会员或欠缴会费，找到对应语音的语音信息，准备语音文件在 VOICE(n).TXT，再到播放语音元件。

3. 播放语音元件，经此元件播放语音(语音文件在 VOICE(n).TXT）。

7.2.1 股市分析语音系统（会员制）

本应用须配合执行你自己写的程序，在外部程序设计中详细说明使用者的程序如何配合。请先执行你自己写的程序,用于检查会员资料，才会正常动作，再执行语音软件生成器，用鼠标在左边显示的元件(语音元件一览表)选元件1400(即会员制的股市分析系统的起始元件号码)，再在【系统设定】中选【设定为接电话元件】后，自动显示树状结构图，关闭语音软件生成器，并执行语音管理程序中的【语音线模拟】，即可模拟股市分析的功能。

<所用元件表>

<树状图>

<设定>

用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件后，按鼠标二下，进入功能设定，即可看到所要设定元件的应答功能设定.

<各元件功能>

元件 1400 直接跑到元件 400 去执行。

1.播放语音元件: 元件 400，440，450，460，480，499

2.元件 405，445，430，455，475，477:

只播放语音元件核取是否计数: 循环回路1(输入号码，密码次数)包括元件 405，445，430。循环回路2(重听次数) 包括元件 455，475，477。

每一个循环回路，含循环回路的起始、继续和结束等三个元件

循环回路的起始: 元件 405，455

循环回路的继续: 元件 445，475

循环回路的结束: 元件 430，477

循环回路1的起始: 元件 405

设定为【取用一个新计数器】，起始值=2，即循环次数为2，经此循环回路计数后，跑到元件号码410执行。

循环回路1的继续: 元件 445设定为【下一轮】，每次经此元件后，循环次数减一，若循环次数 =0，经此循环回路计数后，到元件号码480去执行，若循环次数 >0, 经此循环回路计数后， 跑到元件号码410执行。

循环回路1的结束: 元件 430设定为【归还最近取用之计数器】，结束这个循环回路，经此循环回路计数后， 跑到元件号码435执行。

3.元件 410:资料输入元件

播放语音次数=2，设定2个语音文件，顺序为：

a. 播放第1个语音文件(GREET1.GRT)，接受第1次电话按键(最多按几个键，依据【按键最大長度语音1】=5，如按12345。

b. 播放GREET2.GRT，接受第2次电话按键(最多【按键 最大长度语音2】=5)，如按54321。

错误重试次数：重新电话输入次数=2，按完电话按键后会跑到按键表【其他】的元件420。输入资料(号码，密码)存在c:\AG32\Tools\VMSLINK(n).TXT 以供执行程序元件420之用。

4.元件 420: 执行程序元件

将按键输入元件410所输入资料(号码，密码，储存在 \AG32\Tools\VMSLINK(n).TXT)，执行你自己写的程序以检查有无此会员，欠缴会费，产生\AG32\Tools\GOTOBOX(n).TXT(欠缴会费跑到元件 450，有此会员跑到元件 430，无此会员跑到元件 440 去执行)和\AG\Tools\VOICE(n).TXT(可使用次数，以供播放语音元件435用)

<设定>

【给外部程序之功能代码】：自行指定=420，用来辨別是那一个执行程序元件来要求执行其它程序，則 EXEREQ(n).TXT 内容如下：

420，xxxxxxx，dddddddd

xxxxxxx: 目前语音流程所在的目录(\AG32\tools经语言切换元件切换到不同系统语音目录)。

dddddddd: 跑到这个执行程序元件(Execution Box)的日期。

等待外部程序之时间(秒)=30，本系统检查 EXEACK(n).TXT 文件案是否存在的时間，超过这个等待秒数仍未发现 EXEACK(n).TXT 文件时，会跑到失败元件所设定的元件号码499去执行。

5.元件 435: 播放语音元件

经此元件后，播放 \AG32\Tools\VOICE(n).TXT (由执行程序元件 420 产生)所有语音文件，n代表电话线号，如VOICE3.TXT，代表第3条电话线。

<设定>

播放语音成功之后，跑到元件 455 去执行；播放语音失败之后，跑到元件号码0执行。

6.元件 47 0: 资料输入元件

接受电话按键，依照按键跳到所设定的元件，元件 470 播放\AG32\Tools\470.BOX\GREET1.GRT 语音时， 按 0 跳到元件460重听。


一般的语音查询应用

<电脑语音广场> 第7章 第三节 信息即时回报

7.3 信息即时回报的语音查询应用

信息变动较多的语音信息查询的应用，如股市成交的电话语音即时回报查询系统、银行存款余额的电话语音查询系统等，须配合执行使用者的程序，提供即时变动的语音信息。本节使用快速按键输入元件、执行程序元件、循环回路元件及中文转语音元件，来模拟一个股市成交电话语音即时回报的查询系统。

7.3.1 股市成交即时回报系统 [与外部程序沟通]

配合执行程序元件，您可用任何的程序语言，将由按键输入元件所输入的帐户号码(VMSLINK(n).TXT)，到您的数据库寻找是否成交的资料，经过播放语音元件，以即时提供成交即时回报的语音信息(VOICE(n).TXT)或修改数据库，您的程序只要做资料处理即可。以下修改上一节股市电话分析（会员制）的例子，成为一个股市成交电话语音即时回报的查询系统。

<步骤 1> 设定元件400为接电话元件

请执行语音软件生成器，用鼠标在左边显示的元件(语音元件一览表)选元件400，再在【系统设定】中选【设定为接电话元件】后，自动显示树状结构图如下：

<步骤 2> 修改410成为按键输入元件

用鼠标在左边显示的元件(语音元件一览表)，选所要设定的元件410后，按鼠标二下，进入功能设定.在【元件功能】右边按 选【按键输入元件】:

按【功能设定】，设定如下:

按【确定】。

在语音软件生成器，按 准备语音资料。按【录音】按钮，以录制「请输入帐戶号码的语音文件」，录完按【停止】后，储存成\AG32\tools\410.box\greet1.grt的语音文件，按【确定】。

<步骤 3> 修改你自己写的程序.

你可使用任何 Windows语言撰写自己写的程序，本节修改「外部程序设计」章节中的例子，成为一个股市成交电话语音即时回报的查询系统。

在使用手册「外部程序设计」章节中，使用四种程序语言(C，VB， for Visual Basic for Windows、Borland C、Builder 3.0、Delphi4.0详细说明了外部程序如何配合。

电话进来时，经过元件 410(按键输入元件)后，本系统会将所输入帐户号码存在 VMSLINK(n).TXT，经过元件 420(执行程序元件)时，将产生REQ(n).TXT通知外部程序，EXEREQ(n).TXT 内容为元件 420(执行程序元件所设的执行代码 420)。

外部程序一直检查有无 REQ(n).TXT，发现有REQ(n).TXT，开启Exereq(n).TXT，且内容为【给外部程序之功能代码】= 420 时，根据存在 VMSLINK(n).TXT 的所输入帐户号码，到自己数据库检查有无此帐户号码后，产生GOTOBOX(n).TXT，(GOTOBOX(n).TXT=430表有此帐户号码时跑到元件 430去执行，GOTOBOX(n).TXT=440表无此帐户号码时跑到元件 440 去执行)。和根据帐户号码，到您的数据库寻找其是否成交的资料，经过播放语音元件进行中文转语音，以即时提供成交即时回报的语音信息(VOICE(n).TXT)(成交的中文GB码)，以供中文转语音元件460播放成交语音之用。

外部程序执行完后，产生EXEACK(n).TXT 文件，通知系统已执行完，系统检查到EXEACK(n).TXT 文件后会根据GOTOBOX(n).TXT，到指定元件去执行，本系统产生REQ(n).TXT后，会一直检查 EXEACK(n).TXT 文件是否存在，若外部程序超过 30 秒(等待秒数 = 30)仍未产生EXEACK(n).TXT 文件时，本系统会跑到失败元件499去执行。

例如，第3条电话线打电话进来经过元件 410按键输入元件，在外部程序执行前的文件为 REQ3.TXT、EXEREQ3.TXT，VMSLINK3.TXT。若有此帐户号码，本程序执行完毕的文件为 GOTOBOX3.TXT、VOICE3.TXT、EXEACK3.TXT和 VMSLINK3.TXT。

GOTOBOX3.TXT: 内容为 430表有此帐户号码时，跑到元件 430 去执行。

VOICE3.TXT: 内容为成交的中文GB码，例如:王大杰，成交为中电56元，5张。

若无此帐户号码，本程序执行完毕的文件为GOTOBOX3.TXT、EXEACK3.TXT和VMSLINK3.TXT。

GOTOBOX(n).TXT: 内容为 440，表无此帐户号码时，跑到元件 440 去执行。

<步骤 4> 修改430循环回路功能

用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件430后，按鼠标二下，进入功能设定.核取是否计数，按【设定】原画面回归还所有计数器要保留，接着设定步骤三如下:按【确定】按钮。

<步骤 5> 修改460成为播放元件

用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件460后，按鼠标二下，进入功能设定，不选【播放招呼语】，在【元件功能型态】右边按 选【选播语音】，按【播放语音元件】，设定;按【确定】按钮。

<步骤 6>

状闭【语音软件生成器】，并执行【电话语音管理程序】中的【线上模拟】，即可模拟整套功能。

7.3.2 银行存款余额查询系统

本节使用按键输入元件、执行程序元件、循环回路元件和播放语音元件，[元件功能请参考第4章]来模拟一个银行存款余额的电话语音查询系统。配合执行程序元件，您可用任何的程序语言，将由按键输入元件所输入的存款帐户号码(VMSLINK(n).TXT)，到您的数据库寻找存款余额，经过播放语音元件，以即时提供语音信息(VOICE(n).TXT)或修改数据库。您的程序只要做资料处理即可!以下修改股市电话分析（会员制）的例子，成为一个银行存款余额的电话语音查询系统。

<步骤 1> 设定元件400为接电话元件.

请执行语音软件生成器，用鼠标在左边显示的元件(语音元件一览表)选一下，选元件400，再在【系统设定】中选【设定为接电话元件】后，自动显示树状结构图

<步骤 2> 修改410成为按键输入元件

在语音软件生成器按 准备语音资料，按【录音】按钮，以录制「请输入存款帐户号码」的语音文件，录完按【停止】后，储存成\AG32\Tools\410.box\greet1.grt的语音文件，按【确定】。

<步骤 3> 修改你自己写的程序.

你可使用任何Windows语言撰写自己写的程序，本节修改「外部程序设计」章节中的例子，成为一个银行存款余额的电话语音查询系统。

电话进来，经过元件 410(按键输入元件)后，本系统会将所输入存款帐户号码存在 VMSLINK(n).TXT，经过元件 420(执行程序元件)时，将产生REQ(n).TXT通知外部程序，EXEREQ(n).TXT 内容为元件 420(执行程序元件)所设的执行代码 420。外部程序一直检查有无REQ(n).TXT，发现有，再开啟EXEREQ(n).TXT，且内容为【给外部程序之功能代码】= 420 时，根据存在 VMSLINK(n).TXT 的所输入存款帐户号码，到自己数据库检查有无此存款帐户号码后，产生GOTOBOX(n).TXT，根据存款帐户号码，到您的数据库寻找其存款余额，产生VOICE(n).TXT (存款余额的中文GB码)，以供中文转语音元件460播放存款余额语音用。

外部程序执行完后产生EXEACK(n).TXT 文件，通知系统已执行完，系统检查到EXEACK(n).TXT 文件后会根据GOTOBOX(n).TXT，跑到那个元件去执行。本系统产生EXEREQ(n).TXT及REQ(n).TXT后，会一直检查 EXEACK(n).TXT 文件是否存在，外部程序超过 30 秒(等待秒数= 30)仍未产生EXEACK(n).TXT 文件时，本系统会跑到失败元件499去执行。

例如，第3条电话线打电话进来经过元件 410按键输入元件，在你自己写的程序执行前的文件为 EXEREQ3.TXT、REQ3.TXT、VMSLINK3.TXT。

若有此存款帐户号码，本程序执行完毕的文件为 GOTOBOX3.TXT

(内容为 430表有此存款帐户号码时，跑到元件 440 去执行)， VOICE3.TXT(内容为存款余额的中文GB码，例如:王大节，存款余额为561234元。)，EXEACK3.TXT， VMSLINK3.TXT。

若无此存款帐户号码，本程序执行完毕的文件为 GOTOBOX(n).TXT(内容为 440，表无此存款帐户号码时，跑到元件 440 去执行)，EXEACK3.TXT，VMSLINK3.TXT。

<步骤 4> 修改430循环回路元件

用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件430后，按鼠标二下，进入功能设定.核取是否计数，按【设定】原归还所有计数器要保留，接著设定步骤三;按【确定】按钮。

<步骤 5> 修改460成为播放语音元件

用鼠标在左边显示的元件(语音元件一览表)选所要设定的元件460后，按鼠标二下，进入功能设定，不选【播放招呼语】，在【元件功能型态】右边按 选【播放语音元件】，按【播放语音元件】，设定如下:

按【确定】按钮。

<步骤 6>

关闭【语音软件生成器】，并执行【电话语音管理程序】中的【线上模拟程序】，即可模拟整套功能。


电话语音信箱系统

<电脑语音广场> 第8章 电话语音信箱系统

第8章

电话语音信箱系统 （具体实施请参考:50AP\企业语音信箱系统）

电脑语音广场，架构各语音元件的树状关系网，不一定要写程序，即可产生一套电话语音信箱系统之应用，使用的语音元件有按键输入元件、留言元件、远端遥控元件等。在系统接电话后，可使用语言切换元件提供多种语言功能，经此元件后，切换到不同语言，如切换到英语、粤语或普通话等。电话语音信箱应用例子，有电话秘书、电话择友、语音信箱、自动总机等等。对于较复杂的应用，可配合外部程序以管理留言文件:

留言

1.使用执行程序元件:依照来电者在电话上所按的数字(VMSLINK(n).TXT)，执行自己的程序，找到对应的留言文件名，存在 VMSLINK(n).TXT，再到留言元件。

2.使用留言元件，设为【留言文件由VMSLINK(n).TXT提供】时，留言储存到在 VMSLINK(n).TXT语音文件名。

听取留言

1.使用执行程序元件:依照来电者在电话上所按的数字(VMSLINK(n).TXT)，执行自己的程序，找到对应的留言文 件名，存在 VMSLINK(n).TXT，再到只播放语音元件；或准备语音文件在 VOICE(n).TXT，再到播放语音元件。

2.只播放语音元件，播放招呼语设为【文件名称由VMSLINK(n).TXT提供】或播放语音元件，经此元件播放语音(语音文件在 VOICE(n).TXT）。